android-sdks / build-tools / 17.0.0 / aapt:加载共享库时出错:libz.so.1:无法打开共享目标文件:没有这样的文件或目录该怎么办?

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (2)
  • 关注 (0)
  • 查看 (151)

我刚安装了eclipse,android sdk和jdk,安装了64位的fedora 14,但是当我创建一个新项目时,我在控制台中收到以下错误消息:

android-sdks / build-tools / 17.0.0 / aapt:加载共享库时出错:libz.so.1:无法打开共享目标文件:没有这样的文件或目录

我使用的是64位机器,我需要安装一些32位驱动程序,所以我试图安装:

sudo apt-get install ia32-libs读取软件包列表...完成构建依赖关系树...完成E:找不到软件包ia32-libs

提问于
用户回答回答于

你可以尝试下这个吧:

sudo yum install zlib.i686 libstdc++.i686
用户回答回答于

运行Kubuntu 13.10(x64),我使用了lib32z1,它为我解决了这个问题:

sudo apt-get install lib32z1

所属标签

可能回答问题的人

  • 嗨喽你好

    7 粉丝480 提问8 回答
  • uncle_light

    5 粉丝518 提问7 回答
  • 富有想象力的人

    3 粉丝0 提问6 回答
  • 人生的旅途

    10 粉丝484 提问6 回答

扫码关注云+社区

领取腾讯云代金券