首页
学习
活动
专区
工具
TVP
发布

通达信议价转折点主图指标

指    标    源    码

公式源码:

M5:MA(C,5);

MB1:=EMA(WINNER(C)*100,5);

MB2:=EMA(MB1,2);

MB3:=EMA(MB2,2);

MB4:=EMA(MB3,2);

VAR2:=MB1;

DRAWKLINE(HIGH,OPEN,LOW,CLOSE);

VAR3:=DRAWLINE(VAR2>=HHV(VAR2,5)=1,VAR2,VAR2

DRAWTEXT_FIX(1,0.980,0,1,'缠论君QQ号:212265953'),COLOR666666;

顶G:=IF(VAR2=VAR3,VAR2,DRAWNULL);

XDG:=REF(VAR2,1)=REF(VAR3,1) AND VAR2>REF(VAR2,1);

买入条件:=TFILTER(XDG,顶G,1);

卖出条件:=TFILTER(顶G,XDG,0);

买入价:=IF(买入条件,C,DRAWNULL);

卖出价:=IF(卖出条件,C,DRAWNULL);

DRAWICON(买入条件,L,1);

DRAWICON(卖出条件,H*1.02,2);

DRAWNUMBER(买入条件,L,买入价),COLORRED;

DRAWNUMBER(买入条件,L*0.97,REF((H+L)/2,1)),COLORLIRED;

DRAWNUMBER(卖出条件,H,卖出价),COLORGREEN;

DRAWNUMBER(卖出条件,H*1.02,REF((H+L)/2,1)),COLORLIGREEN;

DRAWTEXT_FIX(C>O,0.01,0.81,0,'更多精彩指标公式,

请关注微信公众号:通达信指标公式'),COLORYELLOW;

Z1:=STRCAT(HYBLOCK,'');

Z2:=STRCAT(Z1,FGBLOCK);

Z3:=STRCAT(Z2,DYBLOCK);

Z4:=STRCAT(Z3,' ');

DRAWTEXT_FIX(ISLASTBAR,0.00,0.99,0,STRCAT(Z4,GNBLOCK)),COLORYELLOW;

  • 发表于:
  • 原文链接https://kuaibao.qq.com/s/20230211A0463Y00?refer=cp_1026
  • 腾讯「腾讯云开发者社区」是腾讯内容开放平台帐号(企鹅号)传播渠道之一,根据《腾讯内容开放平台服务协议》转载发布内容。
  • 如有侵权,请联系 cloudcommunity@tencent.com 删除。

扫码

添加站长 进交流群

领取专属 10元无门槛券

私享最新 技术干货

扫码加入开发者社群
领券