Hyperledger Fabric For Java 区块链框架-1

本文为Hyperledger Fabric For Java 区块链框架系列的第一篇文章, 主要讲述了使用Hyperledger Fabric需要做的一些前提准备.

Hyperledger Fabric运行需要cUrl和Docker !!!

Welcome To Read Hyperledger Fabric For Java Cours

安装cURL

如果尚未安装cURL工具或使用cCURL命令时遇到错误, 请下载最新版本的cURL(https://curl.haxx.se/download.html).

注意: 如果你使用的是Windows, 你可以安装使用Git来实现同样的效果.

安装Docker

这里需要主要下, Docker的版本最低17.06.2-ce

大致安装命令如下:

yum –y install docker.x86_64

yum –y install python-pip

pip install docker-compose

yum –y install npm

下载Hyperledger Fabric源码

这里我给出两种方法, Windows的用户可以使用Git的方法

第一种: cUrl

curl -sSL https://github.com/hyperledger/fabric/blob/master/scripts/bootstrap.sh | bash -s 1.1.0-rc1

第二种: Get

git clone -b master https://github.com/hyperledger/fabric-samples.git

cd fabric-samples

git checkout

为确保版本兼容, 需要与你的Fabric版本匹配, 例如v1.1.0-rc1. 要查看所有标签列表, 请使用命令"git tag".

学习资料

文档地址: https://godoc.org/github.com/hyperledger/fabric

JavaSDK: https://github.com/hyperledger/fabric-sdk-java

GitHub地址: https://github.com/hyperledger/fabric

  • 发表于:
  • 原文链接http://kuaibao.qq.com/s/20180306A0GH9T00?refer=cp_1026
  • 腾讯「云+社区」是腾讯内容开放平台帐号(企鹅号)传播渠道之一,根据《腾讯内容开放平台服务协议》转载发布内容。
  • 如有侵权,请联系 yunjia_community@tencent.com 删除。

扫码关注云+社区

领取腾讯云代金券