from selenium import webdriver报错

前几天电脑坏掉了,重装系统之后首要的一件事就是把以前用的些工具都装回来。当然最先装的Python,并把selenium环境配置好。把该安装的都装上之后,小小试了试,报错了

这个报错从提示上看,貌似可以怀疑我selenium没安装好,我使用的是pip install selenium 命令安装的方式,有返回安装成功,并且能查看到当前版本

其次可能会怀疑Chormedriver不兼容,要根据对应的浏览器版本取对应的浏览器驱动,很多配置环境的文章中只说了需要把chromedriver.exe放到对应的python安装目录中,但是我也曾经出现过莫名其妙的报错,把chromedriver.exe也保存到chrome的安装目录中才解决问题。这次不是这原因

还有一个地方需要注意,这也是广大配置环境的文章中并不会专门去提及的。pycharm IDE需要找到正确的python版本。这里的报错就是这个原因。

重新选择即可。

  • 发表于:
  • 原文链接http://kuaibao.qq.com/s/20180423G1GLJG00?refer=cp_1026
  • 腾讯「云+社区」是腾讯内容开放平台帐号(企鹅号)传播渠道之一,根据《腾讯内容开放平台服务协议》转载发布内容。

扫码关注云+社区

领取腾讯云代金券