TensorFlow 1.7.1 发布,修复了一些潜在的安全问题

TensorFlow 1.7.1 已释出,发布说明显示该版本修复了一些潜在的安全问题:

  • 从 TFLite 文件中的某些字段进行读取时,TensorFlow Lite TOCO 编译器不执行正确的边界检查
  • 元文件中的块大小可能包含一个大的 int64 值,这会导致在添加时发生整数溢出。后续使用 n 作为索引的代码可能会导致读取超出边界
  • TensorFlow 检查点元文件使用 Google 的 https://github.com/google/snappy 压缩/解压缩库,而 TensorFlow 当前使用的 snappy 版本存在 memcpy-param 重叠问题
  • 传递到 TensorFlow XLA 编译器的恶意制作的配置文件可能导致无效的内存访问,或同时出现堆缓冲区溢出的情况

可以看到,其中涉及到一些边界条件判断、内存溢出等问题。

源码下载

  • 发表于:
  • 原文链接:https://www.oschina.net/news/95777/tensorflow-1-7-1-released

扫码关注云+社区

领取腾讯云代金券