近 300 个 macOS 应用有兼容性问题,苹果要背这个锅

Photoshop, Matlab, Panic Transmit 和 Eclipse 有什么共同之处?看上去它们之间毫无联系,事实上,这几个 macOS 应用程序都是需要进行兼容性修复的 299 个应用程序的其中一部分。

近日,有开发者发文表示,有 299 个应用程序运行于较新版本的 macOS 系统上存在兼容性方面的问题,并指出,即使是最好的应用程序在较新版本的 macOS 上运行,通常也需要进行一些调整。另外,大多数这些兼容性补丁只适用于旧版本的应用程序。

其中,苹果自家的应用也有出现在这份名单上,据统计有 64 个,这也是意料之中的,毕竟苹果可能会用到一些第三方不能使用的私有 API 和技巧,这都会导致出现兼容性问题。

下面是一些相关的应用程序列表。

来自大公司的生产力工具:

  • most of the Adobe suite
  • the Microsoft Office suite
  • Autodesk’s AutoCAD and Maya
  • Matlab
  • Ableton Live
  • Intuit Quicken/QuickBooks
  • TurboCAD
  • VMWare Fusion

通讯应用:

  • Google Chrome
  • Opera Browser
  • Twitter for Mac
  • Tencent QQ, WeChat
  • AOL Messenger
  • Citrix GoToMeeting
  • Cisco Spark
  • HipChat
  • Sketch
  • Spotify
  • Evernote
  • Dropbox

游戏类:

  • Blizzard’s games: installer, Diablo 3, Heroes of the Storm, Starcraft 2, World of Warcraft, Hearthstone, and Battle.NET
  • Grid 2 Reloaded
  • Dragon Age 2 (of course)

开源应用:

  • Firefox
  • VLC
  • Blender
  • Eclipse
  • AquaMacs (an Emacs port)
  • OpenJDK
  • Textual IRC

独立应用:

  • Panic’s Coda and Transmit
  • Omni Group’s OmniFocus, OmniGraffle, OmniPlan, and OmniWeb
  • Sketch
  • 1Password
  • BBEdit/TextWrangler

设备驱动:

  • Garmin TrainingCenter
  • Epson xp640
  • HP Installer
  • Fujitsu ScanSnap

Apple 内部 apps:

  • com.apple.ist.Merlin
  • com.apple.ist.Radar7 (probably the most ironic)
  • com.apple.ist.SoftwareDepot.Checker
  • com.apple.ist.appledirectory4
  • com.apple.ist.hr.Merlin

更多应用可点此查看:https://worthdoingbadly.com/assets/blog/appkitcompat/appkit_processed.html

  • 发表于:
  • 原文链接:https://www.oschina.net/news/96310/macos-apps-are-so-buggy-apple-fixes-them-in-appkit

扫码关注云+社区

领取腾讯云代金券