hdp安装及使用问题汇总(一)

1)安装HDP时,如果打印如下错误信息:

是由于系统的python版本过高,导致验证ssl失败,将python降级为2.7.5以下或修改每个安装节点的python证书验证配置文件,执行以下命令修改:

我通过修改每个节点上的verification.cfg文件解决该问题,还可以参考以下解决办法:

https://community.hortonworks.com/articles/68799/steps-to-fix-ambari-server-agent-expired-certs.html

https://community.hortonworks.com/questions/120861/ambari-agent-ssl-certificate-verify-failed-certifi.html

2)使用Ambari安装HDP时,如果在某一步耗时过长,需要刷新浏览器,重新之前的步骤,不然可能一直卡在某一步导致安装进行不下去。

3)配置本地yum源时,如果使用repo模板文件,记得将无关的yum源配置删除,只配置需要安装的软件的yum源,否则执行yum install时会失败。

4)如果yum源通过http方式访问,需要确保/var/www/html/目录下的文件有访问权限,否则在安装HDP时,注册和确认节点会出现访问不到yum源导致安装失败。

5)导入SSH Private Key 时,可以直接将id_rsa文件内容复制粘贴到输入框即可,不需要选择文件然后导入。

6)当注册和确认节点失败时,一般是由于yum源配置错误或缺少依赖的安装包如libtirpc-devel-0.2.4-0.10.el7.x86_64.rpm导致,按提示解决即可。

7)如果yum源通过http方式访问,需要确保/var/www/html/目录有下列文件夹且包含了相应的软件安装包:

ambari:安装ambari相关软件

centos74:安装操作系统相关软件

HDP:安装HDP相关软件

HDP-UTILS-1.1.0.21:安装HDP相关工具软件

mysql:安装mysql相关软件

另外,在/etc/yum.repos.d/目录要有以上5个软件包的yum源配置。

8)安装完java,在设置java相关PATH环境变量时,切记将java的环境变量放在PATH前面,如果放在后面,会使用系统默认安装的java版本,PATH顺序导致的问题我遇到过好几次了,有时候很难定位,所以安装新软件后,如果系统已经安装了其他版本的软件,切记设置PATH时将使用的bin放置在前面,例如:

错误的方式:

正确的方式:

  • 发表于:
  • 原文链接https://kuaibao.qq.com/s/20180730G0PHGT00?refer=cp_1026
  • 腾讯「云+社区」是腾讯内容开放平台帐号(企鹅号)传播渠道之一,根据《腾讯内容开放平台服务协议》转载发布内容。

扫码关注云+社区

领取腾讯云代金券