Ghostscript中的关键缺陷可能使许多系统面临黑客攻击的风险

Google Project Zero的安全研究人员在Ghostscript中发现了一个关键的远程代码执行(RCE)漏洞 - 一个用于Adobe Systems的PostScript和PDF页面描述语言的开源解释器。 Ghostscript完全用C语言编写,是一个在不同平台上运行的软件包,包括Windows,macOS和各种Unix系统,使软件能够将PostScript语言文件(或EPS)转换为许多光栅格式,例如: PDF,XPS,PCL或PXL。 许多流行的PDF和图像编辑软件,包括ImageMagick和GIMP,都使用Ghostscript库来解析内容并转换文件格式。 Ghostscript套件包含一个内置的-dSAFER沙箱保护选项,可以处理不受信任的文档,防止执行不安全或恶意的PostScript操作。 但是,Google Project Zero团队研究员Tavis Ormandy发现Ghostscript包含多个-dSAFER沙箱绕过漏洞,这可能允许远程未经身份验证的攻击者在易受攻击的系统上执行任意命令。 要利用此漏洞,攻击者需要做的就是向受害者发送特制的恶意文件(可能是PDF,PS,EPS或XPS),如果使用易受攻击的Ghostscript的应用程序打开,则可以允许攻击者完全接管目标系统。 在撰写本文时,Ghostscript的维护者Artifex Software尚未发布任何补丁来修复漏洞。 根据US-CERT发布的咨询报告,像ImageMagick图像处理库这样的应用程序(默认情况下使用Ghostscript处理PostScript内容)会受到漏洞的影响。 包括RedHat和Ubuntu在内的主要Linux发行版已确认它们也受此漏洞的影响,而Arch Linux,CentOS,Debian,Dell,Apple等的状态仍然未知。 Ormandy建议Linux发行版禁用PS,EPS,PDF和XPS内容的处理,直到问题得到解决。

“我强烈建议默认情况下,发行版会在policy.xml中开始禁用PS,EPS,PDF和XPS编码器,”Ormandy表示。

这不是Ormandy第一次在Ghostscript中发现问题。他在2016年10月和去年4月(CVE-2017-8291)的Ghostscript中发现了类似的高严重性漏洞,其中一些漏洞在外界被发现。

  • 发表于:
  • 原文链接https://thehackernews.com/2018/08/ghostscript-postscript-vulnerability.html
  • 如有侵权,请联系 yunjia_community@tencent.com 删除。

扫码关注云+社区

领取腾讯云代金券