Python3.4 安装 pycrypto 提示错误的处理办法

公众号回复「送书」,了解送书活动

阅读本文大概需要 4.3 分钟。

今天做接口测试,有个接口的参数使用了 AES 加密,开发提供了加密函数的实现,但是 Python2.6 实现的,我习惯使用的是 Python3.4,于是准备做下兼容处理,本以为很简单,结果发现安装 pycrypto 库会报错。

作为测试,定位问题并解决问题乃是我们的强项,于是花了点时间把问题处理了,顺便把解决的结果做个记录,如果后面有同学碰到同样的问题,也不用重复踩坑了。

先看看我安装库用的命令行:

下面是报错信息中的关键部分:

从报错信息看,就是缺少依赖库文件,确实,我机器上安装的是 VS2008,因为用的少一直没更新,但是提示的是需要 VS2010 支持,总不能因为装一个库,我就去装一个大得多的 VS2010 吧,所以:

方法一:安装 VS2010,然后设置环境变量

先放弃,实在找不到方法再说。

继续 Google 后,发现有同学提供了新的方案:

方法二:卸载 crypto 库后重新安装 pycrypto

根据说明依次执行如下命令行:

错误依旧,报错信息也是一字没改,方法无效

继续看其他方案:

方法三:升级下 setuptools

我也没搞懂这和我的问题有啥关系,但是升级下也没坏处,升,依次执行如下命令:

错误依旧,报错信息也是一字没改,方法无效

眼瞅着要回头去找 VS2010 安装包了,突然发现有人找到了这个库编译好的 exe 安装包,赞,果然还是那句话「有需求的地方,就有人去满足」,就看你能不能找得到了。

方法四:安装 pycrypto 编译好的 exe 安装包

安装包地址:

http://www.voidspace.org.uk/python/pycrypto-2.6.1/pycrypto-2.6.1.win32-py3.4.exe

亲测有效,问题解决。

另外,记得到 Python 安装目录下 \Lib\site-packages 去看下,如果 crypto 是全小写就改成 Crypto,不然引入会报错。

附上引入代码:

  • 发表于:
  • 原文链接https://kuaibao.qq.com/s/20180822G0O6BK00?refer=cp_1026
  • 腾讯「云+社区」是腾讯内容开放平台帐号(企鹅号)传播渠道之一,根据《腾讯内容开放平台服务协议》转载发布内容。
  • 如有侵权,请联系 yunjia_community@tencent.com 删除。

扫码关注云+社区

领取腾讯云代金券