解决php在ubuntu报 no version information available

今天网超卡的,

打个游戏都卡飞了,

啊西八,王者掉了3颗星,

难受!!!

哎,网卡那就撸撸码吧,

可是!

$ php -v

php: /usr/local/openssl/lib/libcrypto.so.1.0.0: no version information available (required by php)

php: /usr/local/openssl/lib/libcrypto.so.1.0.0: no version information available (required by php)

php: /usr/local/openssl/lib/libcrypto.so.1.0.0: no version information available (required by php)

php: /usr/local/openssl/lib/libcrypto.so.1.0.0: no version information available (required by /lib/x86_64-linux-gnu/libssl.so.1.0.0)

php: /usr/local/openssl/lib/libcrypto.so.1.0.0: no version information available (required by /lib/x86_64-linux-gnu/libssl.so.1.0.0)

php: /usr/local/openssl/lib/libcrypto.so.1.0.0: no version information available (required by /lib/x86_64-linux-gnu/libssl.so.1.0.0)

php: /usr/local/openssl/lib/libcrypto.so.1.0.0: no version information available (required by /lib/x86_64-linux-gnu/libssl.so.1.0.0)

php: /usr/local/openssl/lib/libcrypto.so.1.0.0: no version information available (required by /usr/local/curl/lib/libcurl.so.4)

PHP 7.2.11 (cli) (built: Oct 23 2018 16:18:54) ( NTS )

Copyright (c) 1997-2018 The PHP Group

Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies

with Zend OPcache v7.2.11, Copyright (c) 1999-2018, by Zend Technologies

这鬼东西我已经忍你很久了,

在有虚拟机的时候老是出现这个,

这原以为只有我本地虚拟机会,

本来不想管它的,

没想到我的服务器上也会,

啊西八,

重装n次和换php版本都不行,

好气啊!

找了好久,

最后终于在网上找到了解决办法,

方法就是什么报错删什么

$ sudo rm /usr/local/openssl/lib/libssl.so.1.0.0

$ sudo rm /usr/local/openssl/lib/libcrypto.so.1.0.0

问题是解决了,

但是不知道这是什么原因!

这让我有点小难受啊。

还是记录一下吧,

至少把碍事的问题解决了!

  • 发表于:
  • 原文链接https://kuaibao.qq.com/s/20181027G0AH2400?refer=cp_1026
  • 腾讯「云+社区」是腾讯内容开放平台帐号(企鹅号)传播渠道之一,根据《腾讯内容开放平台服务协议》转载发布内容。
  • 如有侵权,请联系 yunjia_community@tencent.com 删除。

扫码关注云+社区

领取腾讯云代金券