学习
实践
活动
专区
工具
TVP
写文章

Spring Boot 2.4 版本的系统运行要求

Spring Boot 2.4.2-SNAPSHOT 版本要求至少 Java 8 及其以上版本,目前最高能够支持到 Java 15 (包含 15)的版本。Spring 框架(Framework) 5.3.2 的版本或者以上的版本是必须的。

能够被下面的编译工具支持:

Servlet 容器

Spring Boot 能够支持下面的嵌入 Servlet 容器版本:

当然,你也可以将 Spring Boot 应用部署到任何能够兼容 3.1+ 容器版本的服务器上。

Servlet 的版本比较重要,针对不同的应用服务器版本,支持的 Servlet 的版本也是不同的。很多时候不同的 Servlet 版本之间会出现兼容性问题。

所以如果你的 Spring Boot 的版本比较高的话,如果你使用是运行容器部署方式,不是使用 Spring Boot 内置的应用服务器,你需要在这里考虑 Servlet 的版本兼容性问题。

Spring Boot 是基于 Java 环境的,因此不管怎么配置,Spring Boot 都需要你已经正确的配置了 JDK。JDK 的环境是必须的,而且版本也是有一定要求的。

当前 JDK 的主流版本是 8,所以基本上能够满足你的要求。

  • 发表于:
  • 原文链接https://kuaibao.qq.com/s/20201231A00RDI00?refer=cp_1026
  • 腾讯「腾讯云开发者社区」是腾讯内容开放平台帐号(企鹅号)传播渠道之一,根据《腾讯内容开放平台服务协议》转载发布内容。
  • 如有侵权,请联系 cloudcommunity@tencent.com 删除。

关注

腾讯云开发者公众号
10元无门槛代金券
洞察腾讯核心技术
剖析业界实践案例
腾讯云开发者公众号二维码

扫码关注腾讯云开发者

领取腾讯云代金券