一款下单软件

这是小编的第篇文章,大家多多关照哦!!!

给大家带来一款易语言开发的下单软件最重要的是开源!!!这套程序是小编从网上找到的,也经过小编自己摸索着易语言的一点点知识改过。当时打算好好开放这套程序但是找到曾今买的那本《中文编程 从入门到精通》,先是翻开目录看了看。好,进入第一章。

前面的什么安装教程也就直接跳过了,我也相信那些我自己可以摸索得到。就直接看到了这个 信息框(信息框1.内容,0,)刚开始看到这个一点都不理解也没有详细的说明注释,直到看到一个实例才理解。唉!

我们直奔主题这软件的部分代码:

.版本 2

.支持库 spec

.支持库 iext

客户ip = 服务器1.取回客户 ()

数据 = 到文本 (服务器1.取回数据 ())

分割 = 分割文本 (数据, #分割符3, )

.如果真 (功能集_是否被攻击 (数据, 取数组成员数 (分割)) = 真)

功能集_发送消息给客户 (客户ip, “请不要恶意更改本软件,一经发现,永久IP封号处理。”)

返回 ()

.如果真结束

jc = 0

jc1 = 0

调试输出 (数据)

.如果真 (分割 [2] ≠ “”)

' -------------------------------------注册------------------------------------

.如果真 (分割 [1] = #注册头)

.如果 (寻找文本 (注册黑名单.内容, 分割 [2], , 假) = -1)

.计次循环首 (全体用户列表框.取表项数 (), jc)

.如果真 (分割 [2] = 全体用户列表框.取标题 (jc - 1, 0))

cz = 真

跳出循环 ()

.如果真结束

.计次循环尾 ()

.如果 (cz = 真)

功能集_发送消息给客户 (客户ip, “萌萌的服务君提示您:” + #换行符 + #换行符 + “该用户名已经被别人注册了,请重新注册!”)

.否则

表项 = 全体用户列表框.插入表项 (-1, 分割 [2], , , , )

全体用户列表框.置标题 (表项, 1, 分割 [3])

全体用户列表框.置标题 (表项, 2, “0”)

全体用户列表框.置标题 (表项, 3, 分割 [4])

全体用户列表框.置标题 (表项, 4, 分割 [5])

功能集_发送消息给客户 (客户ip, “可爱的恶龙提示您:” + #换行符 + #换行符 + “账号注册成功!”)

功能集_保存用户数据库 ()

功能集_写日志 (分割 [2] + “注册为新用户”)

.如果结束

.否则

功能集_发送消息给客户 (客户ip, “可爱的恶龙提示您:” + #换行符 + #换行符 + “(¬︿??¬)你的用户名名是系统禁止注册的!”)

.如果结束

返回 ()

.如果真结束

' -------------------------------------登录------------------------------------

.如果真 (分割 [1] = #登录头)

.如果 (寻找文本 (登陆黑名单.内容, 分割 [2], , 假) = -1)

.计次循环首 (全体用户列表框.取表项数 (), jc)

.如果真 (分割 [2] = 全体用户列表框.取标题 (jc - 1, 0))

用户索引 = 1 ' 有这个用户名

.如果 (分割 [3] = 全体用户列表框.取标题 (jc - 1, 1))

.如果真 (全体用户列表框.取标题 (jc - 1, 5) = “真”)

功能集_发送消息给客户 (客户ip, “您的账号已被冻结,暂时无法登录。”)

延迟 (100)

返回 ()

.如果真结束

服务器1.发送数据 (客户ip, #登录头 + #分割符3 + 到文本 (取文本长度 (分割 [2])) + #分割符3 + 到文本 (取文本长度 (分割 [2]) ÷ 3.1415926), 1)

表项 = 在线用户列表框.插入表项 (-1, 客户ip, , , , )

在线用户列表框.置标题 (表项, 1, 分割 [2])

延迟 (100)

服务器1.发送数据 (客户ip, #用户信息 + #分割符3 + 全体用户列表框.取标题 (jc - 1, 0) + #分割符3 + 全体用户列表框.取标题 (jc - 1, 3) + #分割符3 + 全体用户列表框.取标题 (jc - 1, 2), ) ' 名称 邮箱 余额 三个信息

功能集_写日志 (“用户” + 分割 [2] + “登录成功!”)

.否则

服务器1.发送数据 (客户ip, #登录头 + #分割符3 + “sb” + #分割符3 + “0”, 1)

功能集_发送消息给客户 (客户ip, “( - ) 求求您!~请不要瞎输入账号好不好啊?”)

.如果结束

跳出循环 ()

.如果真结束

.计次循环尾 ()

.如果真 (用户索引 ≠ 1)

功能集_发送消息给客户 (客户ip, “您的用户名是不是输错了?”)

.如果真结束

返回 ()

.否则

功能集_发送消息给客户 (客户ip, “可爱的恶龙提示您:” + #换行符 + #换行符 + “(¬︿??¬)你的用户名名是系统禁止登陆的!”)

.如果结束

返回 ()

.如果真结束

.如果真 (分割 [1] = #充值头)

.计次循环首 (充值卡号管理.取表项数 (), jc)

.如果真 (分割 [2] = 充值卡号管理.取标题 (jc - 1, 0))

cz = 真

余额 = 到整数 (充值卡号管理.取标题 (jc - 1, 3))

.如果 (余额 = 0)

功能集_发送消息给客户 (客户ip, “抱歉,您提供的卡密没有余额哦!”)

.否则

.计次循环首 (全体用户列表框.取表项数 (), jc1)

.如果真 (分割 [3] = 全体用户列表框.取标题 (jc1 - 1, 0))

全体用户列表框.置标题 (jc1 - 1, 2, 到文本 (到整数 (全体用户列表框.取标题 (jc1 - 1, 2)) + 余额))

充值卡号管理.置标题 (jc - 1, 3, “0”)

充值卡号管理.置标题 (jc - 1, 4, 分割 [3])

充值卡号管理.置标题 (jc - 1, 2, 功能集_取时间 ())

调试输出 (jc)

功能集_发送余额 (客户ip, 全体用户列表框.取标题 (jc1 - 1, 2))

功能集_写日志 (“用户” + 分割 [3] + “充值了” + 到文本 (余额) + “元”)

功能集_保存用户数据库 ()

功能集_发送消息给客户 (客户ip, “充值成功,您共充值了:” + 到文本 (余额) + “ 当前余额为:” + 全体用户列表框.取标题 (jc1 - 1, 2) + “元”)

跳出循环 ()

.如果真结束

.计次循环尾 ()

跳出循环 ()

.如果结束

.如果真结束

.计次循环尾 ()

.如果真 (cz ≠ 真)

功能集_发送消息给客户 (客户ip, “抱歉,您提供的卡密无效。”)

.如果真结束

返回 ()

.如果真结束

.如果真 (分割 [1] = #获取商品头)

.如果真 (功能集_发送商品目录 (客户ip) = 假)

功能集_发送消息给客户 (客户ip, “可爱的恶龙订单君提示您:对不起呢。。。获取订单内容失败!”)

.如果真结束

返回 ()

.如果真结束

.如果真 (分割 [1] = #购买头)

商品编号 = 分割 [3]

.计次循环首 (商品管理.取表项数 (), jc1)

.如果真 (商品管理.取标题 (jc1 - 1, 0) = 商品编号)

商品索引 = jc1 - 1

' 调试输出 (商品索引)

跳出循环 ()

.如果真结束

.计次循环尾 ()

商品价格 = 到整数 (商品管理.取标题 (商品索引, 2))

商品数量 = 到整数 (商品管理.取标题 (商品索引, 4))

商品类型 = “”

.如果真 (寻找文本 (商品管理.取标题 (商品索引, 1), #卡密类标识, , 假) ≠ -1)

商品类型 = “卡密类”

.如果真结束

' 调试输出 (商品编号)

.计次循环首 (全体用户列表框.取表项数 (), jc)

.如果真 (分割 [2] = 全体用户列表框.取标题 (jc - 1, 0))

用户余额 = 到整数 (全体用户列表框.取标题 (jc - 1, 2))

用户索引 = jc - 1

跳出循环 ()

.如果真结束

.计次循环尾 ()

' 调试输出 (商品价格)

' 调试输出 (用户余额)

.如果 (商品管理.取标题 (商品索引, 5) = “真”)

功能集_发送消息给客户 (客户ip, “对不起,您购买的商品已经被商家冻结,请购买其他商品。”)

.否则

调试输出 (商品类型)

.如果 (商品数量 > 0)

.如果 (商品类型 = “卡密类”)

.如果 (用户余额 - 商品价格 ≥ 0)

商品管理.置标题 (商品索引, 4, 到文本 (到整数 (商品管理.取标题 (商品索引, 4)) - 1))

全体用户列表框.置标题 (用户索引, 2, 到文本 (用户余额 - 商品价格))

' -----------------------------------------购买成功后给用户商品的代码加在这里 呃...还有就是要处理订单什么的也要写在这里。用户订单下次写吧。。马上就要下课了。

当前订单号 = 时间_格式化 (取现行时间 (), “yyyyMd”, “Hmmss”) + 全体用户列表框.取标题 (用户索引, 0) + 到文本 (商品索引)

用户订单数据 = 到文本 (读入文件 (取运行目录 () + “\user\” + 全体用户列表框.取标题 (用户索引, 0)))

未处理的订单 = 当前订单号 + #分割符2 + 商品管理.取标题 (商品索引, 1) + #分割符2 + “1” + #分割符2 + 功能集_取时间 () + #分割符2 + 功能集_获取卡密 (商品索引) + #分割符1

用户订单数据 = 用户订单数据 + 未处理的订单

' 功能集_添加未处理订单 (全体用户列表框.取标题 (用户索引, 0) + #分割符2 + 未处理的订单)

写到文件 (取运行目录 () + “\user\” + 全体用户列表框.取标题 (用户索引, 0), 到字节集 (用户订单数据))

' -----------------------------------------购买成功后给用户商品的代码加在这里

功能集_发送消息给客户 (客户ip, “恭喜您!购买成功。您购买的为卡密类型商品,请点击我的订单查询卡密。”)

功能集_保存商品数据库 () ' 程序过卡时可以不要

功能集_保存用户数据库 ()

延迟 (100)

功能集_发送余额 (客户ip, 全体用户列表框.取标题 (用户索引, 2))

.否则

功能集_发送消息给客户 (客户ip, “对不起呢,您的余额不足,购买失败!”)

.如果结束

.否则

.如果 (用户余额 - 商品价格 > 0)

商品管理.置标题 (商品索引, 4, 到文本 (到整数 (商品管理.取标题 (商品索引, 4)) - 1))

全体用户列表框.置标题 (用户索引, 2, 到文本 (用户余额 - 商品价格))

' -----------------------------------------购买成功后给用户商品的代码加在这里 呃...还有就是要处理订单什么的也要写在这里。用户订单下次写吧。。马上就要下课了。

当前订单号 = 时间_格式化 (取现行时间 (), “yyyyMd”, “Hmmss”) + 全体用户列表框.取标题 (用户索引, 0) + 到文本 (商品索引)

用户订单数据 = 到文本 (读入文件 (取运行目录 () + “\user\” + 全体用户列表框.取标题 (用户索引, 0)))

未处理的订单 = 当前订单号 + #分割符2 + 商品管理.取标题 (商品索引, 1) + #分割符2 + “1” + #分割符2 + 功能集_取时间 () + #分割符2 + 分割 [4] + #分割符1

用户订单数据 = 用户订单数据 + 未处理的订单

功能集_添加未处理订单 (全体用户列表框.取标题 (用户索引, 0) + #分割符2 + 未处理的订单)

写到文件 (取运行目录 () + “\user\” + 全体用户列表框.取标题 (用户索引, 0), 到字节集 (用户订单数据))

' -----------------------------------------购买成功后给用户商品的代码加在这里

功能集_发送消息给客户 (客户ip, “恭喜您!购买成功。”)

功能集_保存商品数据库 ()

' 功能集_保存商品数据库 () ' 程序过卡时可以不要

功能集_保存用户数据库 ()

延迟 (100)

功能集_发送余额 (客户ip, 全体用户列表框.取标题 (用户索引, 2))

.否则

功能集_发送消息给客户 (客户ip, “对不起呢,您的余额不足,购买失败!”)

.如果结束

.如果结束

.否则

功能集_发送消息给客户 (客户ip, “sorry:商品剩余库存不足,购买失败!”)

.如果结束

.如果结束

返回 ()

.如果真结束

.如果真 (分割 [1] = #获取订单头)

功能集_发送客户订单 (客户ip, 分割 [2])

返回 ()

.如果真结束

.如果真 (分割 [1] = #提交建议)

调试输出 (写到文件 (取运行目录 () + “\jianyi\” + 时间_格式化 (取现行时间 (), “yyyyMd”, “Hmmss”) + “建议.txt”, 到字节集 (分割 [2])))

调试输出 (取运行目录 () + “\jianyi\” + 功能集_取时间 () + “.txt”)

返回 ()

.如果真结束

.如果真 (分割 [1] = #更改密码头)

.计次循环首 (全体用户列表框.取表项数 (), jc)

.如果真 (全体用户列表框.取标题 (jc - 1, 0) = 分割 [2])

用户索引 = jc - 1

.如果真 (全体用户列表框.取标题 (用户索引, 3) = 分割 [4] 且 全体用户列表框.取标题 (用户索引, 4) = 分割 [5])

cz = 真

.如果真结束

.如果 (cz = 真)

商品编号 = “ZHMM” + 到文本 (取随机数 (123, 123456)) + 文本_取随机字母 (10, 2) ' 这里是找回密码的验证,并非商品编号

写到文件 (取运行目录 () + “\zh\” + 分割 [2], 到字节集 (商品编号))

' 连接发信服务器 (#邮箱地址, 25, #邮箱账号, #邮箱密码, )

功能集_发送消息给客户 (客户ip, “” + 商品编号 + “找回成功,口令已经复制到您的剪辑版,请妥善保存”)

.否则

功能集_发送消息给客户 (客户ip, “找回密码失败,请确保您输入的信息是否正确。”)

.如果结束

跳出循环 ()

.如果真结束

.计次循环尾 ()

返回 ()

.如果真结束

.如果真 (分割 [1] = #找回密码头)

.如果 (到文本 (读入文件 (取运行目录 () + “\zh\” + 分割 [2])) = 分割 [3])

.计次循环首 (全体用户列表框.取表项数 (), jc)

.如果真 (全体用户列表框.取标题 (jc - 1, 0) = 分割 [2])

用户索引 = jc - 1

跳出循环 ()

.如果真结束

.计次循环尾 ()

全体用户列表框.置标题 (用户索引, 1, 分割 [4])

文件_删除 (取运行目录 () + “\zh\” + 分割 [2])

功能集_保存用户数据库 ()

' 调试输出 (“正在车上”)

功能集_发送消息给客户 (客户ip, “恭喜您的账号:” + 分割 [2] + “ ,新密码设置成功。”)

.否则

功能集_发送消息给客户 (客户ip, “抱歉,您提供的信息不符。”)

.如果结束

' 调试输出 (“正在车上”)

来看看图片

客户端呢就不介绍了,有喜欢的联系小编哦

  • 发表于:
  • 原文链接:http://kuaibao.qq.com/s/20180201G01ME300?refer=cp_1026

相关快讯

扫码关注云+社区