升级ES集群版本

最近更新时间:2019-07-24 15:19:04

1. 接口描述

接口请求域名: es.tencentcloudapi.com 。

升级ES集群版本

默认接口请求频率限制:20次/秒。

注意:本接口支持金融区地域。由于金融区和非金融区是隔离不互通的,因此当公共参数 Region 为金融区地域(例如 ap-shanghai-fsi)时,需要同时指定带金融区地域的域名,最好和 Region 的地域保持一致,例如:es.ap-shanghai-fsi.tencentcloudapi.com。

2. 输入参数

以下请求参数列表仅列出了接口请求参数和部分公共参数,完整公共参数列表见 公共请求参数

参数名称 必选 类型 描述
Action String 公共参数,本接口取值:UpgradeInstance
Version String 公共参数,本接口取值:2018-04-16
Region String 公共参数,详见产品支持的 地域列表
InstanceId String 实例ID
EsVersion String 目标ES版本
CheckOnly Boolean 是否只做升级检查,默认值为false
LicenseType String 目标商业特性版本:
  • oss 开源版
  • basic 基础版
  • 当前仅在5.6.4升级6.x版本时使用,默认值为basic

    3. 输出参数

    参数名称 类型 描述
    RequestId String 唯一请求 ID,每次请求都会返回。定位问题时需要提供该次请求的 RequestId。

    4. 示例

    示例1 升级ES集群版本

    输入示例

    https://es.tencentcloudapi.com/?Action=UpgradeInstance
    &InstanceId=es-4texbn20
    &EsVersion=6.4.3
    &<公共请求参数>

    输出示例

    {
      "Response": {
        "RequestId": "c96a110c-7493-452d-a99b-683d0711dada"
      }
    }

    5. 开发者资源

    API Explorer

    该工具提供了在线调用、签名验证、SDK 代码生成和快速检索接口等能力,能显著降低使用云 API 的难度,推荐使用。

    SDK

    云 API 3.0 提供了配套的开发工具集(SDK),支持多种编程语言,能更方便的调用 API。

    命令行工具

    6. 错误码

    以下仅列出了接口业务逻辑相关的错误码,其他错误码详见 公共错误码

    错误码 描述
    FailedOperation.NoPayment 账户未绑定信用卡或paypal,无法支付。
    InternalError 内部错误。
    InvalidParameter 参数错误。
    ResourceInUse 资源被占用。
    ResourceInsufficient 资源不足。
    ResourceInsufficient.Balance 账户余额不足。
    UnsupportedOperation 操作不支持。