前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDU 1102 Constructing Roads(Kruskal)

HDU 1102 Constructing Roads(Kruskal)

作者头像
ShenduCC
发布2018-04-26 16:55:46
4260
发布2018-04-26 16:55:46
举报
文章被收录于专栏:算法修养

Constructing Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 19432    Accepted Submission(s): 7404

Problem Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.  We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum. 

Sample Input

代码语言:javascript
复制
3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

代码语言:javascript
复制
179
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>

using namespace std;
int n;
int a;
int q;
int b,c;
struct Node
{
    int x;
    int y;
    int w;
}edge[105*105];
int father[105];
int cmp(Node a,Node b)
{
    return a.w<b.w;
}
int find(int x)
{
    if(x!=father[x])
        x=find(father[x]);
    return x;
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=1;i<=n;i++)
            father[i]=i;
        int cot=0;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
            {
                scanf("%d",&a);
                if(i==j)
                    continue;
                edge[cot].x=i;
                edge[cot].y=j;
                edge[cot++].w=a;
            }
        scanf("%d",&q);
        for(int i=1;i<=q;i++)
        {
            scanf("%d%d",&b,&c);
            b=find(b);
            c=find(c);
            father[b]=c;
        }
        sort(edge,edge+cot,cmp);
        int ans=0;
        for(int i=0;i<cot;i++)
        {
            int xx=edge[i].x;
            int yy=edge[i].y;
            xx=find(xx);
            yy=find(yy);
            if(xx!=yy)
            {
                ans+=edge[i].w;
                father[xx]=yy;
            }
        }
        printf("%d\n",ans);
    }
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016-04-22 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Constructing Roads
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档