前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PAT 甲级 1025 PAT Ranking

PAT 甲级 1025 PAT Ranking

作者头像
ShenduCC
发布2018-04-27 10:39:12
7880
发布2018-04-27 10:39:12
举报
文章被收录于专栏:算法修养算法修养

1025. PAT Ranking (25)

时间限制

200 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

代码语言:javascript
复制
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

代码语言:javascript
复制
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

不知道为什么用longlong 表示registration 最后一组过不了,用string就可以了

代码语言:javascript
复制
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>
#include <map>
#include <string>

using namespace std;
typedef long long int LL;
int n,k;
struct Node
{
    string num;
    int r1;
    int tag;
    int score;
}a[100005];
int cmp(Node a,Node b)
{
    if(a.score==b.score)
        return a.num<b.num;
    return a.score>b.score;
}
map<string,int> m;
int main()
{
    scanf("%d",&n);
    int cnt=0;
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&k);
        int l=cnt;
        //m.clear();
        for(int j=1;j<=k;j++)
        {
            cin>>a[cnt].num;
            scanf("%d",&a[cnt].score);
            a[cnt++].tag=i;
        }
        sort(a+l,a+l+k,cmp);
        int r=0;
        for(int j=l;j<cnt;j++)
        {
            r++;
            if(j!=l&&a[j].score==a[j-1].score)
                m[a[j].num]=m[a[j-1].num];
            else if(j==l||a[j].score!=a[j-1].score)
                m[a[j].num]=r;
        }
    }
    sort(a,a+cnt,cmp);
    int r=0;
    printf("%d\n",cnt);
    for(int i=0;i<cnt;i++)
    {
        cout<<a[i].num<<" ";
        r++;
        if(i!=0&&a[i].score==a[i-1].score) a[i].r1=a[i-1].r1;
        else if(i==0||a[i].score!=a[i-1].score)
            a[i].r1=r;

        printf("%d %d %d\n",a[i].r1,a[i].tag,m[a[i].num]);
    }
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-05-31 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 1025. PAT Ranking (25)
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档