前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDU 1002 高精度 大数据加法

HDU 1002 高精度 大数据加法

作者头像
csxiaoyao
发布2019-02-18 17:56:55
4410
发布2019-02-18 17:56:55
举报
文章被收录于专栏:csxiaoyaocsxiaoyao

一条很简单的大数据加法题,题意简单明了 题目:

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 187987    Accepted Submission(s): 35894

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

代码语言:javascript
复制

2 1 2 112233445566778899 998877665544332211

Sample Output

代码语言:javascript
复制

Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

代码:

代码语言:javascript
复制
#include<stdio.h>
#include<string.h>
void main()
{
	int n,i,j,c[1002],d[1002],e[1002],l1,l2,l,x;
	char a[1002],b[1002];
	scanf("%d",&n);
	for(i=0;i<n;i++)
	{
		for(j=0;j<1002;j++)
		{
			a[j]='0';
			b[j]='0';
			c[j]=0;
			d[j]=0;
			e[j]=0;
		}
		scanf("%s %s",a,b);
		l1=strlen(a);
		l2=strlen(b);
		l=l1>l2 ? l1:l2;
		x=0;
		for(j=l1-1;j>=0;j--)
		{
			c[j]+=a[x++]-'0';	
		}
		x=0;
		for(j=l2-1;j>=0;j--)
		{
			d[j]+=b[x++]-'0';
		}
		for(j=0;j<l;j++)
		{
			e[j]=c[j]+d[j];
		}
		for(j=0;j<l;j++)
		{
			if(e[j]>9)
			{
				e[j]-=10;
				e[j+1]++;
			}
		}
		if(e[l]!=0)
			l++;
		printf("Case %d:\n",i+1);
		printf("%s + %s = ",a,b);
		for(j=l-1;j>=0;j--)
			printf("%d",e[j]);
		if(i!=n-1)
			printf("\n\n");
		else
			printf("\n");
	}
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2014年02月17日,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 一条很简单的大数据加法题,题意简单明了 题目:
  • A + B Problem II
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档