前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDU 1027 组合数学

HDU 1027 组合数学

作者头像
csxiaoyao
发布2019-02-18 17:59:15
6220
发布2019-02-18 17:59:15
举报
文章被收录于专栏:csxiaoyaocsxiaoyao

题目:

题意需要理解一下,到底怎么排序,然后就简单了

Ignatius and the Princess II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 4066    Accepted Submission(s): 2436

Problem Description

Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess." "Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......" Can you help Ignatius to solve this problem?

Input

The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.

Output

For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.

Sample Input

代码语言:javascript
复制

6 4 11 8

Sample Output

代码语言:javascript
复制

1 2 3 5 6 4 1 2 3 4 5 6 7 9 8 11 10

代码:

代码语言:javascript
复制
#include<stdio.h>
#include<stdlib.h>
int comp(const void*a,const void*b)
{
    return *(int*)b-*(int*)a;
}
void main()
{
	int i,j,k,n,m,a[100001],temp;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(i=0;i<n;i++)//数组赋初值
			a[i]=n-i;
		for(i=0;i<m-1;i++)//操作次数
		{
			for(j=0;j<n;j++)
			{
				if(a[j+1]<a[j])
					break;
			}//确定调换的位置
			for(k=0;k<n;k++)
			{
				if(a[k]>a[j+1])
				{
					temp=a[j+1];
					a[j+1]=a[k];
					a[k]=temp;
					break;
				}
			}
			qsort(a,j+1,sizeof(int),comp);//尾数排序
		}
		for(j=n-1;j>0;j--)
		{
			printf("%d ",a[j]);
		}
		printf("%d\n",a[0]);
	}
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2014年02月17日,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 题目:
  • 题意需要理解一下,到底怎么排序,然后就简单了
  • Ignatius and the Princess II
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档