前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDU 2899 Strange fuction

HDU 2899 Strange fuction

作者头像
风骨散人Chiam
发布2020-10-28 10:34:50
2800
发布2020-10-28 10:34:50
举报
文章被收录于专栏:CSDN旧文

Strange fuction Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 11746 Accepted Submission(s): 7841

Problem Description Now, here is a fuction: F(x) = 6 * x^7 +8* x^6 + 7x^ 3+5x^2-y*x (0 <= x <=100) Can you find the minimum value when x is between 0 and 100.

Input The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

Output Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

Sample Input 2 100 200

Sample Output -74.4291 -178.8534

Author Redow

Recommend lcy

这个题可以三分求单调性,也可以求导再进行计算。

代码语言:javascript
复制
#include<iostream>
#include<cstdio>
using namespace std;
double F(double x,double y)
{
	return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-y*x;
}
double f(double x)//易知导函数单调递增,则原函数先减后增;
{
	return 42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x;
}
int main()
{
	int t;
	double y,l,h,mid;
	cin>>t;
	while(t--)
	{
		cin>>y;
		l=0.0;h=100.0;
		while(h-l>1e-7)
		{
			mid=(l+h)/2;
			if(f(mid)<y) l=mid;
			else h=mid;
		}
		printf ("%.4lf\n",F(mid,y));

	}
	return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2019/05/18 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档