前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >数学--数论-- HDU -- 2854 Central Meridian Number (暴力打表)

数学--数论-- HDU -- 2854 Central Meridian Number (暴力打表)

作者头像
风骨散人Chiam
发布2020-11-06 00:48:16
2890
发布2020-11-06 00:48:16
举报
文章被收录于专栏:CSDN旧文CSDN旧文

A Central Meridian (ACM) Number N is a positive integer satisfies that given two positive integers A and B, and among A, B and N, we have N | ((A^2)*B+1) Then N | (A^2+B) Now, here is a number x, you need to tell me if it is ACM number or not.

Input

The first line there is a number T (0<T<5000), denoting the test case number. The following T lines for each line there is a positive number N (0<N<5000) you need to judge.

Output

For each case, output “YES” if the given number is Kitty Number, “NO” if it is not.

Sample Input

2 3 7 Sample Output

YES NO Hint X | Y means X is a factor of Y, for example 3 | 9; X^2 means X multiplies itself, for example 3^2 = 9; XY means X multiplies Y, for example 33 = 9.

题意:

给你一个数,如果能找出两个数a,b使得这三个数满足式子1,但不满足式子2,那么这个数n就不是符合要求的数,输出NO

思路: 实在算不粗来了,把我写的代码打了个表,然后,发现最大是240,然后其他,就没其他了。

#include <cstring>
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <map>
using namespace std;
int mp[10000000];
int main()
{
    mp[1] = 1;
    mp[2] = 1;
    mp[3] = 1;
    mp[4] = 1;
    mp[5] = 1;
    mp[6] = 1;
    mp[8] = 1;
    mp[10] = 1;
    mp[12] = 1;
    mp[15] = 1;
    mp[16] = 1;
    mp[20] = 1;
    mp[24] = 1;
    mp[30] = 1;
    mp[40] = 1;
    mp[48] = 1;
    mp[60] = 1;
    mp[80] = 1;
    mp[120] = 1;
    mp[240] = 1;
    int T, a;
    cin >> T;
    while (T--)
    {
        scanf("%d", &a);
        if (mp[a] == 1)
            puts("YES");
        else
            puts("NO");
    }
    return 0;
}

达标代码

#include <iostream>
#include <cstdio>
using namespace std;
int mp[10000000];

int ok(int x)
{
    for (int i = 1; i <= 1000; i++)
    {
        for (int j = 1; j <= 1000; j++)
        {
            if ((i * i * j + 1) % x == 0 && ((i * i + j) % x != 0))
                return 0;
        }
    }
    return 1;
}
int main()
{
    for (int i = 1; i <= 1000; i++) //打表部分
    {
        if (ok(i))
        {
            printf("mp[%d]=1; \n", i);
        }
    }
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2019-12-19 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档