前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDOJ(HDU) 1708 Fibonacci String

HDOJ(HDU) 1708 Fibonacci String

作者头像
谙忆
发布2021-01-21 15:26:14
2020
发布2021-01-21 15:26:14
举报
文章被收录于专栏:程序编程之旅程序编程之旅

Problem Description After little Jim learned Fibonacci Number in the class , he was very interest in it. Now he is thinking about a new thing – Fibonacci String .

He defines : str[n] = str[n-1] + str[n-2] ( n > 1 )

He is so crazying that if someone gives him two strings str[0] and str[1], he will calculate the str[2],str[3],str[4] , str[5]….

For example : If str[0] = “ab”; str[1] = “bc”; he will get the result , str[2]=”abbc”, str[3]=”bcabbc” , str[4]=”abbcbcabbc” …………;

As the string is too long ,Jim can’t write down all the strings in paper. So he just want to know how many times each letter appears in Kth Fibonacci String . Can you help him ?

Input The first line contains a integer N which indicates the number of test cases. Then N cases follow. In each case,there are two strings str[0], str[1] and a integer K (0 <= K < 50) which are separated by a blank. The string in the input will only contains less than 30 low-case letters.

Output For each case,you should count how many times each letter appears in the Kth Fibonacci String and print out them in the format “X:N”. If you still have some questions, look the sample output carefully. Please output a blank line after each test case.

To make the problem easier, you can assume the result will in the range of int.

Sample Input 1 ab bc 3

Sample Output a:1 b:3 c:2 d:0 e:0 f:0 g:0 h:0 i:0 j:0 k:0 l:0 m:0 n:0 o:0 p:0 q:0 r:0 s:0 t:0 u:0 v:0 w:0 x:0 y:0 z:0

格式:每个案例后面都有一个空行!!!

不能直接用字符串相加来做,因为可能到后面会超内存!累加到后面的字符串太长了!!!

所以换位思考,既然是统计字母的个数,为什么不直接来建立整型数组呢。 只要统计出str0和str1中各个字母的个数就可以了。 后面各个字母个数的按照公式来推就行。

代码语言:javascript
复制
import java.util.Scanner;

public class Main{
    public static void main(String[] args) {
        long num[][] = new long[56][26];
        Scanner sc = new Scanner(System.in);
        int t = sc.nextInt();
        while(t-->0){
            for(int i=0;i<num[0].length;i++){
                for(int j=0;j<num.length;j++){
                    num[j][i]=0;
                }
            }
            String str0 = sc.next();
            for(int i=0;i<str0.length();i++){
                for(int j='a';j<='z';j++){
                    if(str0.charAt(i)==(char)j){
                        num[0][j-'a']++;
                        break;
                    }
                }
            }
            String str1 = sc.next();
            for(int i=0;i<str1.length();i++){
                for(int j='a';j<='z';j++){
                    if(str1.charAt(i)==(char)j){
                        num[1][j-'a']++;
                        break;
                    }
                }
            }
            int n = sc.nextInt();
            for(int i=2;i<=n;i++){
                for(int k='a';k<='z';k++){
                    num[i][k-'a'] = num[i-1][k-'a']+num[i-2][k-'a'];
                }
            }

            for(int k='a';k<='z';k++){
                System.out.println((char)k+":"+num[n][k-'a']);
            }
            System.out.println();

        }
    }


}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016/04/21 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档