专栏首页solate 杂货铺libstdc++.so.6 version CXXABI_1.3.8找不到

libstdc++.so.6 version CXXABI_1.3.8找不到

安装软件的时候提示

ImportError: /lib64/libstdc++.so.6: version `CXXABI_1.3.8` not found 

就是这个文件比较老

  1. 查看下自己系统里面的最高版的CXXABI:
strings /usr/lib64/libstdc++.so.6 | grep CXXABI

我这里最高版本是CXXABI_1.3.7

下载libstdc++.so.6.0.26

链接: https://pan.baidu.com/s/1qqXBMxmKMDpp-jycRnHyMQ 提取码: bv88

将文件移动到系统目录/usr/lib64/下面

ll libstdc++.so*

现在的libstdc++.so.6.0.26是白色的,需要让它变成可链接文件,这里必须让文件有可执行权限才能被链接

chmod +x libstdc++.so.6.0.26
mv libstdc++.so.6 libstdc++.so.6.bak
ln -s libstdc++.so.6.0.26 libstdc++.so.6

然后测试

strings /usr/lib64/libstdc++.so.6 | grep CXXABI

成功

https://www.codenong.com/cs106550245/

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

我来说两句

0 条评论
登录 后参与评论

相关文章

  • libgomp.so.1: version `GOMP_4.0' not found 或者libstdc++.so.6: version `CXXABI_1.3.8' not found 错误解决

    白墨石
  • Ubuntu14.04创建Genymotion虚拟机

    最近工作开发环境有Windows切换到了Ubuntu,以前在Windows环境下使用Genymotion搞Android开发还蛮好用的。那么在Ubuntu环境下...

    静默加载
  • libstdc++库版本较低的解决办法

    xxx.exe: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by ...

    用户7592569
  • OpenSystemArchitect linux安装笔记

    一款类似Powerdesign的开源产品OpenSystemArchitect。 网站:https://www.codebydesign.com/ 下载64位安...

    斯武丶风晴
  • 第三方so通过patchelf兼容低版本glibc

    背景:第三方so依赖glibc2.14版本,如何在不升级cenos 6.2自带的gblic2.12情况下,运行so?

    lovelife110
  • tensorflow 1.0安装过程中出现/usr/lib64/libstdc++.so.6: version 'GLIBCXX_3.4.19' not found问题的解决

    在linux redhat 6.4环境下安装tensorflow的过程中,利用PIP直接安装是非常快的。 但是在调用测试的过程中,却发现报这样的错误。 /us...

    sparkexpert
  • C++11 gcc升级到5.2.0后报错:... version 'GLIBCXX_3.4.17' not found

    版权声明:本文为博主原创文章,转载请注明源地址。 https://blog.csdn.net...

    用户1148648
  • Rstudio Server 不同R版本配置和切换

    Rstudio Desktop for Windows/Mac 切换不同R版本非常简单,Tools→Global Options→General→Basic→R...

    生信技能树
  • 在Ubuntu上安装SAP Cloud Connector的一些错误

    SAP官方文档对基于Linux内核的操作系统的规定: You have either of the following 64-bit operating sy...

    Jerry Wang
  • clickhouse编译安装以及搭建mysql实时复制

    由于clickhouse的发布比较频繁,目前版本为20.7 尚未支持与mysql同步,故编译了git上最新的版本 20200909--版本号为20.9。

    老叶茶馆
  • Linux下安装GLIBC_2.18和libstdc++.so

    試毅-思伟
  • centos6.5:gcc 升级(5.2.0)过程记录

    版权声明:本文为博主原创文章,转载请注明源地址。 https://blog.csdn.net...

    用户1148648
  • centos6.5 配置mongodb3

    deepcc
  • ImportError: /lib64/libm.so.6: version `GLIBC_2.23' not found (required by /usr/local/python37/lib/p

    这个错误的出现往往与我前面的一篇文章 ImportError: /lib64/libm.so.6: version `CXXAB_1.3.8.' not fou...

    马一特
  • Matlab 2015b 启动时崩溃 MATLAB crashes during startup on Ubuntu 16.04

    Matlab 启动时崩溃 MATLAB crashes during startup on Ubuntu

    zhangrelay
  • Linux动态链接

    曾经不止一次遇到过这样的情况:从机器A拷贝一个二进制文件到另一台机器B,两台机器的操作系统版本一样,可是在机器A能正常运行,在机器B却提示错误。最常见的就是提示...

    linjinhe
  • Apache Doris 的一场编译之旅

    直接访问官方文档,中文的官方文档对于阅读是比较友好的,正常情况下直接对照文档建议的来基本上不会存在大问题。编译部分官方推荐使用官方提供的 Docker 镜像(D...

    大数据真好玩
  • 通过修改第三方so的elf符号表兼容redhat6.2下低版本glibc

    背景:第三方so依赖glibc2.14版本,如何在不升级redhat 6.2自带的gblic2.12情况下,运行so?

    lovelife110
  • MySQL 8.0.22 源码编译安装全过程

    墨墨导读: Mysql的8.0版本出来已经有一段时间了,近期研究下源码调试。整个编译过程越来越复杂了。

    数据和云

扫码关注云+社区

领取腾讯云代金券