无法找到包linux-headers-4.15.0-kali2-amd64

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (1)
  • 关注 (0)
  • 查看 (417)

我试着运行apt-get install linux-headers-$(uname -r) 但是我得到一个错误。

E: Unable to locate package linux-headers-4.15.0-kali2-amd64
E: Couldnt find any package by glob 'linux-headers-4.15.0-kali2-amd64
E: Couldnt find any package by regex'linux-headers-4.15.0-kali2-amd64

所以这就是事情,我用(https://docs.kali.org/general-use/kali-linux-sources-list-repositories)这些存储库(链接)更改source.list 。我认为我的kali版本与链接不匹配。当我写apt-cache search linux-headers,我的标题似乎是linux-headers-4.16.0-kali2-all ...

那有什么建议吗?我怎么解决这个问题 ?或者是否有4.16.0版本的链接?

提问于
用户回答回答于

首先尝试改变这条线

linux-headers-4.15.0-kali2-amd64 变成

linux-headers-4.15.0-kali-amd64

因为根本没有kali2的东西。

你还能做的就是运行

apt-cache search linux-headers

它将显示所有可用的标题。

扫码关注云+社区

领取腾讯云代金券