php artisan key:generate 报错?

  • 回答 (3)
  • 关注 (0)
  • 查看 (898)

请描述您遇到的问题

问题所在页面

页面截图

浏览器信息

Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/60.0.3112.113 Safari/537.36
闪亮科学闪亮科学提问于
3416180057回答于

这个错误是因为php的版本跟Laravel要求的版本不一致,composer install安装依赖失败导致的,我们会更新实验教程,您目前可以先执行下面的操作,然后继续按步骤执行也可以解决问题

yum -y remove php56w php56w-fpm php56w-mysql php56w-mcrypt php56w-dom php56w-mbstring php56w-common.x86_64
yum -y install php70w php70w-fpm php70w-mysql php70w-mcrypt php70w-dom php70w-mbstring php70w-common.x86_64
cd /home/blog/
composer install
100001079559回答于

PHP Warning: require(/home/blog/vendor/autoload.php): failed to open stream: No such file or directory in /home/blog/artisan on line 18

PHP Fatal error: require(): Failed opening required '/home/blog/vendor/autoload.php' (include_path='.:/usr/share/pear:/usr/share/php') in /home/blog/artisan on line 18

安装以后没有/home/blog/vendor/autoload.php

是这个问题吗??文件缺失。导致错误。

医生修改于

之前步骤中指导安装的 PHP 版本是 5.6.*,而最新版 Laravel 5.5 依赖 PHP 7。

方法 1:

卸载 PHP 5.6,安装 PHP 7。

方法 2:

在 home 目录下:

composer create-project laravel/laravel blog 5.4.*

可能回答问题的人

  • mariolu

    腾讯 · 后台开发工程师 (已认证)

    28 粉丝0 提问1 回答
  • 尊托云数

    15 粉丝1 提问1 回答
  • 用户1909162

    0 粉丝0 提问1 回答
  • 用户2993187

    0 粉丝0 提问1 回答

扫码关注云+社区

领取腾讯云代金券