Bower安装包EPERM重命名错误?

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (2)
  • 关注 (0)
  • 查看 (54)

使用node和git来清理win7专业版

Bower.json

{
  "name": "name123456",
  "version": "1.0.0",
  "dependencies": {
    "closure-compiler": "http://dl.google.com/closure-compiler/compiler-latest.zip"
  }
}

运行 bower install,会报错如下:

知道为什么会这样吗?谢谢。

提问于
用户回答回答于

它是Bower1.2.7及以上版本中与升级的zip库相关的一个bug。解决方法是重新安装Bower,因为它将强制对zip库进行升级:

bower cache clean
npm uninstall -g bower
npm install -g bower

有关更多信息,请参见https://github.com/Bower/Bower/Isks/991

用户回答回答于
npm uninstall -g bower && npm update decompress-zip && npm install -g bower

扫码关注云+社区

领取腾讯云代金券