为什么Play动作失败了“没有找到合适的驱动程序”与巧妙和PostgreSQL?

  • 回答 (1)
  • 关注 (0)
  • 查看 (57)

我正在编写Scala网络应用程序播放框架2.1.1使用本地Postgres数据库以及Slick1.0.0,我在这里遇到了一个矛盾。

这是我遇到的错误:

[SQLException: No suitable driver found for postgres://user:password@localhost:5432/postgres]
56  
57  def instance = Action {
58    Database.forURL("postgres://user:password@localhost:5432/postgres", driver = "org.postgresql.Driver") withSession {
59      val q = Retailer.map(_.name)
60      Ok(views.html.instance(q.list, newRForm))
61    }
62  }
63

何地userpassword分别是usernamepasswordPostgres数据库。

我发现:

  1. 需要使用Class.forName("org.postgresql.Driver");
  2. 在程序的类路径中需要PostgreSQL驱动程序的JAR文件。

Application.scala我有以下代码块:

{
  println(ConfigFactory.load().getString("db.default.url"))
  println(Class.forName("org.postgresql.Driver"))
} 

play compile成果如下:

(Server started, use Ctrl+D to stop and go back to the console...)

[info] play - database [default] connected at jdbc:postgresql://localhost:5432/postgres
[info] play - Application started (Dev)
postgres://user:password@localhost:5432/postgres
class org.postgresql.Driver
[error] application -

! @6ei1nhkop - Internal server error, for (GET) [/instance] ->

play.api.Application$$anon$1: Execution exception[[SQLException: No suitable driver found for jdbc:postgresql://user:password@localhost:5432/postgres]]
        at play.api.Application$class.handleError(Application.scala:289) ~[play_2.10.jar:2.1.1]
        at play.api.DefaultApplication.handleError(Application.scala:383) [play_2.10.jar:2.1.1]
        at play.core.server.netty.PlayDefaultUpstreamHandler$$anonfun$17$$anonfun$apply$24.apply(PlayDefaultUpstreamHandler.scala:326) [play_2.10.jar:2.1.1]
        at play.core.server.netty.PlayDefaultUpstreamHandler$$anonfun$17$$anonfun$apply$24.apply(PlayDefaultUpstreamHandler.scala:324) [play_2.10.jar:2.1.1]
        at play.api.libs.concurrent.PlayPromise$$anonfun$extend1$1.apply(Promise.scala:113) [play_2.10.jar:2.1.1]
        at play.api.libs.concurrent.PlayPromise$$anonfun$extend1$1.apply(Promise.scala:113) [play_2.10.jar:2.1.1]
java.sql.SQLException: No suitable driver found for jdbc:postgresql://user:password@localhost:5432/postgres
        at java.sql.DriverManager.getConnection(Unknown Source) ~[na:1.7.0_21]
        at java.sql.DriverManager.getConnection(Unknown Source) ~[na:1.7.0_21]
        at scala.slick.session.Database$$anon$2.createConnection(Database.scala:105) ~[slick_2.10-1.0.0.jar:1.0.0]
        at scala.slick.session.BaseSession.conn$lzycompute(Session.scala:207) ~[slick_2.10-1.0.0.jar:1.0.0]
        at scala.slick.session.BaseSession.conn(Session.scala:207) ~[slick_2.10-1.0.0.jar:1.0.0]
        at scala.slick.session.BaseSession.close(Session.scala:221) ~[slick_2.10-1.0.0.jar:1.0.0]

然后play dependencies而Postgres.jar就解决了!

Here are the resolved dependencies of your application:
+--------------------------------------------------------+--------------------------------------------------------+-----------------------------------+
| ←[32mpostgresql:postgresql:9.1-901-1.jdbc4←[0m         | ←[37mats:ats_2.10:1.0-SNAPSHOT←[0m                     | ←[37mAs postgresql-9.1-901-1.jdbc4.jar←[0m |
+--------------------------------------------------------+--------------------------------------------------------+-----------------------------------+

conf/应用

# Database configuration
db.default.driver=org.postgresql.Driver
db.default.url="jdbc:postgres://user:password@localhost:5432/postgres"
db.default.user=user    
db.default.password=password

项目/Build.scala

import sbt._
import Keys._
import play.Project._

object ApplicationBuild extends Build {

  val appName    = "ats"
  val appVersion = "1.0-SNAPSHOT"

  val appDependencies = Seq(
    // Add your project dependencies here, 
    jdbc,
    "com.typesafe.slick" %% "slick"      % "1.0.0",
    "postgresql"         %  "postgresql" % "9.1-901-1.jdbc4"
  )

  val main = play.Project(appName, appVersion, appDependencies).settings(
    // Add your own project settings here    
  )

我也有postgresql-9.2-1002.jdbc4.jarslick_2.10-1.0.1-RC1.jar在我的/lib文件,以及我的本地Postgres版本SELECT version();9.2.4不过,Postgres驱动程序解析似乎要解析到9.1.jar,并且当我注释掉应用程序依赖项时,可以让/lib自己包括在内,/lib似乎不在剧中的CLASSPATH。

我知道Postgres url是正确的,当我的应用程序第一次启动时,我能够连接到我的数据库。

程序猿闯子程序猿闯子提问于
遮天之李数学 本回答于
已采纳

你把事情搞混了。

然后我看了这个问题,上面写着..。

  1. 你装到什么地方。Class.forName(“org.postgresql.Driver”);
  2. 将需要程序类路径中的PostgreSQL驱动程序.jar文件。

这在这种情况下不适用。你有一个框架为你处理这些事情。所提到的问题是描述如何使用“原始”JDBC访问数据库。


你应该这么做。

首先,可以简化配置部分。5432是postresql和localhost也是默认主机。用户名和密码应放在url之外。

# Database configuration
db.default.driver=org.postgresql.Driver
db.default.url=jdbc:postgres:postgres
db.default.user=user    
db.default.password=password

现在定义正确的SBT依赖项。只需将JAR文件从/lib文件夹并更新依赖项以获得最新的PostgreSQL驱动程序(9.2),方法是更改Build.scala应用程序。请注意,GroupId已从postgresqlorg.postgresql...

val appDependencies = Seq(
  // Add your project dependencies here, 
  jdbc,
  "com.typesafe.slick" %% "slick" % "1.0.0",
  "org.postgresql" % "postgresql" % "9.3-1102-jdbc41"
)

最后,应该更改控制器以从配置中解析数据源:

def instance = Action {
  Database.forDataSource(DB.getDataSource()) withSession {
    val q = Retailer.map(_.name)
    Ok(views.html.instance(q.list, newRForm))
  }
}

扫码关注云+社区