ASP.NETCore(ASP.NET 5)应用程序中有哪些框架可用?

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (2)
  • 关注 (0)
  • 查看 (29)

我已经看到了有针对性的各种框架project.json文件,使用的名称,如netcore50dotnetdnx451net45,和其他人。“框架”部分project.json文档没有(但)指定如何将这部分用于不同的框架。

哪些框架可用,以及project.json中应该使用什么名称来定位每个框架?

提问于
用户回答回答于

完整列表请参阅目标框架

最常见的TFM的ASP.NET应用程序开发人员需要知道的是:

  • netcoreappx.y=一个面向.NET Core xy的应用程序(例如netcoreapp1.0= .NET Core 1.0)
  • netstandardx.y=一个面向.NET标准xy的库。(例如netstandard2.0= .NET标准2.0)。.NET标准库可以在桌面.NET,Windows Phone,Mono等平台上运行。
  • net4xy=面向桌面.NET Framework 4.xy的库或控制台应用程序(例如net452net46

这个Nuget博客文章显示了可用于nuget的额外TFM。它也解释了dotnetTFM。

尽管这不是官方文档,但Oren Novotny的这篇博客文章有一张极好的表格,显示了不同的目标框架标记。

用户回答回答于

截至目前,只有两个三包支持。

.Net Framework 4.5.1 = dnx451 .Net Framework 4.5.2 = dnx452 .Net Core 5.0 = dnx50

.NET Framework 4.6.0(dnx46)将在不久的将来发布。

仍然取决于你'可用'的含义。任何人都可以发布一个他们想要的新框架,那只猫现在已经没有了。然而,默认情况下,dnu使用project.json通过查看nuget.org上的主要提要来查找依赖关系。现在在nuget.org上,这些是唯一的dnx框架依赖关系。

例如,看看microsoft.aspnet.mvc nuget页面:https://www.nuget.org/packages/Microsoft.AspNet.Mvc/6.0.0-beta4

Dependencies

DNX 4.5.1
Microsoft.AspNet.Authorization (≥ 1.0.0-beta4)
Microsoft.AspNet.Cors (≥ 1.0.0-beta4)
Microsoft.AspNet.Mvc.Razor (≥ 6.0.0-beta4)
Microsoft.Framework.Caching.Memory (≥ 1.0.0-beta4)

DNXCore 5.0
Microsoft.AspNet.Authorization (≥ 1.0.0-beta4)
Microsoft.AspNet.Cors (≥ 1.0.0-beta4)
Microsoft.AspNet.Mvc.Razor (≥ 6.0.0-beta4)
Microsoft.Framework.Caching.Memory (≥ 1.0.0-beta4)

在早期的测试版本中也有一个aspnet50和aspnetcore50,但它们已被弃用,应分别用dnx451和dnxcore50替换。

扫码关注云+社区