将Bootstrap更新到版本3 - 我必须做什么?

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (2)
  • 关注 (0)
  • 查看 (17)

我是Bootstrap的新手,并且拥有旧版本2.3.2。

版本3已经发布。如果我想使用最新版本,我只需简单地替换CSS和Javascript文件?

提问于
用户回答回答于
  1. http://getbootstrap.com/下载最新版本或用最新版本替换css和js文件或使用CDN(http://www.bootstrapcdn.com/
  2. 迁移你的html,确实是阅读http://bootply.com/bootstrap-3-migration-guide。你可以尝试http://twitterbootstrapmigrator.w3masters.nl/http://code.divshot.com/bootstrap3_upgrader/(也提供清单)

  3. 添加html5shiv.js以将对HTML5元素的支持添加到IE8
  4. 在IE中为媒体查询支持添加respond.js(https://github.com/scottjehl/Respond)。注意这不适用于CDN
  5. 自RC2以来Glyphicons已恢复正常(来自Glyphicon Halflings集的字体格式为180个字形)
  6. 如果你使用Javascript Typeahead组件,则必须集成https://github.com/twitter/typeahead.js/(原因typeahead javascript被丢弃)
  7. 切换到最新版本的jQuery 1.x(不要使用2.x版本,因为jQuery 2.x不支持IE8)
  8. 如果你使用向你的代码添加或插入HTML的第三方小部件(如addthis.com,sharethis.com和Google地图),请为该框的大小创建一个包装
用户回答回答于

扫码关注云+社区