怎么在Mac OS X上升级Ruby?

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (2)
  • 关注 (0)
  • 查看 (21)

我想我的电脑上升级Ruby的版本。我运行Mac OS X Snow Leopard并在命令行中执行ruby -v显示我正在运行Ruby 1.8.7。

我安装了MacPorts并运行sudo port install ruby​​19命令,但是每当我键入ruby -v时,它仍然显示Ruby 1.8.7。

提问于
用户回答回答于

ruby19如果你这样安装的话,你必须运行ruby。你也可以使用irb19ri19

用户回答回答于

工具“rvm”非常好。它代表了我认为的Ruby Verson Manager,开发人员擅长于在irc渠道中提供支持。你可以在一边安装多个版本的ruby,选择你想使用的。

http://rvm.io

扫码关注云+社区