“aapt”IOException错误= 2,没有这样的文件或目录“为什么我不能在jenkins上构建我的gradle?

  • 回答 (2)
  • 关注 (0)
  • 查看 (11)

我有一个小问题。

问题: 我试图在Jenkins上构建我的Android项目的一个gradle,现在我站在这个我无法解决的问题上。在建筑期间,我有这个错误信息:

:Client:mergeDebugResources
/var/lib/jenkins/workspace/LMA-Client/Client/build/exploded-aar/com.google.android.gms/play-services/3.1.59/res/drawable-hdpi/common_signin_btn_text_focus_light.9.png: 
Error: Cannot run program "/opt/android-sdk/build-tools/19.0.1/aapt": java.io.IOException: error=2, No such file or directory
:Client:mergeDebugResources FAILED

你可以想象,这个问题......它是在那里,还有PNG ......它也在那里,所以这个错误一定在别的地方。

解决方案? 现在我搜索了1-2个小时,浏览了这个伟大的网站,我发现如果Jenkins运行在64位系统上,我需要安装ia32-libs。像那样:

sudo apt-get install ia32-libs

现在我试过了,我无法安装它:

The following packages have unmet dependencies:
 ia32-libs : Depends: ia32-libs-multiarch

所以我试图安装“ia32-libs-multiarch”,但是又一次:

The following packages have unmet dependencies:
 ia32-libs-multiarch:i386 : Depends: libgphoto2-2:i386 but it is not going to be installed
                            Depends: libsane:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

最后 终于站在这里问我:这真的是解决方案吗?我为什么要安装这个东西?如何?所以请帮助我,我想我离答案不远了。

看破红尘的黑猫看破红尘的黑猫提问于
MyLove回答于

我在Ubuntu 13.10上遇到了类似的错误:

Cannot run program "/usr/local/android-sdk-linux/build-tools/19.0.3/aapt": error=2, No such file or directory

对我来说:

为了让aapt工作(这也解决了我的问题,只需安装这两个软件包): sudo apt-get install lib32stdc++6 lib32z1

problemQuants回答于

对于Arch 64用户,必须先为pacman 启用multilib,然后安装32位软件包:

sudo pacman -Syv lib32-libstdc++5 lib32-zlib

扫码关注云+社区