有困难要上,没有困难创造困难也要上!

175 篇文章
37 人订阅

全部文章

kongxx

Singularity升级

以前装的Singularity版本比较低,最近要用新功能,只能升级了。因为以前Singularity安装的时候是使用自己编译的rpm安装的,所以要安装新版本,需...

281
kongxx

Linux使用cgroup限制程序资源

以前一直在使用Docker来封装并限制容器资源,从而实现限制进程资源的目的。但Linux Docker底层是基于cgroup来实现的,于是乎今天就想起来试试直接...

562
kongxx

Singularity入门之运行图形应用

要在 Singularity 中运行图形程序需要重新制作一个镜像,使其包含执行图形应用程序需要的环境和程序,这里还是通过 sandbox 的方式来制作一个可以运...

893
kongxx

Singularity入门之安装

Singularity 提供了几种安装方式,这里选择使用编译 rpm 包的方式来安装。

772
kongxx

Singularity入门之通过沙盒创建镜像

在此镜像目录之上运行容器,这里需要使用 “--writable” 选项来使其可写。

1062
kongxx

Singularity入门之运行容器

和Docker类似,要运行 Singularity 也需要先获取镜像,Singularity 可以从Singularity Hub 或者 Docker Hub ...

1322
kongxx

Singularity入门之通过recipe文件创建镜像

Singularity中也提供了类似Docker中通过Dockerfile来创建镜像的功能,我们可以把创建镜像的内容写到Singularity文件中,然后使用S...

1081
kongxx

Xpra使用入门

Xpra 是一个开源的跨平台远程显示服务器和客户端工具,可以用来转发图形应用和桌面。这里以 CentOS7 系统为例,演示一下怎样使用 Xpra 转发图形应用和...

1031
kongxx

Xpra使用入门(二)

前一篇博客说了怎样安装和使用Xpra,其中xpra是通过类似ssh -X方式来工作的,并且是在一个命令中实现的。

752
kongxx

基于Struts2的war包在WebLogic上部署找不到Action问题及解决办法

Struts2的工程,使用了Convention Plugin,在eclipse里测试的时候可以运行,但是部署到WebLogi中时报错找不到Action。

653
kongxx

Ubuntu修改默认sh为bash

现在的Ubuntu版本默认sh都是使用的dash,用起来实在是别扭,所以找了一下,发现可以通过设置,修改为原来的bash。

961
kongxx

WebSphere8.5.5.2修改默认Java版本为JDK7

在WebSphere8.5.5.2中默认使用的是JDK6,如果想升级成JDK7,可以使用下面方法。

1523
kongxx

从零开始构建Flink开发项目-Scala版

今天要做一个Flink的测试,因此需要创建一个简单的Flink项目,于是找到了下面这种方式来创建一个Flink启动项目。

2363
kongxx

Mac挂载NTFS移动硬盘进行读写操作

在Mac上,默认情况对NTFS磁盘的挂载方式是只读(read-only)的,其实Mac原生是支持NTFS的,但是后来由于微软的限制,苹果把这个功能给屏蔽了,但是...

1403
kongxx

安装Nvidia驱动时提示需要disable the Nouveau kernel driver

今天在安装Nvidia驱动(NVIDIA-Linux-x86_64-418.56.run)的时候,提示需要“disable the Nouveau kernel...

1272
kongxx

CentOS7修改系统启动模式

在CentOS Linux上我们通常都是修改 /etc/inittab 文件,在其中加入 “id:<num>:initdefault:” 来设置系统启动模式,但...

1604
kongxx

CentOS7系统上使用RapidSVN

由于公司使用的代码管理工具还是 subversion,每次都命令行使用实在有点不方便,于是乎想到了找一个 Linux 平台的可视化 subversion 工具,...

1214
kongxx

Superset安装出错 sqlalchemy.exc.InvalidRequestError: Can't determine which FROM clause to join from, ...

今天试着在python3.7.2上安装最新的superset(0.28.1),在初始化数据库的时候报如下错误:

6342
kongxx

Superset安装出错 cannot import name _maybe_box_datetimelike from pandas.core.common

今天试着在python3.7.2上安装最新的superset(0.28.1),在创建管理员用户的时候报如下错误:

6562
kongxx

设置Docker允许非root用户操作

以前写过一篇博客介绍过怎样允许非root用户来访问Docker,当时的方法是将用户加入的docker组里,这样做安全是安全了,但是实在是太麻烦了,对于我这种安全...

1704

扫码关注云+社区

领取腾讯云代金券