首页
学习
活动
专区
圈层
工具
发布

删除mysql日志文件

的日志文件占据了大部分空间 , 整整27G,于是现在的任务就是清理mysql的日志文件(主要是清理.log文件和mysql-bin.00000X二进制日志文件) 一、删除mysql日志文件 第一步:登陆进入...mysql-bin.000005,那么删除日志文件的时候应该排除掉该文件。...删除日志文件的命令:purge binary logs to ‘mysql-bin.000005’;mysql> purge binary logs to 'mysql-bin.000005'; 删除除...删除后就能释放大部分空间。 二、mysql 定时清理日志文件 如果每次等到发现空间不足的时候才去手动删除日志文件, 这种方式是很不理想的。...编辑mysql的配置文件,设置expire_logs_days(mysql定时删除日志文件) [root@sam ~]# vim /etc/my.cnf 在my.cnf中,添加或修改expire_logs_days

5.2K00

LNMP 关闭 Mysql 日志,删除 mysql-bin.0000*日志文件

今天访问网站出现数据库链接错误,然后想重启 lnmp 环境,发现无法正常关闭 mysql 服务,回想一下,服务器已经平稳运行 4 个多月了,配置方面应该没有什么问题,所以想到,可能是数据盘空间用完了,果然如此...就想到应该是日志文件导致的,最后检查到 mysql 的日志文件超过,而且居然好几个日志文件几个G。好吧,看来问题就是出在这里。...百度到军哥的博客,删除了所有 mysql-bin.0000*日志文件,重启就OK了,顺手把 mysql 日志功能关闭了。...LNMP一键安装包安装的MySQL默认是开启了日志文件的,如果数据操作比较频繁就会产生大量的日志,在/usr/local/mysql/var/下面产生mysql-bin.0000* 类似的文件,而且一般都在几十...如何关闭MySQL的日志功能: 删除日志: 执行: /usr/local/mysql/bin/mysql -u root -p 输入数据库root用户的密码登录后再执行:reset master

3.6K11
  • 您找到你想要的搜索结果了吗?
    是的
    没有找到

    mysql日志记录

    一.mysql二进制日志 配置如下: log-bin = /path/mysql-bin #其记录日志文件名为mysql-bin.index,mysql-bin.000001(注:重启或者单个文件超出限制会...like 'log_%'; #查看日志设置 查看二进制日志 show binary logs; #查看日志文件个数与文件名 mysqlbinlog filename #查看二进制文件内容 删除二进制日志...mysql -uroot -ppass 二、错误日志 配置如下: log-error = /path/error.log 查看状态 show variables like 'log_error'; 删除错误日志...= /path/general_query.log 删除错误日志 flush logs 或 mysqladmin -uroot -ppass flush-logs 删除文件后重新创建 四、慢查询日志...配置如下: slow_query_log = ON slow_query_log_file = /path/slow-query.log long_query_time = 10 #超过10秒会记录 删除错误日志

    6.3K20

    MySQL 核心模块揭秘 | 52 期 | 删除记录的 Undo 日志

    Delete Undo 日志格式 Delete 语句删除表中一条记录,先标记删除主键索引记录,再标记删除二级索引记录。...所以,删除一条记录产生的 Undo 日志的格式和更新一条记录产生的 Undo 日志的格式基本相同,唯一不同之处是删除一条记录产生的 Undo 日志中,没有更新字段区域。...删除主键索引记录之前,会生成 Undo 日志,并写入 Undo 页。删除二级索引记录,不会生成 Undo 日志。删除记录产生的 Undo 日志格式,如下图所示。...Delete Undo 日志内容 示例 SQL 删除 t1 表中 的记录产生的 Undo 日志,如下图所示。...总结 删除一条记录产生的 Undo 日志的格式和更新一条记录产生的 Undo 日志的格式基本相同,唯一不同之处是删除一条记录产生的 Undo 日志中,没有更新字段区域。

    65910

    MySQL audit访问日志记录

    假如某个数据库被人删除了,但是拥有数据库权限的人很多,这样有必要记录下每个人的操作纪律。但是如果开启了general log的话,日志又非常大。 下面的使用init_connect的方法还不错。...登录进mysql,创建一个日志表 > create database accesslog; > use accesslog; > CREATE TABLE `accesslog` (`id` int(11...mysqld]添加 init_connect='insert into accesslog.accesslog values (connection_id(),user(),now());' 将配置持久化到文件...*的权限),用这些低级别账户进去操作下数据库或者数据表。 root用户进去查看操记录: > select * from accesslog.accesslog;  类似如下: ?...再结合accesslog.accesslog里面的记录,可以看到是下图这个时间点登录的账户操作的。这样就有据可查。 ?

    3.3K30

    MySQL数据库基础练习系列7、日志记录系统

    MySQL数据库基础练习系列目标 很多学生或者说是初学者在学习完成数据库的基础增删改查后就自认为在数据库这里就很熟悉了,但是不接触项目根本部知道需求,我这里准备了50个项目的基本需求来让大家来熟练各类项目的列信息...数据库环境 MySQL版本:5.7.31-log 数据库字符集,所有数据库通用字符集与排序规则,支持中文数据。...', '记录系统级别的事件和状态'), ('错误日志', '记录应用程序运行时的错误信息'), ('访问日志', '记录用户访问和请求信息'), ('安全日志', '记录与安全相关的事件和警报'), (...INSERT INTO system_configs (config_key, config_value, description) VALUES ('max_log_size', '10MB', '日志文件最大大小限制...@example.com', '接收系统警告的电子邮件地址'), ('log_level', 'INFO', '系统日志记录级别'); 遵循的数据库三范式 数据库建表的三范式(3NF,Third Normal

    46710

    MySQL查看数据库表中的重复记录并删除

    表数据如下 查看用户名相同的记录 select * from user where username in (select username from user group by username...HAVING count(*) >1); 查看用户名和手机号都相同的重复记录 select * from user where (username,phone) in (select username...删除用户名和手机号都相同的重复记录 DELETE from user where (username,phone) -- 注意:此处一定要加括号,当成联合字段来处理 IN ( --...SELECT MIN(id) FROM user GROUP BY username,phone HAVING COUNT(1) > 1 ); 上述语句看着是不是应该正常能执行删除掉用户名和手机号都相同的重复记录只保留...ROW_FORMAT=DYNAMIC COMMENT='用户表'; INSERT INTO `user`(`id`, `username`, `phone`, `age`) VALUES (1, '我是主数据库的

    15.1K30

    11.22 访问日志不记录静态文件

    访问日志不记录指定类型的文件目录概要 网站大多元素为静态文件,如图片、css、js等,这些元素可以不用记录 把虚拟主机配置文件改成如下: DocumentRoot...会看到右侧出现很多的元素,每一行都表示一个元素,这些请求,这些访问都会记录到访问日志里面去的,但实际上没有必须记录一些图片、css、js等元素,而这些请求都会记录到日志文件里,就会导致每天的日志访问量很大...img 表示 env非 img 类型的都进行日志记录 在设置好配置文件后,先不加载配置文件,先做一个测验 [root@hf-01 ~]# curl -x127.0.0.1:80 111.com/asdasdsaf.jpg...查看日志文件,会发现日志文件中没有记录图片的日志,这个就是因为定义了日志标签 [root@hf-01 111.com]# tail -5 /usr/local/apache2.4/logs/111.com-access_log...img ,并重新加载配置文件,在刷新图片,会看到日志文件中并没有记录日志 日志文件不记录总结 若是不去做一个限制,那么每一次请求都会记录到日志文件,日志文件就会变得越来越大,这样不仅会消耗磁盘空间,还会耗费磁盘

    1.9K60

    Apache访问日志+不记录静态文件

    Apache访问日志 : 访问日志:顾名思义就是当有人访问咱们的站点,就会被记录些信息!其实这个还是蛮重要,尤其是站点受到攻击,直接命令的日志可以让我们迅速找到攻击者IP的规律!...---- 访问日志不记录静态文件 : 当有网友访问我们的站点,站内会有很多的静态文件,如图片、css、js等,但是每当我们查看某个IP都是访问了咱们站内的什么内容时候,往往会因为这些多出来的元素导致不可以很直观的看出来访问的页面...,所以咱们可以让这些元素可以不用记录在访问日志中。...img 除了咱们自定义的img文件,全部都记录在如上此文件中!...虽然没有成功访问图片,但是关于png和gif的图片压根就没有记录日志! ---- 实用扩展: apache 日志中记录代理IP以及真实客户端IP。

    2.8K50
    领券