故障场景:AIX IBM存储更换存储控制器电源模块导致存储双控同时掉电,存储双控恢复供电后发生锁盘,IBM解盘后 RAC数据库无法正常启动,启动报错:ORA-00600: internal error...code, arguments: [2131], [33], [32], [], [], [], [], [], [], [], [], []
恢复方案确定:由于损坏的数据库数据量巨大,有30T之多,...商议之下,使用备份控制文件恢复数据库,进行数据库的不一致性恢复。 ...恢复过程:
1、从磁带库拉取控制文件备份集并恢复到Oracle RAC数据库ASM存储中
--此时尝试启动数据库会遇到报错信息:
ORA-00600: internal error code, arguments...否则,后续的使用中会时不时遇到如下报错信息:
ORA600[6122]和ORA600[KDSGRP1],实质文件是索引逻辑坏块引起的,以drop和create重建相关的索引即可。