首页
学习
活动
专区
圈层
工具
发布

XAMPP启动报错: Apache shutdown unexpectedly or MySQL shutdown unexpectedly

最近准备写一个怎么建站的教程,奈何安装xampp的时候启动的时候一直报错: ? 你们是不是也是这样?哈哈 ,如果是问题就很简单了,因为你仔细读读报错信息的话其实是很简单的,是不是懒得翻译?...在这里关闭也是一样的,ok,那么启动mysql的时候报错也是一样的处理办法,相信您已经知道怎么做了! 这里不做赘述!...当然他们都是对应的,你操作哪边都是一样的,进程都是可以关闭的,这个时候你再启动xampp就不会报错了! ? 可以了,然后想进入后台的话就可以直接点击apach的admin就行了。...我前面说了,还有一种解决办法就是我们点击启动报错的Config,举例子来说我们现在的mysql启动报错,我们可以点击: ?...如果您是一个写后端的,就会经常用这个,加入我们正在调试数据库,但是我又要启动xampp的mysql或者apach,端口的80被占用,但是结束进程的话,程序自己写的程序没办法跑了,这个时候就可以用这个办法

2.9K40
  • 您找到你想要的搜索结果了吗?
    是的
    没有找到

    MacBook安装XAMPP实现PHP调试环境及解决MySQL无法启动

    如果我们需要启动XAMPP环境调试PHP程序,我们可以打开客户端,然后启动。我们需要调试程序的时候,需要在"应用程序"-"XAMPP"-"HTDOCS"就是目录文档。...第二、解决MYSQL无法启动问题 我们在启动XAMPP之后,PHP是启动好了,但是发现MYSQL无法启动。 我们可以看到上图,MYSQL没有启动。.../share/mysql/mysql.server /Applications/XAMPP/xamppfiles/bin/mysql.server 我们在终端输入上述A、B两行命令,如果启动还解决不了得话...sudo /Applications/XAMPP/xamppfiles/bin/mysql.server start 执行这一条之后,我可以在终端看到启动MYSQL成功,然后我们也可以看到XAMPP客户端看到从原来的...本文出处:老蒋部落 » MacBook安装XAMPP实现PHP调试环境及解决MySQL无法启动 | 欢迎分享

    3.5K30

    MySQL 移动数据目录后启动失败

    MySQL 移动数据目录后启动失败 背景概述 由于安装数据库时将MySQL的数据目录放在了根目录下,现在存储空间不足,想通过mv将数据目录移动到其他目录下,但将数据目录移动到其他数据目录后,启动数据库失败...5.修改配置文件中数据目录的地址 shell> sed -i 's#/mysql80#/data/mysql80#g' my5001.cnf 6.启动数据库 shell> /data/mysql80.../svr/mysql/bin/mysqld_safe \ --defaults-file=/data/mysql80/conf/my5001.cnf --user=mysql & 此时启动数据库失败,...--defaults-file=/data/mysql80/conf/my5001.cnf --user=mysql & 数据库启动成功。...#/data/mysql80#g' relaylog.index 重新启动数据库,并启动主从复制 # 重启实例 mysql> restart; # 启动主从复制 mysql> start replica

    2.1K20

    技术分享 | MySQL 启动失败的常见原因

    作者:姚远 专注于 Oracle、MySQL 数据库多年,Oracle 10G 和 12C OCM,MySQL 5.6,5.7,8.0 OCP。...现在鼎甲科技任技术顾问,为同事和客户提供数据库培训和技术支持服务。 本文来源:原创投稿 *爱可生开源社区出品,原创内容未经授权不得随意使用,转载请联系小编并注明来源。...---- MySQL 启动失败的最常见的原因有两类,分别是无法访问系统资源和参数设置错误造成的,下面分别分析如下。...一、无法访问系统资源 MySQL 不能访问启动需要的资源是造成而 MySQL 无法启动的一个常见原因,如:文件,端口等。...二、参数设置错误 参数设置错误造成 MySQL 无法启动的原因也非常常见,此时先要检查 MySQL 启动时会调用的参数,下面的命令可以查询 MySQL 启动时调用参数文件的顺序: $ mysqld --

    3.5K40

    xampp 中 mysql的相关配置

    最近开始接触PHP,而一般搭建PHP环境使用的都是xampp 这个集成环境,由于之前我的系统中已经安装了mysql服务,所以在启动mysql的时候出现一些列错误,我通过查询各种资料解决了这个问题,现在记录一下...启动 刚开始时我在点击启动mysql的时候发现它一直卡在尝试启动mysql这个位置,xampp提示内容如下: Attempting to start MySQL service......它启动不成功但是也不提示出错,而且查询日志发现没有错误的日志,这个时候我想到应该是我本地之前安装了mysql,导致失败。...sc delete mysql 上述命令直接删除mysql这个服务。然后重启xampp,再次启动mysql,它终于报错了。...完成了这些操作,我这边就可以通过xampp面板启动mysql了。

    4.2K30

    惊心动魄-生产环境Mysql启动失败

    一、问题描述 1、客户数据库从服务器,套接字丢失/tmp/mysql.sock,导致mysql 直连本地提示访问拒绝 2、正常解决方法:需要人为重启动数据库。...3、重启动过程出现服务器不能启动(惊悚……)直接提示bug不能启动。 #二、处理流程 1、检查mysql 日志(日志如下) 按照错误提示修改key_buffer_size这几个参数,启动依旧失败。...$PATH:/usr/local/mysql-5.7.16-linux-glibc2.5-x86_64/bin 启动数据库错误问题依旧。。。。。。...& 三、解决方法 根据提示:mysql5.7的mysqld_safe启动时,引用的mysql5.6动态库,是不是因为环境变量之类有影响。...直接到/usr/local/mysql-5.7.16-linux-glibc2.5-x86_64/ 路径下启动试试,启动成功^-^。

    1.9K40

    启动MySql提示:The server quit without updating PID file(…)失败

    启动MySql提示:The server quit without updating PID file(…)失败. 1.可能是/usr/local/mysql/data/rekfan.pid文件没有写的权限...解决方法 :给予权限,执行 “chown -R mysql:mysql /var/data” “chmod -R 755 /usr/local/mysql/data”  然后重新启动mysqld!...2.可能进程里已经存在mysql进程 解决方法:用命令“ps -ef|grep mysqld”查看是否有mysqld进程,如果有使用“kill -9  进程号”杀死,然后重新启动mysqld!...3.可能是第二次在机器上安装mysql,有残余数据影响了服务的启动。 解决方法:去mysql的数据目录/data看看,如果存在mysql-bin.index,就赶快把它删除掉吧,它就是罪魁祸首了。...p=186 4.mysql在启动时没有指定配置文件时会使用/etc/my.cnf配置文件,请打开这个文件查看在[mysqld]节下有没有指定数据目录(datadir)。

    12.1K50

    老毛子固件mysql启动失败的解决方法

    关于这个问题的解决方法,我也探索了许多方法,以下的方法我实测成功 首先,mysql启动失败是由两个原因引起的 第一,opt目录下mysql文件夹没有了(解救方法:在opt目录下新建mysql文件夹) 第二...,路由器的内存不足,导致mysql下载文件不完整(解决方法:第一种,完全格式化U盘为ext4格式,开启swap并重新安装lnmp环境,第二种方法:先开启swap,然后重置mysql数据) 下面我们来说一下具体的解救方法...数据 打开老毛子固件主界面——搭建web环境——选择重置mysql数据——应用本页面设置 然后我们查看日志,如果lnmp环境mysql启动失败时,我们进入下一步 第三步,重建mysql文件夹 我们进入老毛子固件管理界面...文件夹,我们右键,创建文件夹,文件夹名填mysql 创建成功后,我们关闭flashfxp 再次进入老毛子固件主界面——搭建web环境——重启lnmp服务 我们静静等待五分钟,之后我们可以看到,mysql...已经启动成功了 然后你就可以尽情折腾了!!!!

    5.8K20
    领券