展开

关键词

cocoapods安装到使用

cocoapods安装 0.升级/安装Ruby环境 CocoaPods 是使用 Ruby 实现的,可以通过 gem 命令来安装。 也可参考 如何在Mac OS X上安装 Ruby运行环境 sudo gem update --system 1.查看现有Ruby镜像源是否为taobao.org $gem sources -l 2.通过以上命令 $sudo gem install cocoapods 这个命令默认安装的应该是最新版本,如果想安装指定版本的cocoapods,请使用以下命令: $sudo gem install cocoapods 如果安装失败那么 ~/.cocoapods 里面是空的,就需要以下两个命令重新setup。 仓库到本地~/.cocoapods目录。

11.6K40

占坑!利用 JenKins 持续集成 iOS 项目时遇到的问题

构建(构建步骤) 点击”增加构建步骤”选项,因为我使用的是CocoaPods管理的第三方,打包前先运行pod install –verbose –no-repo-update安装下第三方库。 ? 如果Xcode版本不低于9.0,就会由于Xcode 9.0不在允许你访问钥匙串里的内容,而输出ipa失败。具体的解决方法请参照后面”构建项目时遇到的几个问题“中具体的解决方法。 ,是因为看到一篇文章(cocoapods插件GEM_PATH的配置),说是修改Xcode中CocoaPods插件的GEM_PATH:中的路径与SHELL PATH:中路径一致就能解决: env: ruby_executable_hooks 4. in `find_spec_for_exe’: can’t find gem cocoapods (>= 0.a) in `find_spec_for_exe’: can’t find gem cocoapods 也可以输入命令: $ sudo gem install cocoapods -v 0.39.0 安装特定版本的CocoaPods。 由于给iOS项目构建版本时必须依赖于xcodebuild环境。

1K20
  • 广告
    关闭

    【玩转 Cloud Studio】有奖调研征文,千元豪礼等你拿!

    想听听你玩转的独门秘籍,更有机械键盘、鹅厂公仔、CODING 定制公仔等你来拿!

  • 您找到你想要的搜索结果了吗?
    是的
    没有找到

    Cocoapods安装及使用

    /CocoaPods 一、 配置Ruby环境,安装CocoaPods CocoaPods是基于ruby ecosystem的,需要ruby环境,使用ruby的gem命令。 源源(当然你有其他可用的源也可以) sudo gem install cocoapods // 安装cocoapods,需要输入用户密码,输入完成后,按回车键,需要等待许久后才能完成安装 gem uninstall cocoapods //卸载CocoaPods 终端命令截图: ? 当前CocoaPods版本 执行pod setup ,这条命令是将Github上的开源库https://github.com/CocoaPods/Specs.git托管的Podspec索引文件都下载到本地的 搜索失败 搜索第三方库如果出现了上述错误,可以执行 rm ~/Library/Caches/CocoaPods/search_index.json来删除本地旧的search_index.json文件

    42470

    升级macOS系统版本后pod命令无效的问题

    Generating Pods project Abort trap: 6 也是安装失败了。 只能重新安装一下gemcocoapods。 打开终端,输入命令行。 然后清楚原来安装gem: $ sudo gem uninstall cocoapods $ sudo gem uninstall cocoapods-core $ sudo gem uninstall $ sudo gem uninstall cocoapods-search $ sudo gem uninstall cocoapods-stats $ sudo gem uninstall cocoapods-try $ sudo gem uninstall cocoapods-trunk 这一步完成后,就可以安装了,直接输入: $ sudo gem install cocoapods --pre 这是出现了这个错误 /usr/local/bin cocoapods --pre 就安装成功了,这时候再去工程目录下pod install,就可以成功了。

    20020

    iOS_开发Terminal和Cocoapods常用指令

    文章目录 一、基础命令 二、快捷键 三、`gem`相关: 1、管理`gem`: 2、配置`gem`: 3、`gem`使用 四、操作`CocoaPods`: 1、安装或更新: 2、查看版本: 3、降低版本 在使用gem安装CocoaPods的时候,建议先更新gem的版本。 gem sources -a https://ruby.taobao.org/ 3、gem使用 gem list # 列出本地安装的包 sudo gem update # 更新所有的包 sudo gem cleanup # 清除过期的gem ---- 四、操作CocoaPods: 1、安装或更新: sudo gem install cocoapods # 安装 sudo gem install gem uninstall cocoapods # 删除 2、查看版本: pod --version 3、降低版本 3.1、查看gems中本地程序包 gem list # 找到`cocoapods`相关的程序包

    7220

    项目 添加pods

    二、安装 由于网上的教程基本都大同小异,但细节之处还不是很完善,所以借机会在这里补充下: 注:要使用CocoaPods,那就要下载安装它,而下载安装CocoaPods需要Ruby环境 1、Ruby环境搭建 Mac  OS本身自带Ruby,但还是更新一下保险,因为我第一次安装在没有更新Ruby的情况下就失败了。 a 查看下当前ruby版本:打开终端输入 ruby -v(确实安装了,不过用这个版本接下来工作失败了,所以更新下ruby) ritekiMac-mini:PodTest lucky$ ruby -v    to sources ritekiMac-mini:~ lucky$ gem sources -l   *** CURRENT SOURCES ***   2、下载安装CocoaPods 终端输入:  after 10 seconds   1 gem installed  这样就下载安装好了CocoaPods 3、使用CocoaPods a  新建一个项目,名字PodTest b  终端中,cd到项目总目录

    16530

    新版Cocoapods更新 CDN

    Seguin [https://rvm.io] 2、Ruby的安装 cocoaPods需要Ruby版本大于2.2.2。先检测一下当前版本。 成功后设置一下默认版本: $ rvm use 2.6 --default 3、更换GemGem是一个管理Ruby库和程序的标准包,它通过Ruby Gem(如rubygems.org/)源来查找、安装 4、更新升级Gem版本 Gem是管理Ruby库和程序的标准包,如果它的版本过低也可能导致安装失败,解决方案升级Gem。 $ sudo gem update -n /usr/local/bin —system 5、安装cocoaPods // 如果之前有 $ sudo gem uninstall cocoapods (移除原来的 cocoapods) // 安装CocoaPods(10.11后苹果升级了安全策略) $ sudo gem install -n /usr/local/bin cocoapods 新版的 CocoaPods

    96420

    cocosPod 找不到最新库

    原因: 1.cocosPod不是最新版本 2.本地仓库没有更新 解决办法: 首先查看pod版本 :  pod  --version       ( 现在是1.2.0beta $ sudo gem update --system // 先更新gem,国内需要切换源 1.2检查镜像,因为cocospod要访问外国网站,所以要用淘宝镜像。 / $ gem sources -l *** CURRENT SOURCES *** https://ruby.taobao.org/ 1.3 、然后安装 $ sudo gem install cocoapods // 安装cocoapods 如果遇到下面的报错:  While executing gem ... /bin cocoapods --pre 然后你可以查看一下pod 版本是否是最新的了 2、远程库没有更新到本地 pod repo update    耐心等,很慢。

    84010

    Cocopods| 使用自己的私有仓库时的一次报错记录

    查看本地cocoapods repos 有没有时,发现没有我们想要的类库:JWJFramework 然后打开隐藏目录 .cocoapods (这个目录在你的个人目录底下, ~/.cocoapods 4、查看gem源是否是最新的:gem sources -l 5、升级cocoapods:sudo gem install -n /usr/local/bin cocoapods --pre 3、安装cocoapods A.先升级Gem(可以省略) sudo gem update --system B.切换cocoapods的数据源 【 安装cocoapods有一些不同的命令,下面总结一下: 1.检查ruby环境,若需要请按如下更新 $ sudo gem update --system 2.卸载cocoapods $ sudo [Yn] y 3.重装cocoapods (安装命令有变化) 10.11之前 $ sudo gem install cocoapods 10.11之后 $ sudo gem install

    1.3K20

    程序员面试闪充--Cocoapods的详解

    在 install cocoapods 命令后,需要执行 pod setup 这个命令,pod setup 命令就是将远程索引库克隆到本地来。 二、安装 1、升级Gem 系统太老可能会有问题,所以安装之前最好升级一下gem sudo gem update --system 2、切换cocoapods的数据源 cocoapods的数据源在国外,在国内访问速度会特别慢 gem sources --remove https://rubygems.org/ gem sources -a https://ruby.taobao.org/ gem sources -l 3、安装 cocoapods sudo gem install cocoapods sudo gem install -n/usr/local/bin cocoapods (10.11以上的系统) 4、将Podspec 如果有多个类库依赖于同一个类库,但是依赖于不同的版本,那么cocoaPods会自动设置一个兼容的版本。 2)下载依赖:根据分析依赖的结果,下载指定版本的类库到本地项目中。

    1.3K100

    CocoaPods 2017最新、最快安装和使用说明

    安装CocoaPods 本文开发环境为 iMac OS X 10.10.3,(最近安装最新版本: 10.13 )安装 CocoaPods之前,要先确保电脑本地是否有 Ruby环境,因为CocoaPods 接下来的安装过程:  以前用到的镜像有淘宝的:   gem sources -a https://ruby.taobao.org/(停止维护)                                       gam:  2.6.14)你的要不是最新的,你可以试着升级一下gem :  sudo gem update --system /************   2017 - 07-10 更新    再次执行命令安装 Cocoapods: sudo gem install cocoapods                // Mac OS X 10.11前 输入这一条 sudo gem install -n /usr -0.4.4.gem (100%) Successfully installed cocoapods-try-0.4.4 Fetching: cocoapods-0.37.1.gem (100%) Successfully

    29160

    macOS Catalina 10.15 十分钟安装 CocoaPods

    sources -l *** CURRENT SOURCES *** https://gems.ruby-china.com/ 2、安装 CocoaPods ruby 环境安装后,就可以安装 CocoaPods 了 2.1、真假 CocoaPods 不要着急敲命令,往下看,有坑 不要着急敲命令,往下看,有坑 不要着急敲命令,往下看,有坑 方法一 输入安装 CocoaPods 命令 sudo gem install cocoapods sudo gem install cocoapods 等待了几分钟后,显示下面的信息,便表示已经安装成功了。 Unable to find a pod with name, author, summary, or description matching `AFNetworking` 看来还是失败了,天不助我啊 真正安装成功喽。

    27020

    CocoaPods与Ruby安装,配置,及使用详细记录(Mac环境)

    当我们为App工程导入第三方库的时候经常用到CocoaPods这个工具,这篇文章就介绍安装CocoaPods的详细记录。 附:笔者介绍另一种导入第三方库工具Carthage的文章,可以另外点击进入查看http://www.jianshu.com/p/1de99aeedbf6 1.给Mac安装Ruby环境 1.1 首先要安装好 Aborting. ``` ### 2.给Mac安装CocoaPods - 安装CocoaPods > $ gem install cocoapods ``` miki:~ ChenMan$ gem 第三库名称,名称一定要正确,不然有可能安装失败。 See `https://guides.cocoapods.org/syntax/podfile.html#platform`. ``` 若出现`pods installed`字样表示安装成功。

    49730

    iOS-安装和使用 CocoaPods

    Seguin [https://rvm.io] 二、安装 ruby 环境 *Tips: 如果ruby的版本低于2.2.2,安装CocoaPods会报错,所以建议先升级ruby环境,建议升级到2.3.0 添加ruby-china源 gem source --add https://gems.ruby-china.org 如果遇到同样的问题,还是以管理员身份添加就好了 ---- 四、安装 Cocoapods 终端执行命令,以管理员的身份安装 sudo gem install cocoapods 安装成功(出现gems installed证明安装成功) Fetching: nanaimo-0.2.3.gem 第一次执行Pod setup时,CocoaPods会将这些podspec索引文件更新到本地的~/.cocoapods/目录下,这个索引文件比较大,有821.7M左右。所以第一次更新时会有点慢。 8.安装框架第三方框架,不更新本地索引,速度快 pod install --no-repo-update ?

    1.3K70

    CocoaPods使用详解

    CocoaPods安装与使用 Ruby CocoaPods可以很方便的使用Mac自带的RubyGems安装(Mac系统默认安装了Ruby环境),如果不确定自己系统中是否有Ruby的,可以使用ruby *** CURRENT SOURCES *** https://ruby.taobao.org/ 5,安装CocoaPods安装命令如下: sudo gem install cocoapods 安装过程中,常见的错误如下: ERROR: While executing gem ... sudo nvram boot-args="rootless=0" sudo reboot 此时,在执行安装命令: sudo gem install cocoapods -V 如果依旧有错误 第一次执行pod setup时,CocoaPods会将这些podspec索引文件更新到本地的~/.cocoapods目录下,当我们想在国内的服务器建立了Cocoapods索引库的时候,我们可以按照如下的方法

    65470

    【IOS】CocoaPods安装总结

    /configure --prefix=/usr/local make make install 5 安装CocoaPods安装CocoaPods之前,首先要在本地安装好Ruby环境。 至于如何在Mac中安装好Ruby环境,请google一下,本文不再涉及。 假如你在本地已经安装好Ruby环境,那么下载和安装CocoaPods将十分简单,只需要一行命令。 那请小编吃饭,小编告诉你): sudo gem install cocoapods 但是,且慢。如果你在天朝,在终端中敲入这个命令之后,会发现半天没有任何反应。 按照下面的顺序在终端中敲入依次敲入命令: gem sources --remove https://rubygems.org/ //等有反应之后再敲入以下命令 gem sources -a http install cocoapods 等上十几秒钟,CocoaPods就可以在你本地下载并且安装好了,不再需要其他设置。

    9920

    安装cocoapods遇到的几点问题

    一、安装顺序:Homebrew->rvm->ruby->cocoapods 二、安装cocoapods,报错:activesupport requires Ruby version >= 2.2.2,如下图 解决办法: 1、更新Gem: sudo gem update --system 2、卸载Homebrew: ruby -e "$(curl -fsSL : rvm install 2.3.1 5、安装cocoapods: sudo gem install cocoapods 三、第一次使用pod CocoaPods会将这些podspec索引文件更新到本地的 ~/.cocoapods/目录下,这个索引文件比较大,有80M左右。 所以第一次更新时非常慢。 这是因为包含所有第三方库的repo还没下载到本地,解决办法: 1、pod repo add master https://github.com/CocoaPods/Specs.git

    90820

    代码管理| 简易教程之Cocopods的安装和使用

    Cocoapods安装安装之前,先检查本地是否已经安装好了Cocopods,如果安装好了就不用再安装了,终端输入 pod,如果出现下面图1的命令就是已经安装。 如果没有安装就需要先安装Cocoapods 1.首先更新gemGem 是一个管理 Ruby 库和程序的标准包)到最新版本,在终端中输入: sudo gem update --system 2.删除自带的 5.安装CocoaPods,终端输入: 10.11之前 $ sudo gem install cocoapods 10.11之后 $ sudo gem install -n /usr/local /bin cocoapods 安装完后可在终端输入 pod ,会有如下输出: ? (如果你的电脑没有安装,pod后就出现上面这图,说明以前就安装好了,可直接使用) Cocoapods 的使用 打开终端,切换到你的工程目录,输入下面的命令 pod init ?

    19730

    SwiftUI案例:Lottie载入动画

    第四步: 更换更快一点的镜像源 sudo gem update --system gem sources --remove https://rubygems.org/ gem sources --add https://gems.ruby-china.com/ 使用ruby安装cocopods sudo gem install -n /usr/local/bin cocoapods 安装本地库 pod setup 注意:在较新的macOS系统中,系统命令行执行pod setup命令会直接结束; 解决办法,手动安装本地库,执行如下命令: git clone https://github.com/CocoaPods /Specs.git ~/.cocoapods/repos/trunk // 等待 // 这个命令等待几分钟不一定成功,注意:不是错误,是网络问题,重新执行即可。 git clone https://mirrors.tuna.tsinghua.edu.cn/git/CocoaPods/Specs.git ~/.cocoapods/repos/trunk 至此CocoPods

    9130

    Weex 开发新手上路 - (1) 启程踩坑篇

    SDK 安装失败 开始的第一个问题:全局安装 weex-toolkit 失败CocoaPods安装 这次 ios-deploy 安装成功了,但之后马上发现还是无法启动 iOS 调试: Command failed: pod update /bin/sh: pod: command not found 搜索错误关键字 pos update,得知需要安装 cocoapods,似乎是一个 iOS 的第三方开源组件库管理器。 执行 sudo gem install cocoapods,等半天后提示从 https://ruby.taobao.org 下载失败。 最后通过手动添加 --http-proxy 参数,终于安装成功了…… 各种常用工具的配置方法: 设置 git/npm/bower/pip/gem镜像或代理 安装完毕 经过半天的折腾,环境终于安装完毕,可以在

    9920

    相关产品

    • 私有网络

      私有网络

      私有网络(VPC)是基于腾讯云构建的专属网络空间,为您的资源提供网络服务,不同私有网络间完全逻辑隔离。作为隔离网络空间,您可以通过软件定义网络的方式管理您的私有网络 ,实现 IP 地址、子网、路由表等功能的配置管理……

    相关资讯

    热门标签

    活动推荐

    扫码关注腾讯云开发者

    领取腾讯云代金券