首页
学习
活动
专区
圈层
工具
发布
  • 您找到你想要的搜索结果了吗?
    是的
    没有找到

    Navicat连接MySQL时弹出:1045:Access denied for user ‘root’@’localhost’

    错误原因: 当登录MySQL数据库出现 Error 1045 错误时,表明你输入的用户名或密码错误被拒绝访问了;MySQL服务搭建后,默认root用户是不能进行远程访问连接的。...建议在数据库搭建时,创建一远程连接的用户或者在localhost的主机上将mysql数据库下的"user"表里的"root"用户开启远程登录(把localhost这个值替换为%)。...IDENTIFIED BY “密码”; 实际操作: >mysql –uroot –p #进入mysql环境,语法:mysql –u用户名 –p数据库密码 mysql> set password for 'root...'@'%' =password('数据库英文密码'); #设置mysql数据库密码 mysql> GRANT ALL PRIVILEGES ON *.* TO “root”@”%” IDENTIFIED

    78.4K106
    领券