学习
实践
活动
工具
TVP
写文章

Ubuntu apt-get和pip更换

Ubuntu apt-get和pip更换 更新数据为国内,是为了加速安装包的增加速度。 更换apt-get数据 输入:sudo -s切换为root超级管理员; 执行命令:vim /etc/apt/sources.list; 使用命令:%d 清空所有内容; 清华数据源地址:https:// mirrors.tuna.tsinghua.edu.cn/help/ubuntu/ 选择相应的版本复制内容,点击“i”键进入编辑文本模式,粘贴内容到vim编辑窗体,点击“ESC”键进入编辑模式,输入“:wq”保存离开; 更新源:sudo apt-get update; 更新软件:sudo apt-get upgrade; pip3的安装与升级 安装pip3:sudo apt-get install python3-pip 升级pip3:sudo pip 清华的5分钟同步官网一次,建议使用。

4K61

Ubuntu 18.04更换apt-get的方法

使用apt-get安装时,会很慢,更换了国内的后,就可以解决这个问题了。 1. https://mirrors.tuna.tsinghua.edu.cn/ubuntu/ bionic-proposed main restricted universe multiverse #阿里云 ,我都试过,感觉阿里云速度更快。 更新 保存sources.list文件后需要更新apt-get。 sudo apt-get update 更新完成后就可以正常使用了。 到此这篇关于Ubuntu 18.04更换apt-get的文章就介绍到这了,更多相关Ubuntu 18.04更换apt-get内容请搜索ZaLou.Cn以前的文章或继续浏览下面的相关文章希望大家以后多多支持

5.7K31
  • 广告
    关闭

    11.11云上盛惠

    万元礼包限时领取,百款云产品特惠助力上云,云服务器2核2G低至4.2元/月

  • 您找到你想要的搜索结果了吗?
    是的
    没有找到

    apt-get update出错:N: 无法安全地用该进行更新,所以默认禁用该

    执行命令 sudo apt-get update 执行以上命令后出现 获取:1 http://mirrors.163.com/ubuntu bionic InRelease [242 kB] 获取:2 N: 无法安全地用该进行更新,所以默认禁用该。 N: 参见 apt-secure(8) 手册以了解仓库创建和用户配置方面的细节。 N: 无法安全地用该进行更新,所以默认禁用该。 N: 参见 apt-secure(8) 手册以了解仓库创建和用户配置方面的细节。 keyserver.ubuntu.com --recv-keys 3B4FE6ACC0B21F32 # 将签名更换为报错的那个 然后再次执行更新命令就可以了 root@uos-PC:/home/uos/iso# sudo apt-get 完成 如果还是不行的话,说明不行,需要换。 ​

    2.7K30

    apt-get指令

    install package #安装包 apt-get reinstall package #重新安装包 apt-get -f install package #强制安装 apt-get remove package #删除包(只是删掉数据和可执行文件,不删除配置文件) apt-get remove –purge package #删除包 ,包括删除配置文件等 apt-get autoremove –purge package #删除包及其依赖的软件包+配置文件等 apt-get update #更新源 apt-get upgrade #更新已安装的包 apt-get dist-upgrade #升级系统 apt-get dselect-upgrade #使用 build-dep package #安装相关的编译环境 apt-get source package #下载该包的源代码 apt-get clean && apt-get autoclean

    64710

    强大的 apt-get 命令

    强大的 apt-get 命令(小结) 一、ubuntu下管理软件最方便的非 apt-get 工具莫属了,它的常见用法稍微整理一下供以后参考(详细见 man apt-get ): 1.更新源,升级软件和系统之前要先干这个 ~ (源目录:/etc/apt/sources.list) sudo apt-get update 2.更新已安装的包到最新版本(若已经最新则忽略) sudo apt-get upgrade 3.升级系统 pac 也可以使用正则匹配哦 sudo apt-get install pac1 pac2 pac3… 5.删除软件,用法同 install,会保留配置文件 sudo apt-get remove pac1 source pac 8.安装相关的编译环境 sudo apt-get build-dep pac 9.更新缓存,检查是否有损坏的依赖 sudo apt-get check 10.下载二进制包到当前目录 二、及升级 1.更新源 /etc/apt/sources.list 2.升级版本 sudo apt-get install update-manager-core sudo do-release-upgrade

    52720

    apt和apt-get的区别

    您可能想知道apt-get和apt之间的区别是什么?如果他们有类似的命令结构,那么新的apt命令需要什么?您可能还在考虑apt是否比apt-get更好? apt和apt-get命令之间的区别 虽然apt确实有一些与apt-get类似的命令选项,但它并不与apt-get向后兼容。 这意味着如果只是用apt替换apt-get命令的apt-get部分,它将不会始终有效。让我们看看哪个apt命令替换了apt-get和apt-cache命令选项 我应该使用apt还是apt-get? 除非你要进行利用apt-get更多功能的特定操作,否则我认为没有理由坚持使用apt-get。 三.结论 我希望我能够解释apt和apt-get之间的区别。 最后,总结一下apt与apt-get的争论: apt是apt-get和apt-cache命令的子集,为包管理提供必要的命令 虽然apt-get不会被弃用,但作为普通用户,您应该更频繁地开始使用apt

    99420

    sudo apt-get update 报错

    1.8K40

    apt-get报错和dpkg报错

    update //更新 sudo apt-get -f install //安装 sudo mv /var/lib/dpkg/info sudo rm -rf /var/lib/dpkg/info 安装已经不报错了,但是直接安装thunderbird还是会报错,通过 sudo apt-get -f install 命令后,再用sudo apt-get -f install thunderbird命令进行安装 : sougou pinying 可以通过删除/var/lib/dpkg/info /下面所有的sougou开头的文件,再通过 sudo apt-get -f install后,再执行sudo dpkg 报错2:apt-get安装vim时候,提示: vim : Depends: vim-common (= 2:7.4.1689-3ubuntu1) but 2:7.4.1689-3ubuntu1.2 is 解决方法: sudo apt-get purge vim-common sudo apt-get update sudo apt-get upgrade sudo apt-get install vim

    1.4K40

    apt-get install 遇到依赖问题

    需要用到的部分是用了里面排名最高的回答的 Solutions: 和 Disable/Remove/Purge PPAs: 里的解决步骤 ps: 这是目前唯一一个试成了的方法 我个人实际操作时仅在 sudo apt-get –purge package-name 一句根据具体情况做了改动 另外 Additional Sources: 里的 Y-PAA-Manager 没装上,后来看来可不装 方法二: 更换, 随后更新: sudo apt-get update 删除 /var/lib/apt/lists 下的所有文件 如果还是解决不了问题,另寻办法 ---- ----

    1.6K40

    Ubuntu apt-get不能使用

    输入 apt-get 就有这个提示。 解决方法 我 google 找了一圈,也有人遇到这个问题了,不过没有说是手机的问题,我总结一下就是遇到类似的问题,都可以用下面的方法来解决。

    1.3K20

    Debian 7.8 通过 apt-get 安装 nodejs

    查看当前系统版本 aikaiyuan@debian:~$ cat /etc/debian_version 7.8 aikaiyuan@debian:~$ 安装 curl和 aikaiyuan@debian :~$ sudo apt-get install curl aikaiyuan@debian:~$ sudo curl -sL https://deb.nodesource.com/setup | bash - 安装 nodejs aikaiyuan@debian:~$ apt-get install -y nodejs (adsbygoogle = window.adsbygoogle ||

    53620

    debian apt-get update报错GPG error

    ftp-master.debian.org/archive-key-5.0.asc 然后 apt-key add archive-key-5.0.asc OK 也有可能是另一个问题: 在本本装上Debian后,用apt-get update更新软件时,出现以下warning: GPG error: http://debian.linux.org.tw etch Release: 由于没有公钥,下列签名无法进行验证: NO_PUBKEY 07DC563D1F41B907 解决方案: 首先,确保已经安装了以下程序 #apt-get install gnupg 然后,手动导入所需公钥 #gpg –keyserver keyring.debian.org recv-keys 07DC563D1F41B907 #gpg –armor –export 07DC563D1F41B907 | apt-key add – 当屏幕显示“OK”后,就可以重新更新软件

    8010

    apt-get update遇到NO_PUBKEY

    这是因为给 Ubuntu 安装软件的时候需要做验证,当然了,这个并不是必须的,也就是你的容器里也可以装没有经过认证可能不安全的中安装需要的软件,虽然不建议,但是有时候为了快速调试,比如在公司内部的里安装软件 如果遇到 NO_PUBKEY 的问题,如下: root@spark-sparkoperator-58f598c98b-x7vjn:/etc/apt/trusted.gpg.d# apt-get update creation and user configuration details. root@spark-sparkoperator-58f598c98b-x7vjn:/etc/apt/trusted.gpg.d# apt-get

    67130

    Linux中yum和apt-get

    Ubuntu等 ---- RedHat 系列 -包管理工具 yum 1 常见的安装包格式 rpm包,安装rpm包的命令是“rpm -参数” 2 包管理工具 yum Debian系列-包管理工具 apt-get 1 常见的安装包格式 deb包,安装deb包的命令是“dpkg -参数” 2 包管理工具 apt-get ---- 更多请参考 : Linux中yum和apt-get用法及区别

    28530

    apt 和 apt-get 的区别

    apt和apt-get命令之间的区别 虽然 apt 与 apt-get 有一些类似的命令选项,但它并不能完全向下兼容 apt-get 命令。 apt 命令 取代的命令 命令的功能 apt install apt-get install 安装软件包 apt remove apt-get remove 移除软件包 apt purge apt-get apt-cache show 显示装细节 当然,apt 还有一些自己的命令: 新的apt命令 命令的功能 apt list 列出包含条件的包(已安装,可升级等) apt edit-sources 编辑列表 apt-get已弃用? 目前还没有任何 Linux 发行版官方放出 apt-get 将被停用的消息,至少它还有比 apt 更多、更细化的操作功能。对于低级操作,仍然需要 apt-get。 我应该使用apt还是apt-get? 既然两个命令都有用,那么我该使用 apt 还是 apt-get 呢?作为一个常规 Linux 用户,系统极客建议大家尽快适应并开始首先使用 apt。

    13720

    bash: 一键apt-get更新

    一键 apt-get更新 的 bash文件 源码: echo 'apt-get operation' sudo apt-get update sudo apt-get upgrade sudo apt-get -f install ---- ----

    53210

    Ubuntu dpkg ---- apt-get ------ aptitude 区别及作用

    aptitude        autoclean #同上 编译相关   apt-get source package #获取源码 apt-get          build-dep   package 更新源 apt-get       update #更新源 aptitude     update #同上 更新系统 apt-get             upgrade #更新已经安装的软件包 * apt-get install packagename——安装一个新软件包(参见下文的aptitude ) * apt-get remove packagename——卸载一个已安装的软件包(保留配置文件 * apt-get autoclean apt会把已装或已卸的软件都备份在硬盘上,所以如果需要空间 的话,可以让这个命令来删除你已经删掉的软件 * apt-get clean 这个命令会把安装的软件的备份也删除 与apt-get类似,aptitude可以通过命令行方式调用,但仅限于某些命令——最常见的有安装和卸载命令。由于aptitude比apt-get了解更多信息,可以说它更适合用来进行安装和卸载。

    93320

    pip、brew、apt-get区别和作用

    packagename 4、卸载软件 pip uninstall packagename 5、列出已安装软件 pip list 6、查看一个软件包时安装了哪些文件 pip show -f packagename apt-get apt-get命令一般需要root权限执行,所以一般跟着sudo命令。 版本等 apt-cache show packagename 3、安装包 apt-get install packagename 4、已安装包重新安装 apt-get install packagename --reinstall 5、 删除包 apt-get remove packagename 6、删除包,包括删除配置文件等 apt-get remove packagename --purge 7、更新源 apt-get update 8、更新已安装的包 apt-get upgrade 8、了解使用依赖 apt-cache depends packagename

    19010

    ubuntu中apt-get的卸载参数

    很多情况下,当我们遇到一些软件出错的时候,我们正常会选择重新安装软件来初始化我们的配置文件,然而事实上,仅仅调用普通的apt-get remove 命令是不能完全重新安装软件的。 后来才发现其实只要在卸载的时候加上这个参数再重新安装软件即可: myths@myths-X450LD:~$ sudo apt-get remove --purge vsftpd 这个命令虽然十分简单,但是绝对实用

    6820

    扫码关注腾讯云开发者

    领取腾讯云代金券