展开

关键词

首页关键词cocoapods安装

cocoapods安装

安装的方式非常简单,Mac下已经自带了ruby,只要使用ruby的gem命令就可以安装了。打开的Mac的终端,在终端运行下面的命令:$[sudo]geminstallcocoapods$podsetup

相关内容

  • CocoaPods安装过程小记

    今年过年时刚买了台MBP,准备在新本上进行开发,顺便记录下安装CocoaPods过程。CocoaPods$ sudo gem install -n usrlocalbin cocapods现在可能会遇到第一个错误:ERROR: Error installing cocoapods: activesupport$ rvm use 2.3.0再次安装CocoaPods$ sudo gem install -n usrlocalbin cocoapods   回到刚开始出错的地方,重新执行,会开始下载100多兆的文件,开始等$pod setup     成功后绿色字体显示:Setup completed到这里cocoapods已经安装完毕可以使用 $pod search FMDB测试一下setup会下载Podspec文件,可以cd至安装目录,用du -sh *来查看下载进度
    来自:
    浏览:552
  • Cocoapods安装和使用

    安装 打开终端,按照以下输入命令,特别注意https和http,一定要写https 1.查看是否是Ruby镜像 查看镜像命令:gem sources -l?2.把ruby镜像移除掉,利用淘宝镜像,安装cocoapods 删除命令:gem sources --remove https:rubygems.org 添加命令:gem sources -a https注意:https安全协议 3.下载安装Cocoa pods 下载命令:sudo gem install cocoapods?https:ruby.taobao.org 更新ruby: sudo gem update --system 如果提示没有权限使用下面的命令:sudo gem install -n usrlocalbin cocoapods这样cocoapods就更新了
    来自:
    浏览:265
  • 广告
    关闭

    云产品限时秒杀

    云服务器1核2G首年50元,还有多款热门云产品满足您的上云需求

  • 您找到你想要的搜索结果了吗?
    是的
    没有找到
  • CocoaPods的安装使用

    二.CocoaPods 的安装1.替换源 CocoaPods 是基于 ruby ecosystem 的,需要 ruby 环境,使用 ruby 的 gem 命令。所以我们的系统要有 ruby 环境。添加镜像 $gem sources -a https:gems.ruby-china.com (3).重新安装 $sudo gem install -nusrlocalbin cocoapods?安装时报错截图报错原因:command line tools没有安装。(4).重新安装 $sudo gem install -nusrlocalbin cocoapods。?又报错报错原因:xcode版本和现在CocoaPods的版本问题不匹配。解决方案:更新cocoaPods的版本 ,在终端执行如下命令:$gem install cocoapods --pre。再重新执行安装,即安装成功!
    来自:
    浏览:415
  • cocoapods从安装到使用

    cocoapods安装0.升级安装Ruby环境 CocoaPods 是使用 Ruby 实现的,可以通过 gem 命令来安装。$sudo gem install cocoapods 这个命令默认安装的应该是最新版本,如果想安装指定版本的cocoapods,请使用以下命令:$sudo gem install cocoapods如果安装失败那么 ~.cocoapods 里面是空的,就需要以下两个命令重新setup。到这里你已经成功安装了CocoaPods!还有一种更方便的方式,就是使用CocoaPods插件。CocoaPods的安装和使用非常简单,和其他插件的安装一样,此处不再赘述。
    来自:
    浏览:8394
  • CocoaPods安装失败“无法构建gem本地扩展”

    我无法通过以下命令将cocoapods安装到我的Mac Catalina: 以下是来自终端的错误消息:
    来自:
    回答:2
  • iOS - 如何解决 CocoaPods 安装慢的问题

    ,需要使用CocoaPods安装依赖;但是有使用过这个工具的朋友一定会被这个工具折腾过;最折腾的在于 pod update 时间过长,这篇文章就是解决这个问题的过程和最终方案;2、原因分析使用 CocoaPods会将这些podspec索引文件 更新 到本地 ~.cocoapods 目录下。--no-repo-update这样安装依赖的速度就会提升很多,你可以每隔1个月再自己手动更新一次官网即可;5.总结上面讲了这边多,我们总结一下使用 CocoaPods 的正确方式:正常安装 CocoPods去官网clone仓库放到 ~.cocoapodsreposmaster 目录下重新执行 pod setup后续安装依赖使用 pod install --verbose --no-repo-update 安装依赖从发现问题到解决问题,花费了我近1天的时间,主要都是花费在 网络下载 - 下载失败 - 尝试重新下载
    来自:
    浏览:1699
  • CocoaPods安装错误

    我试图在我的项目中安装CocoaPods,但我总是出错 LibraryRubyGems2.0.0gemscocoapods-0.35.0libcocoapodsuser_interfaceerror_report.rb
    来自:
    回答:1
  • Cocoapods的安装及使用

    引入Cocoapods的意义:Cocoapods在引入第三方库时自动为我们完成各种配置,包括配置编译阶段、连接器选项、甚至是ARC环境下的-fno-objc-arc配置等;Cocoapods可以很方便的查找第三方库一、 配置Ruby环境,安装CocoaPodsCocoaPods是基于ruby ecosystem的,需要ruby环境,使用ruby的gem命令。然而Mac系统默认会安装好ruby环境。安装cocoapods,需要输入用户密码,输入完成后,按回车键,需要等待许久后才能完成安装,成功安装后会有提示pod --version 查看是否安装成功,如果成功会显示pod的版本pod setup搜索成功会显示类库的信息----二、安装成功,使用CocoaPods 在使用CocoaPods之后,我只需要将用到的第三方开源库放到一个名为Podfile的文件中,然后执行pod install。
    来自:
    浏览:390
  • 安装cocoapods遇到的几点问题

    一、安装顺序:Homebrew->rvm->ruby->cocoapods二、安装cocoapods,报错:activesupport requires Ruby version >= 2.2.2,如下图卸载Homebrew: ruby -e $(curl -fsSL https:raw.githubusercontent.comHomebrewinstallmasteruninstall) 3、重新安装Homebrew: ruby -e $(curl -fsSL https:raw.githubusercontent.comHomebrewinstallmasterinstall) 4、安装rvm2.3.1: rvm install 2.3.1 5、安装cocoapods: sudo gem install cocoapods三、第一次使用pod install前,需要先pod setup。CocoaPods会将这些podspec索引文件更新到本地的 ~.cocoapods目录下,这个索引文件比较大,有80M左右。所以第一次更新时非常慢。
    来自:
    浏览:451
  • CocoaPods 安装配置

    首先安装配置好 ruby,CocoaPods 需要 Ruby 的版本大于 2.2.2,不然会报错:Error installing pods: activesupport requires Ruby versiongems.ruby-china.org $ gem sources -l *** CURRENT SOURCES ***https:gems.ruby-china.org # 出现以上提示说明添加成功安装$ sudo gem install -n usrlocalbin cocoapods 若 Xcode 为预览版 ,在命令后边添加 --pre查看版本$ pod --version $ sudo xcode-selectAFNetworking, ~> 2.6 pod ORStackView, ~> 3.0 pod SwiftyJSON, ~> 2.3end # 输入以上内容,target **** do 单引号内填入你自己的项目名称安装
    来自:
    浏览:428
  • Cocoapods 制品库

    准备工作 注意: 阅读该篇文档需要准备好以下内容: 安装 Cocoapods。参见 基础操作 创建制品仓库。制品仓库选择 Cocoapods 类型。 安装执行命令安装 Cocoapods。$ sudo gem install cocoapods-- 或$ brew install cocoapods 新建 Demo 项目本节对如何快速创建一个 Demo Cocoapods 制品 提供指引,若您已熟悉 Cocoapods 制品制作可以跳过本节。配置认证信息首先安装 CODING Cocoapods 插件。 sudo gem install cocoapods-coding-ar接下来您可以选择自动生成配置或手动配置,下文以自动生成配置为例。拉取制品根据 Cocoapods 制品仓库中具体制品的拉取指引可以拉取指定 Cocoapods 制品。 修改 Podfile 文件配置。
    来自:
  • CocoaPods 2017最新、最快安装和使用说明

    简介:CocoaPods是OS X和iOS下的一个第三类库管理工具,通过CocoaPods工具我们可以为项目添加被称为“Pods”的依赖库(这些类库必须是CocoaPods本身所支持的),并且可以轻松管理其版本安装CocoaPods本文开发环境为 iMac OS X 10.10.3,(最近安装最新版本: 10.13 )安装 CocoaPods之前,要先确保电脑本地是否有 Ruby环境,因为CocoaPods运行于接下来的安装过程:  以前用到的镜像有淘宝的:   gem sources -a https:ruby.taobao.org(停止维护)                                     gam:  2.6.14)你的要不是最新的,你可以试着升级一下gem :  sudo gem update --system************   2017 - 07-10 更新   再次执行命令安装安装成功后你执行pod setup或者是你直接pod search AFNetworking  这时候你会遇到的问题是:Setting up CocoaPods master repo真的,很恶心,我下载的速度都是在十几
    来自:
    浏览:270
  • CocoaPods使用详解

    CocoaPods安装与使用RubyCocoaPods可以很方便的使用Mac自带的RubyGems安装(Mac系统默认安装了Ruby环境),如果不确定自己系统中是否有Ruby的,可以使用ruby -v来查看CocoaPods安装CocoaPods的安装是非常简单的,但是需要注意的是ruby的软件源rubygems.org因为使用亚马逊的云服务,好像被我天朝隔离了。*** CURRENT SOURCES *** https:ruby.taobao.org5,安装CocoaPods,安装命令如下:sudo gem install cocoapods安装过程中,常见的错误如下sudo nvram boot-args=rootless=0sudo reboot此时,在执行安装命令:sudo gem install cocoapods -V如果依旧有错误,使用第二个方法:sudogem install -n usrlocalbin cocoapodspod setup当出现Setup completed的时候,说明CocoaPods安装成功。
    来自:
    浏览:451
  • 如何安装和使用cocoapods来集成第三方库(实战篇)配置初始项目2.cocoapods的使用

    配置初始项目 1.cocoapods的安装cocoapods的安装是通过ruby,幸运的是Mac电脑都是默认安装ruby的,所以安装ruby的过程就省去了,唯一的前提就是安装Xcode的CommandLineToolscommandLineTools的安装也很简单,只要在终端输入以下命令:$ xcode-select --install如果确实没有安装commandLineTools会提示你要安装它,点安装就可以开始下载,然后等待下载完成后安装即可 但是由于中国的互联网是墙的原因,所以呢,你要改变gem的默认下载源: $ gem sources -a http:ruby.taobao.org 看到以下结果 http:ruby.taobao.org:$ gem sources -r https:rubygems.org看到以下结果就说明已经成功 https:rubygems.org removed from sources 然后呢,就可以愉快地安装上for cocoapods-0.38.2 9 gems installed OK,cocoapods顺利安装完毕!
    来自:
    浏览:235
  • iOS-安装和使用 CocoaPods

    Seguin 二、安装 ruby 环境 *Tips: 如果ruby的版本低于2.2.2,安装CocoaPods会报错,所以建议先升级ruby环境,建议升级到2.3.0以上版本。此处我还没有查明到底是因为什么报错,但是我关闭Terminal以后,再次安装的时候就可以正常安装了。Cocoapods终端执行命令,以管理员的身份安装sudo gem install cocoapods安装成功(出现gems installed证明安装成功) Fetching: nanaimo-0.2.3安装完成以后的输出Setting up CocoaPods master repo $ usrbingit clone https:github.comCocoaPodsSpecs.git master如果安装 CocoaPods 时不执行此命令,在初次执行 pod intall 命令时,系统也会自动执行该指令(这个我并没有试过,只是网上有这种说法) ----六、使用 Cocoapods 给项目安装第三方框架新建一个项目到桌面
    来自:
    浏览:1118
  • CocoaPods升级

    前提是你以前已经安装过CocoaPods 1、查看当前pod版本pod --version2、命令行安装 先更新gemsudo gem update --system 需要漫长的等待3、依次执行命令brew-a https:ruby.taobao.orggem sources -l*** CURRENT SOURCES *** https:ruby.taobao.orgsudo gem install cocoapods安装cocoapodspod setup##大功告成!!!
    来自:
    浏览:1287
  • CocoaPods和GitHub叉?

    这是我第一次分叉一个GitHub项目,我也不太擅长CocoaPods,所以请耐心等待我。REActivityViewController, ~> 1.6.7, :git => https:github.comREActivityViewController.git 然后我对叉子做了一些修改,当然,当我做一个pod install为了安装另一个吊舱,它重新安装了原来的REActivityViewController抹去了我的改变。我意识到我需要在另一个之前把我的改变推到我的叉子上pod install但是我该如何做到这是CocoaPods安装的回购工具呢?我看了看REActivityViewController目录下安装的文件夹。Pods文件夹中没有任何git文件。 我是否需要在项目之外处理我的叉子,然后使用CocoaPods安装更改?
    来自:
    回答:2
  • CocoaPods与Ruby安装,配置,及使用详细记录(Mac环境)

    当我们为App工程导入第三方库的时候经常用到CocoaPods这个工具,这篇文章就介绍安装CocoaPods的详细记录。附:笔者介绍另一种导入第三方库工具Carthage的文章,可以另外点击进入查看http:www.jianshu.comp1de99aeedbf61.给Mac安装Ruby环境1.1 首先要安装好RVM $Aborting.``` ### 2.给Mac安装CocoaPods- 安装CocoaPods > $ gem install cocoapods ```miki:~ ChenMan$ gem install第三库名称,名称一定要正确,不然有可能安装失败。See `https:guides.cocoapods.orgsyntaxpodfile.html#platform`. ```若出现`pods installed`字样表示安装成功。
    来自:
    浏览:377
  • 新版Cocoapods更新 CDN

    新版Cocoapods(1.8)更新升级cocoapods到大于等于1.8之后就可以使用CDN下载代码仓库,速度将得到质的飞跃。强烈建议大家使用!要求: OS X大于等于 10.11 Ruby大于2.2.21、安装rvm命令行工具$ curl -L get.rvm.io | bash -s stable 需要一点时间 $ source ~.bashrcSeguin 2、Ruby的安装cocoaPods需要Ruby版本大于2.2.2。先检测一下当前版本。$ sudo gem update -n usrlocalbin —system5、安装cocoaPods 如果之前有$ sudo gem uninstall cocoapods (移除原来的cocoapods) 安装CocoaPods(10.11后苹果升级了安全策略)$ sudo gem install -n usrlocalbin cocoapods新版的 CocoaPods 不允许用pod repo add
    来自:
    浏览:535
  • CocoaPods安装卡在终端上的POD安装命令上?

    verboseSystemLibraryFrameworksRuby.frameworkVersions2.0usrlibruby2.0.0universal-darwin13rbconfig.rb:212: warning: Insecure world writable dir usrlocalbin in PATH, mode 040777 Setting up CocoaPods已经通过CocoaPods网站提供的资源,所以很少视频教程。即使在等待了几个小时之后,也没有发生什么事,但是仍然试图弄清楚到底是什么问题?我非常感谢你的评论和建议。谢谢!!!
    来自:
    回答:2

扫码关注云+社区

领取腾讯云代金券