展开

关键词

版本php配置composer

wdlinux支持多个版本的php共存,安装composer的时候就不知道咋弄了,其实很简单 1.首先进入到你的那个php路径的bin目录下,比如我这个/www/wdlinux/phps/73/bin/ 100 269k 0 0 13632 0 0:00:20 0:00:20 --:--:-- 18581 All settings correct for using Composer Composer (version 2.0.6) successfully installed to: /www/wdlinux/phps/73/bin/composer.phar Use it: php composer.phar 2.就会下载到这个目录使用 命令:/www/wdlinux/phps/73/bin/php /www/wdlinux/phps/73/bin/composer.phar require

5910

手动升级宝塔的 composer 版本

服务器的 Composer 版本一直都是 1.5-dev,在面板里面升级Composer也提示“当前已是最新版本,无需升级!”。显然,通过面板无法正常升级Composer版本,只能通过其他方式升级。 PHP Warning: putenv() has been disabled for security reasons in phar:///usr/bin/composer/bin/composer /www/server/php/74/bin/php -d "disable_functions=" /usr/bin/composer self-update 如果你的宝塔没有安装php7.4,需要把命令中的 74改成你安装的版本。 5.6对应56,7.0对应70,7.1对应71 最后,完成升级 composer 到最新版本,可以愉快的在面板里正常使用 composer 了。 ----- 最后的最后,还有一个福利。

27320
  • 广告
    关闭

    腾讯云精选爆品盛惠抢购

    腾讯云精选爆款云服务器限时体验20元起,还有更多热门云产品满足您的上云需求

  • 您找到你想要的搜索结果了吗?
    是的
    没有找到

    Composer 设置忽略版本匹配的方法

    简介 Composer是PHP中用来管理依赖(dependency)关系的工具。你可以在自己的项目中声明所依赖的外部工具库(libraries),Composer会帮你安装这些依赖的库文件。 接下来通过本文给大家介绍Composer设置忽略版本匹配的方法,需要的朋友参考下吧 执行composer install遇到错误:Your requirements could not be resolved 这是因为不匹配composer.json要求的版本。 提示我的PHP 7版本太高,不符合composer.json需要的版本,但是在PHP 7下应该也是可以运行的,composer可以设置忽略版本匹配,命令是: 解决方案 composer install --ignore-platform-reqs or composer update --ignore-platform-reqs 再次执行composer命令可以正常安装包了。

    63730

    Composer 版本约束表达式的使用

    相信 Composer 对你来说已经相当熟悉了,不过对于包的版本,我觉得应该还有不少同学不是那么清楚各种写法到底是啥意思。 语义化版本 首先,我们来了解一个东西:语义化版本 版本格式:主版本号.次版本号.修订号,版本号递增规则如下: 主版本号:当你做了不兼容的 API 修改, 次版本号:当你做了向下兼容的功能性新增, 修订号 那在 composer 使用过程中我们通常会有这几种写法: 不限定版本 极不推荐这样玩哦 使用 * 号来表示版本的时候,composer 会根据你配置中的 minimum-stability 的值情况来决定安装最新的 比如: "require": { "overtrue/wechat": "*" } 根据上面语义化版本的定义,这样写就相当于允许大版本的安装,那你的代码在 composer 最后就是使用具体版本号 使用 =1.2.34 或者 1.2.34 都是指定了具体的版本号, composer 不会考虑检查新版本来安装。

    58630

    在多版本php环境,指定composer使用的php版本

    不同的项目中,可能会使用不同的php版本,在使用 composer 安装依赖时,如何指定不同的php版本呢? 比如平时开发时,使用的是 php 7.0版本,但是在按照 Laravel最新版本(5.6) 时就跑不同了。因为在Laravel 5.6中, 最低要求版本是 PHP 7.1.3. // 直接使用默认php版本 $ composerrequirelaravel/passport // 使用指定的php版本(php7.2) $ php72 composer.pharrequirelaravel /passport 再看一下使用对比: // php7.2全路径: // 使用默认php版本: $ composer update // 使用指定php7.2版本: $ /usr/ local/bin/php72 composer.phar update // 使用默认php版本: $ composer install // 使用指定php7.2版本

    65940

    composer self-update 更新版本

    1. self-update 命令官方文档 版本号:https://getcomposer.org/download 中文网:https://docs.phpcomposer.com/03-cli.html 版本更新使用示例 查看当前composr版本(大写的V) composer -V 当前composer更新为最新版 composer self-update 更新到指定版本 composer self-update 版本回滚 回滚到安装的上一个版本 composer self-update -r 4. 版本更新并删除旧版本的备份 composer self-update --clean-backups

    6420

    composer 版本号前置~与^符号的区别

    版本规则: 主版本号.次版本号.修订号 ^ 表示除了大版本号,其他都可以变 "php": "^7.3|^8.0", 意思是 7.3<=版本号<8.0 或者 8.0<=版本号<9.0 ~表示版本号只能改变最末尾那段,更严格一点 "mockery/mockery": "~1.3.2" 意思是 1.3.2<=版本号<1.4.0 "symfony/http-kernel": "~2.7|~3.0|~4.0|~5.0" 意思是 2.7<=版本号<3.0 或者 xxxxxxx

    15010

    Composer进阶使用之版本约束表达式的使用

    先行版本号及版本编译信息可以加到“主版本号.次版本号.修订号”的后面,作为延伸 版本约束 例如我们想要下载5.1版本的ThinkPHP包,我们可以通过composer.json文件: { "require ": { "topthink/framework": "5.1" } } 然后运行install命令,或者通过require命令来加载扩展包 $ composer require topthink /framework:5.1 # 或者 $ composer require topthink/framework=5.1 # 或者 $ composer require topthink/framework 其中与的优先级会大于或 这样的使用场景并不多,根据你的情况来调整就好 精确版本 可以指定具体的版本,告诉Composer只能安装这个版本。 原创文章采用CC BY-NC-SA 4.0协议进行许可,转载请注明:转载自:Composer进阶使用之版本约束表达式的使用

    47731

    Composer

    Composer是PHP中用来管理依赖(dependency)关系的工具。你可以在自己的项目中声明所依赖的外部工具库(libraries),Composer会帮你安装这些依赖的库文件。 如果A依赖B的版本是1.0.0,如果C依赖B的版本是2.0.0,项目当中是否没导入同一包用不同版本的。 虽然已被官方废弃,但因为主流框架都已实现psr-0,因此composer仍然使用psr-0来向下兼容。 psr-4方式,是composer推荐使用的一种方式,也是psr-0的替代方案,因为在PSR-0中目录结构要与命名空间层层对应,无法插入一个单独的目录。 vendor/composer/autoload_classmap.php 文件中 files方式,就是手动指定供直接加载的文件

    69770

    Composer介绍

    d) Composer 会找出哪个版本的包需要安装,并安装它们(将它们下载到你的项目中)。 声明依赖关系 比方说,你正在创建一个项目,你需要一个库来做日志记录。你决定使用 monolog。 .*"} } 我们只要指出我们的项目需要一些 monolog/monolog 的包,从 1.2 到 1.3 之间的最高版本。 系统要求 运行 Composer 需要 PHP 5.3.2+ 以上版本。 我们将从包的来源直接安装,而不是简单的下载 zip 文件,你需要 git 、 svn 或者 hg ,这取决于你载入的包所使用的版本管理系统。 现在只需要运行 composer 命令就可以使用 Composer 而不需要输入 php composer.phar。 使用 Composer 现在我们将使用 Composer 来安装项目的依赖。

    60280

    composer autoloader

    大家都知道composer吧,它是 PHP 用来管理依赖(dependency)关系的工具。 今天不是说composer的,是关于如何管理由composer加载的大量packages。 1 什么是autoloading? '/vendor/autoload.php'; $a = new A(); 使用classmap,告诉composer这是做映射的方法,细节的话可以看运行composer install a) Classmap:最简单,在vendor / composer / autoload_classmap.php中,当composer自动加载类时,它扫描所提到目录中的所有文件(在composer.json b) PSR-0: 当这个逻辑存在在 vendor/composer/autoload_namespaces.php, 要遵循PSR-0规则. c) PSR-4: 当存在在 vendor/composer

    17210

    版本Discuz! Q内测体验 记录Composer安装过程

    Q 安装软件环境 这里,根据官方文档,我们可以看到如果需要安装Q版本,则需要服务器支持下列环境。 Q 使用 Composer 来管理项目依赖。因此,在使用 Discuz! Q 之前,请确保你的机器已经安装了 Composer。 第二、下载内测Discuz! 我们在执行下载过程中看到速度是比较慢的,因为composer会自动下载Discuz! Q和依赖的所有第三方库。由于composer自身的原因,在下载第三方库时可能会比较慢。 第三、WEB服务器配置 根据官方建议,我们需要将安装DISCUZ Q版本的域名启用HTTPS,而且是支持APACHE和NGINX的,但是配置方法不同。 参考网站:https://discuz.chat/docs/ 本文出处:老蒋部落 » 新版本Discuz! Q内测体验 记录Composer安装过程 | 欢迎分享

    12420

    shell 安装 composer

    Composer (version 1.3.0) successfully installed to: /usr/local/bin/composer Use it: php /usr/local/bin /composer 这样我们就可以使用composer进行类库安装了。 修改为国内镜像 全局修改 composer config -g repo.packagist composer https://packagist.phpcomposer.com 碰到的问题 phar ' with message 'phar "/usr/local/bin/composer" has a broken signature' in /usr/local/bin/composer:23 Stack trace: #0 /usr/local/bin/composer(23): Phar::mapPhar('composer.phar') #1 {main} thrown in /usr

    73820

    Composer的安装

    Composer是什么? Composer是 PHP 用来管理依赖关系的工具。 借助Composer我们可以轻易的完成很多工作.极大地提高开发效率.例如验证码.你可能需要通过去了解构建画布.显示验证码.干扰线条怎么完成.等等一些很繁琐的工作.而你只需要通过Composer下载一个包 安装Compsser 首先.你的PHP 版本5.3.2+ 才能运行。 下载链接 https://getcomposer.org/download/ 无脑下一步就好 然后检查下环境变量中当前环境下是否有了Composer.然后在窗口执行composer,看到如下效果表明安装成功 执行下列命令 composer config -g repo.packagist composer https://packagist.phpcomposer.com 到此.Composer的安装已经完成

    36320

    composer

    composer config -g repo.packagist composer https://packagist.phpcomposer.com composer self-update

    27820

    composer init初始化composer.json文件

    当想要初始化一个php项目的时候 , 或者想要开发一个类库给别人使用的时候 都需要一个composer.json文件 直接在项目目录输入 composer init 按照引导就可以生成了 , 详细的引导解释如下 This command will guide you through creating your composer.json config 输入最低稳定版本,stable, RC, beta, alpha, dev Minimum Stability []:dev # 5. 输入版本号 Enter the version constraint to require (or leave blank to use the latest version): >=5.4.0 # 是否生成composer.json Do you confirm generation [yes]?

    19230

    composer改源

    composer config -g repo.packagist composer mirrors.aliyun.com/composer/

    27751

    composer的使用

    Composer 是 PHP 的一个依赖管理工具。它允许你申明项目所依赖的代码库,它会在你的项目中为你安装他们。 我们可以用Composer方便安装PHP库。 安装composer linux curl -sS https://getcomposer.org/installer | php mv composer.phar /usr/local/bin/composer window 下载并且运行 Composer-Setup.exe,它将安装最新版本Composer ,并设置好系统的环境变量,因此你可以在任何目录下直接使用 composer 命令。 Packages https://packagist.org/ 中文镜像 https://pkg.phpcomposer.com/ 安装插件 基于composer.json安装 composer install composer update { "require": { "monolog/monolog": "1.0.*" } } 基于命令 composer create-project

    27710

    Composer系列之四

    我们可以使用 composer config --list 来看看当下可以配置的所有项(composer默认项 + 当前项目项,当前项目优先)。 这个命令也有挺多的参数 --stability (-s): 资源包的最低稳定版本,默认为 stable。 --prefer-source: 当有可用的包时,从 source 安装。 info 这个参数比较简单,如果你用 composer info 则会直接列出当前项目的所有依赖(名称+版本+简介),如果你使用 composer info abei2017/yii2-emoji跟了一个扩展 --all 这是一个很大的命令,列出在packagist.org上所有可用的扩展(名字 + 版本 + 简介) --installed (-i) 列出我们项目安装的扩展 --platform (-p) --name-only (-N) 只显示名字(不显示版本和简介) --path (-P) 显示当前项目安装的扩展的物理目录。

    13420

    相关产品

    • 消息队列 CKafka

      消息队列 CKafka

      CKafka(Cloud Kafka)是一个分布式的、高吞吐量、高可扩展性的消息系统,100%兼容开源 Kafka API(0.9版本)。Ckafka 基于发布/订阅模式,通过消息解耦,使生产者和消费者异步交互,无需彼此等待。Ckafka 具有数据压缩、同时支持离线和实时数据处理等优点,适用于日志压缩收集、监控数据聚合等场景。

    相关资讯

    热门标签

    扫码关注腾讯云开发者

    领取腾讯云代金券