展开

关键词

CentOS7Docker

首先一下系统包 (可以跳过)$ sudo yum update卸载旧的 Docker$ sudo yum erase docker docker-common docker-client docker-compose https:yum.dockerproject.orgrepomaincentos7enabled=1gpgcheck=1gpgkey=https:yum.dockerproject.orggpg安装

79770

OpenSSH(8.4)

OpenSSH8.4上传至服务器或wget直接下载wget https:cdn.openbsd.orgpubOpenBSDOpenSSHportableopenssh-8.4p1.tar.gz3、删除低

13.9K156
  • 广告
    关闭

    90+款云产品免费体验

    提供包括云服务器,云数据库在内的90+款云计算产品。打造一站式的云产品试用服务,助力开发者和企业零门槛上云。

  • 您找到你想要的搜索结果了吗?
    是的
    没有找到

    OpenSSL(1.1.1)

    注意:的稳定是1.1.1系列(https:www.openssl.orgsource)1.查看openssl,目前是1.0系列。 openssl versionSnipaste_2020-12-20_14-20-01.png2.下载稳定的OpenSSL源码包。 然后再次执行openssl version 查看会发现还是OpenSSL 1.0.2k-fips 。出现这情况并不是没有成功。而是该会话还是原来的会话。端来或者重开启的会话即可。 Snipaste_2020-12-20_15-10-45.png开启的会话执行openssl version查看则显示为后的。 Snipaste_2020-12-20_15-17-21.png说明:后如果执行 openssl version 命令出现openssl: error while loading shared libraries

    6.9K41

    如何LTSSonarQube 7.9.1 ?

    整体思路准备测试数据(实际环境可跳过此步骤)数据库迁移(从7.9开始,SonarQube将不再支持MySQL,Mysql-->PG)Sonar(6.7.7 -> 7.9.1)准备测试数据创建用户数据 将sonarqube到7.9.1 LTS7.9.1安装JDK11#因为现在在通过jdk8运行sonar6.7.7,所以暂时可以不配置全局变量,完成后将jdk11配置成全局即可。 哈哈哈哈哈 完成了,数据未丢失??总结完成,剩下的就需要安装相关的插件了。 ERROR: relation schemamigrations does not exist创建的空的PG是不能进行迁移的,需要同的soanr使用后才会找到和这个表! = 2804此问题一定要注意在做数据库迁移的时候,先运行一个同sonar进行迁移哦!3.迁移完成没有数据怎么办?是不是我操作错误了?

    1K31

    Spring Cloud Greenwich ,舒服了~

    去年将 Spring Cloud 到了 Finchley :Spring Cloud Finchley ,踩了所有的坑!这个大栈长是踩了非常多的坑啊,帮助了不少小伙伴。 Greenwich发布也快 1 年了,栈长迟迟没有,距离上个大一年多了,所以栈长近将 Spring Cloud 到了 Greenwich,几乎没踩多少坑,但也有坑,这里再记录分享一下, 依赖前 => 后Spring Cloud Finchley.RELEASE => Spring Cloud Greenwich.SR3Spring Boot 2.0.2.RELEASE => 分不清这些的区别和意义?可以参考栈长之前写的关于的文章:Spring Cloud 多怎么选择?。 未完,栈长将陆续分享 Spring Cloud 技术教程,现在已经写了一堆存货了,关注微信公众号 Java技术栈 ,公众号第一时间推送!@ All 码农们:你们了吗?有遇到什么样的坑?

    49510

    Typecho程序的佳姿势

    如今我们需要做网站可选择的程序很多,其中选择多的应该是WordPress,毕竟提供的主题和插件丰富。 但是,如果是轻便型的个人日志网站,选择Typecho程序的也比较多的,虽然这么多年很慢,但是基的功能就是走的轻便,也不可能去增加太多的功能。 如果我们使用的是老的,如果需要应该如何操作呢?这篇文章老蒋记录Typecho程序的佳姿势。 第一、下载下载地址:http:typecho.orgdownload这里我们下载Typecho程序。 第二、替换文件这里我们需要替换 admin 、var、index.php 2个文件夹中所有内容与index.php文件就可以。第三、登录登录后台,点击完成,这样才算全部完成。

    7440

    mysql(mysql8.0.25)

    过程MySQL 8.0.16之前:1.关闭 MySQL,替换的二进制 MySQL2.启动 MySQL,让服务器 DD(数据字典)表3.运行 mysql_upgrade,更系统表和用户表4.加载的帮助表 5.重启 MySQLMySQL 8.0.16之后:1.关闭 MySQL,替换的二进制 MySQL2.启动 MySQL, DD(数据字典)表和系统表、用户表和帮助表 次验证从mysql8.0.18 的mysql8.0.25环境:mysql:mysql 8.0.18部署方式是:二进制解压安装架构:一主一从复制(开启gtid复制)前检查:下载安装一个mysqlshell工具执行util.checkForServerUpgrade MySQL 10.1.1.14:3308 JS > 对检查发现的问题进行修正2.根据需要确定是否需要修改配置文件配置项,目前环境不需要做任何修改3.下载的二进制包,并解压,修改属主属组cd usrlocalwget --------+9.按照同样方式主库,并启动复制10.测试业务跑基的流程11.备份工具,已进行的备份xtrabackup工具到8.0.25-17

    1.1K41

    mysql官网下载安装教程

    mysql官网下载安装教程有好多人经常问我有没有mysql的安装包,很是无语,因为问的很多 ,所以今天就写一个教程。 双击下载的安装包,会打开安装提示,然后点击next,选择你要,如下图所示,可以选择很多,但是都是些小。 假如说5.5到5.7是不行的,但是你要继续更,到后会让你安装5.7的,但是又不能跳过,所以这块也是一直下一步。? 到这里重点就来了,如果你只是想更,已经达到你的木的,你就可以关闭安装程序了。如果你想卸载就,就remove;图片中我就是安装了两个,如果想保留旧,并且安装,就点击add。? 选择*64的,然后用箭头转移到右边,然后一直下一步,就会安装

    74830

    mysql官网下载安装教程

    mysql官网下载安装教程##有好多人经常问我有没有mysql的安装包,很是无语,因为问的很多 ,所以今天就写一个教程。 双击下载的安装包,会打开安装提示,然后点击next,选择你要,如下图所示,可以选择很多,但是都是些小。 假如说5.5到5.7是不行的,但是你要继续更,到后会让你安装5.7的,但是又不能跳过,所以这块也是一直下一步。? 如果你想卸载就,就remove;图片中我就是安装了两个,如果想保留旧,并且安装,就点击add。? 这里写图片描述选择*64的,然后用箭头转移到右边,然后一直下一步,就会安装

    47050

    云原生|Kubernetes 集群指南

    的 Kubernetes 有着更为先进的特性、更加全面的安全加固和漏洞修复。前一段时间社区刚刚完成了 1.19 的正式发布。 我们可以从以下两个方面对集群的必要性进行说明:对于 Kubernetes 集群的使用者:更的 Kubernetes 意味着更的 feature,更加全面的安全补丁,和诸多的 bugfix。 替换会逐个将旧的节点从集群中移除,并用的节点来替换,从而完成整个 Kubernetes 集群的工作。同样以将 Kubernetes 的从 1.14 到 1.16 为例。 即将 1.14 节点的 ECS A 从节点剔除,并将 1.16 节点的 ECS C 加入集群,再将 ECS B 从集群中删除,后将 ECS D 加入到集群中。 这样就完成了所有节点的轮转工作,整个集群就也就到 1.16 了。如图所示:1)优点替代通过将旧的节点替换为的节点从而完成集群

    17030

    Kubernetes 集群指南:从理论到实践

    的 Kubernetes 有着更为先进的特性、更加全面的安全加固和漏洞修复。前一段时间社区刚刚完成了 1.19 的正式发布。 我们可以从以下两个方面对集群的必要性进行说明:对于 Kubernetes 集群的使用者:更的 Kubernetes 意味着更的 feature,更加全面的安全补丁,和诸多的 bugfix。 替换会逐个将旧的节点从集群中移除,并用的节点来替换,从而完成整个 Kubernetes 集群的工作。同样以将 Kubernetes 的从 1.14 到 1.16 为例。 即将 1.14 节点的 ECS A 从节点剔除,并将 1.16 节点的 ECS C 加入集群,再将 ECS B 从集群中删除,后将 ECS D 加入到集群中。 这样就完成了所有节点的轮转工作,整个集群就也就到 1.16 了。如图所示:1)优点替代通过将旧的节点替换为的节点从而完成集群

    18041

    Kubernetes 集群指南:从理论到实践

    的 Kubernetes 有着更为先进的特性、更加全面的安全加固和漏洞修复。前一段时间社区刚刚完成了 1.19 的正式发布。 我们可以从以下两个方面对集群的必要性进行说明: 对于 Kubernetes 集群的使用者:更的 Kubernetes 意味着更的 feature,更加全面的安全补丁,和诸多的 bugfix。 替换会逐个将旧的节点从集群中移除,并用的节点来替换,从而完成整个 Kubernetes 集群的工作。同样以将 Kubernetes 的从 1.14 到 1.16 为例。 即将 1.14 节点的 ECS A 从节点剔除,并将 1.16 节点的 ECS C 加入集群,再将 ECS B 从集群中删除,后将 ECS D 加入到集群中。 这样就完成了所有节点的轮转工作,整个集群就也就到 1.16 了。如图所示:1)优点替代通过将旧的节点替换为的节点从而完成集群

    7230

    ZBLOG PHP的方法(之前备份数据)

    我们在使用开源程序的时候一定要注意的问题是,如果程序官方有,除非我们特别的需要要求定制导致无法及时的。 老蒋一般建议一定要,当然,我们需要确保当前的确实没有安全的要求,我们可以稍微晚几个,但是迟早我们是需要兼容的。 CMS的目的是为了迎合将来的功能,二来也是确保系统的优化和安全需要。 目前ZBLOG PHP 1.7还在内侧中,目前正是高的是1.6.6。所以我们需要的时候需要如何办呢?第一、备份数据这个很关键。 就这么简单,我们就可以完成ZBLOG PHP程序的文出处:老蒋部落 » ZBLOG PHP的方法(之前备份数据) | 欢迎分享

    5030

    LNMP架构应用实战——openssl

    LNMP架构应用实战——openssl 由于实际生产环境需求,需要将LNMP环境中的openssl至目前openssl-1.1.0c,这玩意还真的不是一般的麻烦,由于它与系统各种服务都有相关的联系 ,比如ssh服务等,因此,非常的繁琐,所以今天将实际生产环境中的过程写出来,供大家参考(100%生产环境) 1、整体环境系统环境# cat etcredhat-release CentOS release Vapplicationmysqlbinmysql Ver 14.14 Distrib 5.5.54, for Linux (x86_64) using EditLine wrapper 使用PHP 5.x 一直没有成功 00:00:00 php-fpm: pool www root 98308 1265 0 00:04 pts0 00:00:00 grep php6、查看phpinfo信息 没这前openssl 的是 目前官网成功 之前一直不成功就是因为php无法识别这个,phpinfo信息里仍然是旧,后面采用PHP ,才成功,不知是不是之间的兼容性问题,还是配置问题,有待考究

    19640

    linux 实现centos7在线内核

    当我们需要实现的功能内核不能提供时,这时我们就需要对内核进行更,来实现满足我们要有功能需要,下面我就演示一下在centos7中内核步骤:使用  uname -sr 查看自己内核号: # uname -srLinux 3.10.0-862.el7.x86_64然后我们在浏览器中输入 www.kernel.org,查看centos,内核为:4.18一:、安装elrepo的yum 源elrepo是CentOS十分有用的稳定的软件源,这是一个第三方仓库,可以将内核。 yum的elrepo源中有ml和lt两种内核,其中ml(mainline)为的内核,lt为长期支持的内核。 内核完毕后,不会立即生效,还需要我们修改grub.conf文件。

    1.1K20

    在centos7安装nodejs并nodejs到

    nodejs发的比较快,有些的框架需要node的,那如何。 到现在,node的是10.4.1,那么,下面介绍如何nodejs1.2 卸载 nodejs1.2.1 使用 yum 先删除一次yum remove nodejs npm -y1.2.2 手动删除残留进入 2.nodesj 2.1 安装nn是nodejs管理工具,是TJ写的,Github: https:github.comtjn$ npm install -g n2.2 安装nodejs安装 $ n latest安装指定$ n 10.5.02.3 切换nodejs$ n选择已安装的 ο node8.11.3 node10.4.1 查看当前node -v,下面表示已切换成功v8.13.3 但问题来了,切换后,查看还是原来的v6.13.3,看下面 使用n切换nodejs失效的解决办法3 切换失效的解决办法3.1 查看 node 当前安装路径$whichnodeusrlocalbinnode

    8330

    nginx-v1.10.3热更

    nginx热更实践有的时候我们需要一下编译安装的nginx的有的时候我们需要给编译安装的nginx上面添加一些扩展模块有的时候,我们只是想玩玩。。。。是的 ,这里都可以帮助你。。。 with-http_ssl_module --add-module=usrlocalsrcnginx_upstream_check_module && make && make installnginx热首先启动 root 12715840 Aug 1 11:12 nginx-rwxr-xr-x 1 root root 12715840 Aug 1 11:30 nginx_1.10.3复制nginx 1.14.2的 612Last-Modified: Thu, 01 Aug 2019 15:25:32 GMTConnection: keep-aliveETag: 5d43046c-264Accept-Ranges: bytes下线旧的 ,但是会在占用80端口,造成从启动nginx失败,因此需要先杀掉80端口的旧的进程root@cluster-node1:webservernginxsbin# .nginx -s quitroot

    4410

    CentOS 7使用elrepo源内核到

    内核需要使用 elrepo 的yum 源1、首先我们导入elrepo的key# rpm --import https:www.elrepo.orgRPM-GPG-KEY-elrepo.org2、安装 elrepo源# rpm -Uvh http:www.elrepo.orgelrepo-release-7.0-3.el7.elrepo.noarch.rpm在ELRepo源中,mainline 为的内核 3.10.0-327.36.3.el7.x86_64) 7 (Core)CentOS Linux (3.10.0-327.el7.x86_64) 7 (Core)3、修改内核启动顺序,默认启动顺序应该为1,后内核是往前面插入 ,为0# grub2-set-default 04、重启系统# reboot5、查看 内核# uname -r

    3.3K00

    在Ubuntu 20.04 上如何将Apache2

    由于通过Ubuntu 20.04 软件源安装的Apache2是2,4.41, 这个目前存在诸多的t高危安全漏洞,所以需要对Apache2。 Apache HTTP Server 2.4 漏洞列表:查询Apache2现有:apache2 -vServer version: Apache2.4.41 (Ubuntu)Server built : 2021-10-14T16:24:43添加Apace2 PPA 软件源并获取可的软件包信息:Ondřej 是Debian 上PHP 的维护者,并为Ubuntu 以及Nginx 和PHP 维护的 sudo add-apt-repository ppa:ondrejapache2 -y && sudo apt update从PPA 软件源Apache2apt upgrade apache2 - y验证Apache2后的apache2 -vServer version: Apache2.4.52 (Ubuntu)Server built: 2021-12-28T20:18:12

    8300

    的IDEA后Maven私仓挂了

    到Intellij IDEA 2021.3之后,Maven出问题了!无法从Maven私有仓库下载依赖了。提示要从maven-default-http-blocker下载,难道不应该去私仓下载吗? 原因原来IDEA更到2021.3后内置Maven的到了3.8.1。Maven3.8.1发布一个变更(CVE-2021-26291):由于使用 HTTP 的自定义存储库可能导致中间人攻击。 简单的方法就是降IDEA或者不使用内置的Maven;好的方法就是到HTTPS。如果你想维持现状就需要把setting.xml中的默认镜像(上面给出的xml标签)给删除掉。

    10510

    扫码关注云+社区

    领取腾讯云代金券