首页
学习
活动
专区
圈层
工具
发布

Linux学习笔记之Linux最小化安装启动后如何配置

在VM虚拟机中安装CentOS 7 时 有时候顾虑到电脑硬件性能,我们需要最小化安装,而最小化安装后与centos6的版本是有一些差异的,接下来我们就对刚安装好的最小化centos7做一些操作,来世我们使用的更得心应手...安装net-tools 最小化安装CentOS7后,在配置网络后,想查看我的IP,发现ifconfig 命令是不好使得。...关闭自带防火墙并启动iptables 我们就要关闭CentOS7自带的防火墙 firewall 启用 IPtable 停止 Firewall systemctl stop firewalld 关闭firewall...自动启动 systemctl disable firewalld.service 安装IPtables防火墙 yum install -y iptables-services 修改iptables配置文件...m tcp -p tcp –dport 80 -j ACCEPT -A INPUT -m state –state NEW -m tcp -p tcp –dport 3306 -j ACCEPT 修改后的

7.7K30
  • 您找到你想要的搜索结果了吗?
    是的
    没有找到

    Linux 启动流程 -- 按下电源后发生的那些事儿

    写在前面 从按下电源到Linux完全启动,发生的事情有太多太多,细节也太多太多,这里我们不会那么深入细节,但力求理清整体的脉络; 这里暂时只会介绍到 体系结构无关部分的初始化和体系结构相关部分的初始化,...这两部分具体细节我们会在以后的学习中继续分析; 这里的分析基于 Linux 5.4.2 x86_64; 如果你希望看到很详细的源码解析,那可能会让你失望了,这里还是以流程为主,能给你的可能只是下面这张图而已...; 启动流程图 ?...linux启动流程.png 要点说明 模式转换 我们这里以x86_64体系结构为例来分析,从按下电源后经过了 16 位实模式 ----> 32位下的保护模式 ----> 64位下的长模式才将算最终完成启动...,长模式,概念我们很容易在网上查到,这里不再赘述;在上图中这几种模式扫从上到下用向右的长箭头作了分隔并用浅蓝色字体作了标注; 伴随着模式转换,执行控制权也有发生转换,从 BIOS 到 引导程序 再到 Linux

    1.3K20

    解决Xilinx ZCU106 Linux启动后没有响应问题。

    工作中,一直使用ZCU106,Linux都启动正常。今天同事拆开DDR保护金属外壳,看了DIMM条。 之后第一次启动Linux,登陆系统后,Linux不再有响应。...后续启动Linux,有时在打印分配网络地址信息后,Linux不再有响应;有时打印emmc的错误信息后,,Linux不再有响应。后来更是没法从SD卡启动。...======================================= ``` 在SDK里创建一个FSBL, 在文件的开始处添加“#define FSBL_DEBUG_DETAILED”,编译后运行...Initialization failed 0x6 ================= In Stage Err ============ Fsbl Error Status: 0x0 ``` FSBL检查到启动模式是...原来的启动模式是SD1, 对应值是1110。比较发现,启动模式的第四位发生了改变。重新设置拨码开关为SD1,也就是把sw6.4设置为off,再启动Linux,登陆系统后,Linux工作正常。

    2.6K20

    GreatSQL登陆Arch Linux之旅

    这是因为 Linux 所谓的“内核”包含有大量的动态加载模块,如果在某次启动后,某个模块没有被加载过,然后系统内核更新了并且删除了旧的内核,那么这些模块将永远不能被加载了——因为它们随着旧内核被删掉了。...innodb_print_ddl_logs = 0 innodb_status_file = 1 #注意: 开启 innodb_status_output & innodb_status_output_locks 后,...-p /data/GreatSQL $ chown -R mysql:mysql /data/GreatSQL $ chmod -R 700 /data/GreatSQL 如果是在一个全新环境中首次启动...:$PATH' >> ~/.bash_profile $ source ~/.bash_profile 执行下面的命令启动GreatSQL服务 $ systemctl start greatsql $...$ mysql -uroot -p Enter password: # 进入数据库后可以看到版本 Server version: 8.0.32-24 首次登入立刻提醒该密码已过期,需要修改,执行类似下面的命令修改即可

    3K10

    Linux登陆失败处理功能

    Linux登陆失败处理功能 本文要实现的功能:如果有人恶意尝试破解你的服务器密码,那么这个功能就能帮你起到一定的作用,当尝试密码错误超过设定的次数后,就会锁定该账户多长时间(自行设定),时间过后即可自行解锁...以上策略表示:普通帐户和 root 的帐户登录连续 3 次失败,就统一锁定 40 秒, 40 秒后可以解锁。...注意: 用户锁定期间,无论在输入正确还是错误的密码,都将视为错误密码,并以最后一次登录为锁定起始时间,若果用户解锁后输入密码的第一次依然为错误密码,则再次重新锁定。...查看日志 tail -f /var/log/secure 可以看出下面的提示 4.登录失败处理功能策略(ssh远程连接登录) 上面只是限制了从终端登陆,如果想限制ssh远程的话, 要改的是 /etc/

    7.8K20
    领券