要连接远程的oracle数据库,首先要安装oracle数据库(我的是企业版),plsql。...用记事本方式打开,添加以下: DB_TEST = (DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (PROTOCOL = TCP)(HOST = 远程数据库...) (CONNECT_DATA = (SERVER = DEDICATED) (SERVICE_NAME = 实例名) ) ) host后面跟的是远程数据库的...IP地址,实例名可以自拟,即plsql登录界面的数据名。...2.tnsnames.ora文件最后参照,或者从远程数据库的目标文件夹复制过来,然后再改动。 3.通过远程数据库方给的用户名和密码登录。 总结: 1.需要别人给的IP,用户名,密码。
选择数据库 use mysql; ---- 数据库连接 如果你想允许用户demo从ip为192.168.1.1的主机连接到mysql服务器,并使用888888作为密码 GRANT ALL PRIVILEGES
IP:172.16.230.200 在实际的工程或项目开发中,如果数据库服务器被放置在机房或机房的机柜中,开发或工程人员只能通过网络远程连接数据库进行操作时就需要用到我下面介绍的内容了。...1、客户端远程连接数据库需要先安装mysql的客户端工具,mysql的客户端工具网上有很多,大家可以百度一下。...4、客户端使用用户名和密码尝试通过网络远程连接数据库 C:\mysql5628\bin>mysql -h 172.16.230.15 -u root -p Enter password: ******...(2)为其他主机远程连接数据库开放访问权限,重新登入数据库: MariaDB [(none)]> use mysql; //选择mysql数据库进行操作 Reading table information...只有这些仍然不够,我们只是开启了MySQL监听远程连接的选项,接下来需要给对应的MySQL账户分配权限,允许使用该账户远程连接到MySQL 输入 select User, host from mysql.user
Mysql安装后,默认不能外网直接访问的,只能本机访问,但是很多用户需要外网访问来备份数据、修改数据或者调用数据,mysql如何开启远程连接呢?下面就是MySQL数据库开启远程连接方法。...登陆mysql操作命令如下直接复制即可 1.下面的命令是给予任何主机访问数据的权限 mysql> use mysql; MySQL>update user set host = '%' where user...= 'root'; MySQL>select host, user from user; MySQL>GRANT ALL PRIVILEGES ON *.* TO 'root'@'%' IDENTIFIED...BY '数据库的密码' WITH GRANT OPTION; 2、修改生效 MySQL>FLUSH PRIVILEGES; 3、退出MySQL服务器 MySQL>EXIT; 【以上内容湘南科技提供
PL/SQL Developer是一个集成开发环境,专门开发面向Oracle数据库的应用。PL/SQL也是一种程序语言,叫做过程化SQL语言(Procedural Language/SQL)。...PL/SQL是Oracle数据库对SQL语句的扩展。..._12_1目录下新建目录network,在network目录下再新建admin目录,在admin目录下新建文件tnsnames.ora, 使用文本编辑器打开写入如下内容: **连接名** = (DESCRIPTION...192.168.0.132** )(PORT = 1521)) ) (CONNECT_DATA = (SERVICE_NAME = **ORCL** ) ) ) 第一个**字块:表示定义远程服务器的在本地主机名...(随意输入) 第二个**字块:远程数据库的IP地址 第三个**子块:远程数据库实例名 4)右击我的电脑选”属性”->“高级”->“环境变量”->”系统变量” 新增下面两个变量 TNS_ADMIN
一、连接远程服务器上的数据库 需要在服务器上安装服务端数据库 本机上安装数据库的客户端及plsql 修改oraname.ora 二、连接本地计算机上的数据库 在本地计算机安装数据库的服务端和客户端
一、如何新建独立帐号并设置权限 这里我使用Navicat作为我的数据库管理工具,打开Navicat。...选择“用户”--“新建用户” 输入用户名、主机、密码,需要注意的是,主机那不是写“localhost”,而是写“%” 然后可以设置“服务器权限” 和指定数据库的权限,最后保存退出即可 二、远程连接慢... 慢是一个很大的问题,网上的办法是在my.ini的“[mysqld]”下面加入一行“skip-name-resolve”,就像这样: 然后保存并重启mysql服务即可。
image.png 安装MySQL sudo apt-get update sudo apt-get install mysql-server sudo apt-get install libmysqlclient-dev...登录 MySQL mysql -u root -p 创建用户 REATE USER 'username'@'host' IDENTIFIED BY 'password'; 进行授权用来远程连接 GRANT...: http://bbs.qcloud.com/thread-11554-1-1.html 重新启动(命令如下): /etc/init.d/mysql stop /etc/init.d/mysql start...执行 flush privileges;命令立即生效 flush privileges; 查询数据库的用户(看到如下内容表示创建新用户成功了) SELECT DISTINCT CONCAT('User...: ''',user,'''@''',host,''';') AS query FROM mysql.user; 使用exit命令退出MySQL exit
本地navcat远程连接宝塔MySQL数据库 宝塔面板在安装好mysql后 本地navicat远程连接的时候报错1045 这个问题是数据库权限问题 在宝塔面板页面找到软件商店 — 已安装 —mysql...—设置 之后点开配置修改 在mysqld里面 添加这一句 skip-grant-tables 保存 重新启动数据库 就可以了
安装完mysql后,此时只是本机访问mysql,其他的任何机器都是无法访问的,Navicat for mysql更是无法使用, 然后进行如下操作: update user set host ='%'...root'; grant all on *.* to root@'%' identified by 'root'; flush privileges; 执行以上3个命令,本以为可以用Navicat 可以连接了...,谁知报了10061错误: 经常一番资料查找,有人说: 在服务端MySQL文件夹下找到my.ini文件。...居然在这个文件中,便修改: 修改bind-address = 127.0.0.1 为 bind-address = 0.0.0.0 :wq --保存退出 之后要重启mysql...服务,很多人是这么启动的: sudo /etc/init.d/mysql restart --重启服务 但我是这么启动的: sudo service mysql restart;
一、必要条件 1、必须保证将要连接的oracle数据库监听服务开启,即1521端口处于监听状态。 2、oracle数据库已启动。...PLSQL Developer.rar ora10client.exe ps:2个软件可以通过“阅读原文”使用f46j提取码获取。...2、解压PLSQL Developer.rar压缩包。 3、安装ora10client.exe并配置数据库连接文件 (1)安装ora10client.exe软件,直接下一步就行。...工具 主要是为了关联我们前面安装的ora10client软件,能识别到我们填写的数据库连接文件。...连接上之后打开sql窗口,随便查询个表,有数据表示已经连接到数据库了。 四、可能遇到的问题 1、配置plsqldev.exe软件,仍然是空白。
PL/SQL 工具的安装可以看我的这个文章: PL/SQL 数据库连接工具的下载、安装与使用,PL/SQL 工具的激活 第一章:PL/SQL 工具配置 ① oci 下载 使用 oci 就不用安装整个 oracle...获取地址:oracle install client 官方下载 根据要远程的数据库下载版本,这个必须跟数据库位数一致,不然不能用。 select * from v$version ? ? ? ?...tnsnames.ora 文件里添加如下配置信息: 其中 [10.10.xx.xx]/orcl 就作为我远程连接数据库的一个表示,这样起名字是为了方便识别,这个名字可以随便定义。 ?...④ PL/SQL 远程连接 Oracle 数据库演示 配置完重新启动 PL/SQL 即可使用,可以看到 database 已经能参照到我们的配置数据库信息了。 ?...⑤ 连接失败配置环境变量解决问题 可以尝试配下环境,首先查下我们要连接的数据库语言。 select userenv('language') from dual; ? ? ?
MySQL开启远程连接 在Linux上面装完MySQL 或 MariaDB,远程登录报错 Host is not allowed to connect to this MySQL server,是因为没有开启远程登陆...解决方法如下: 1、在装有MySQL的机器上登录MySQL; mysql -u root -p你的密码 2、执行下面命令; use mysql; 3、执行下面命令,执行完可能会报错,不用管它。...update user set host = '%' where user = 'root'; 4、继续执行命令,来刷新MySQL的权限相关表; FLUSH PRIVILEGES; 经过上面4步,就可以解决这个问题了
一、MySQL 开启远程连接需要先在服务器上登录到 MySQL mysql -u root -p 然后 Enter password: 二、修改 root 账户的 Host 1、打开 mysql 数据库...use mysql; 2、查看 user 数据表当前已有的数据 select * from user \G; 3、修改一条 root 数据,并刷新MySQL的系统权限相关表 update user set....* to root @"%" identified by "root"; flush privileges; 三、注意事项 当出现 10038错误时 2003 - Can't content to MySQL...server on '127.0.0.1' (10038) ,需要 check 以下几点; 1、记得在服务器安全组开放对应端口 2、开放了安全组后还是连接不上,就要检查防火墙了,可以参考文章:Centos
1、查看当前哪些用户可以访问 进入mysql shell show databases; use mysql ; select host, user ,password from user...; mysql> select host, user ,password from user; ±----------±-----±---------------------------------...node01 | | | ±----------±-----±------------------------------------------+ 2、修改配置,在user表中添加所有用户可以访问本mysql...表示主机上使用的用户 123456 表示用户所使用的密码 3、刷新生效 flush privileges; 检查更新 select host, user ,password from user; mysql...、 关闭防火墙 /etc/init.d/iptables stop chkconfig iptables off(开机不自动启动 chkconfig iptables on 开机自启) 5、远程连接
前言 学习MySQL重新整理以前非MK的记载 ---- 描述 没有开启的话连接数据库报错:2003-can't connect to MYSQL ---- 方法/步骤 第一步 远程连接上Linux...系统,确保Linux系统已经安装上了MySQL数据库。...登陆数据库。...mysql -u$user -p $pwd 第二步 创建用户用来远程连接 GRANT ALL PRIVILEGES ON *.* TO '$username'@'%' IDENTIFIED BY...'$password' WITH GRANT OPTION; $username表示用户名,%表示所有的电脑都可以连接,也可以设置某个ip地址运行连接,$password表示密码 第三步 执行
Navicat 远程连接 MySQL 相信大家都有在远程服务器上进行开发吧,其中 MySQL 的使用率应该也会挺高,如果使用 Navicat 等可视化工具来操作远程数据库不失为一种很好的选择,避免了在命令行写...下面简单介绍一下 Navicat 连接远程数据库的操作。 1 首先我们需要更改 3306端口,查看3306 端口是否对外开放,MySQL 默认情况下是不开放对外访问功能的。...可以看出,mysql的3306端口只是监听本地的连接,这样就阻碍了外部IP对该数据库的访问,修改 MySQL 配置文件 my.conf : vim /etc/mysql/my.cnf 找到 # Instead...至此 MySQL 远程访问端口就成功开启了。...最后重启一下 MySQL 服务: sudo restart mysql 3 服务端设置好了,我们在 Navicat 客户端设置一下连接: 打开 Navicat,点击左上方的 "连接",设置一下数据库的用户名
mysql> GRANT ALL PRIVILEGES ON *.* TO root@"%" IDENTIFIED BY "root"; mysql> flush privileges; 第一句中”%...”表示任何主机都可以远程登录到该服务器上访问。...数据库的grant表中重新加载权限数据。...因为MySQL把权限都放在了cache中,所以在做完更改后需要重新加载 修改配置文件 配置文件只会在两者中个一个 vim /etc/mysql/mysql.conf.d/mysqld.cnf vim...-L -n --line-numbers iptables -D INPUT 5 #删除即可 重启mysql service mysql restart
1.背景 安装好 mysql 后,一般会使用客户端连接(必须Navcat)。本文描述了怎么设置远程连接。...image.png 注意:这里的 root 账户的 host 的值是 localhost 开始修改,执行: mysql> use mysql; mysql> update user set host...image.png 注意:这里的 root 账户的 host 的值变成了 % % 这个百分号表示的意思是任意机器都可以连接,也可以缓存你机器的固定ip。...端口 firewall-cmd --zone=public --add-port=3306/tcp --permanent # 重启防火墙 firewall-cmd --reload 高高兴兴的打开连接...; 看下修改后样子 执行 select host,user,plugin,authentication_string from mysql.user; ?
use mysql;进入mysql库 grant all privileges on \*.\* to root@'%'identified by 'ur passwd'; 设置允许远程连接 flush...privileges; 刷新权限 报错: 1045 , 提示连接到本地(10.122.2.5/10.122.1.77)失败 access denied