两行代码搞定CentOS环境升级PHP

最近升级WordPress的时候突然发现新世纪已然来临了

CentOS自带的5.4显然是不兼容了,那就是要往更高的版本上了?

以往可是先不兼容高版本的。。。此处应有

话不多说,老版本CentOS自带的PHP版本都是以“稳定“为主,但是具体哪个版本稳定,谁也不知道,现在不支持了,首选当然是升级一下PHP版本了。

下面以CentOS 6.5+WDCP V3.2为例,安装方法如下:

wget http://down.wdlinux.cn/in/phps.sh

sh phps.sh

(共支持7个版本的PHP,如5.2.17/5.3.29/5.4.45/5.5.38/5.6.30/7.0.18/7.1.4)

如需默认安装使用版本,可以针对或选择性安装某个版本,如安装7.018:

wget http://down.wdlinux.cn/in/phps.sh

sh phps.sh 7.0.18

收工大吉!

如果安装时出现make错误,可能是因为没有安装latex,先运行如下命令安装latex:

yum -y install texlive-latex

yum -y install texlive-metapost

yum -y install texlive-collection-fontsrecommended

然后再继续安装PHP,多半会收工大吉。

/www/wdlinux/phps/55/bin/php-fpm start

/www/wdlinux/phps/55/bin/php-fpm stop

/www/wdlinux/phps/55/bin/php-fpm restart

如是其它版本,把55替换为相应版本即可,如无特别求,可不必全部安装或启动,因为启动多一个,就会占资源多一份

已知问题

CentOS 7.X系列系统,不再支持php-5.2/5.3的老版本PHP,可考虑使用CentOS 6.X

  • 发表于:
  • 原文链接http://kuaibao.qq.com/s/20180410G1RYCH00?refer=cp_1026
  • 腾讯「云+社区」是腾讯内容开放平台帐号(企鹅号)传播渠道之一,根据《腾讯内容开放平台服务协议》转载发布内容。

扫码关注云+社区

领取腾讯云代金券