多数 Linux 发行版本受严重的权限提升漏洞影响

聚焦源代码安全,网罗国内外最新资讯!

编译:360代码卫士团队

印度安全研究员Narendra Shinde在X.Org服务器包中发现一个非常严重的漏洞,影响OpenBSD和多数Linux发行版本,包括Debian、Ubuntu、CentOS、Red Hat和Fedora。

Xorg X服务器是一款流行的开源X11系统(显示服务器)实现,为更广范围的硬件和操作系统平台提供图形环境。它是客户端和用户应用之间的中介,用于管理图形显示器。

Shinde指出,Xorg X服务器未正确地处理并验证至少两个命令行参数的参数,从而导致低权限用户能够执行恶意代码并覆写任意文件,包括权限用户如根用户所拥有的文件。

这个漏洞的编号是CVE-2018-14665,存在于X.Org服务器1.19.0数据包中,现在已存在几乎两年的时间,可遭终端上的本地攻击者利用或者通过SSH提升在目标系统上的权限。

上文提到的两个易受攻击的参数是:-modulepath和–logfile。前者用于设置目录路径以搜索Xorg服务器模块,后者用于为Xorg服务器设置新的日志文件,而不是使用位于多数平台上/var/log/Xorg.n.log中的默认日志文件。

Xorg发布安全公告表示,“当X服务器以提升后的权限运行时(即Xorg被安装setuid位组且由非根用户启动),-modulepath参数可被用于向将在X服务器中加载的模块指定不安全的路径,从而导致在权限进程中执行非权限代码。”

Red Hat发布安全公告指出,“当启动Xorg X服务器时,对–modulepath和–logfile选项的权限检查不正确,导致能够通过物理控制台登录系统的非权限用户提升权限并以根权限运行任意代码。”

安全研究员Matthew Hickey在推特上共享了PoC利用代码,表示“攻击者能够通过3行甚至更少的命令接管受影响系统。”

X.Org基金会已发布X.Org服务器版本1.20.3,修复该问题。

流行的发行版本如OpenBSD、Debian、Ubuntu、CentOS、Red Hat和Fedora已发布安全公告证实问题的存在,并且正在着手推出补丁更新。

  • 发表于:
  • 原文链接https://kuaibao.qq.com/s/20181029B109DW00?refer=cp_1026
  • 腾讯「云+社区」是腾讯内容开放平台帐号(企鹅号)传播渠道之一,根据《腾讯内容开放平台服务协议》转载发布内容。

扫码关注云+社区

领取腾讯云代金券