vue学习手册系列教程文章——vue 起步与安装

一、vue 起步

我们以 Vue 数据绑定的快速导览开始。

尝试 Vue.js 最简单的方法是使用 JSFiddle Hello World 例子(https://jsfiddle.net/yyx990803/okv0rgrk/)。在浏览器新标签页中打开它,跟着我们查看一些基础示例。

Hello World

{% raw %}

{{ message }}

{% endraw %}

双向绑定

{% raw %}

{{ message }}

{% endraw %}

渲染列表

{% raw %}

{{ todo.text }}

{% endraw %}

处理用户输入

{% raw %}

{{ message }}

Reverse Message

{% endraw %}

综合

{% raw %}

{{ todo.text }} X

{% endraw %}

希望上例能让你对 Vue.js 的工作原理有一个基础概念。我知道你现在有许多疑问——继续阅读,在后面的教程将一一解答。

二、vue 安装

兼容性提示:Vue.js 不支持 IE8 及其以下版本。

独立版本

直接下载并用 标签引入, 会被注册为一个全局变量。重要提示:在开发时请用开发版本,遇到常见错误它会给出友好的警告。

开发版本包含完整的警告和调试模式生产版本删除了警告,{}kb min+gzip

CDN

可以从 jsdelivr 或 cdnjs 获取(版本更新可能略滞后)。

CSP 兼容版本

有些环境,如 Google Chrome Apps,强制应用内容安全策略 (CSP) ,不能使用 对表达式求值。这时可以用 CSP 兼容版本。

NPM

在用 Vue.js 构建大型应用时推荐使用 NPM 安装,NPM 能很好地和诸如 Webpack 或 Browserify 的 CommonJS 模块打包器配合使用。Vue.js 也提供配套工具来开发单文件组件。

命令行工具

Vue.js 提供一个官方命令行工具,可用于快速搭建大型单页应用。该工具提供开箱即用的构建工具配置,带来现代化的前端开发流程。只需一分钟即可启动带热重载、保存时静态检查以及可用于生产环境的构建配置的项目:

开发版本

重要:发布到 NPM 上的 CommonJS 包 ()没有签入源码,因此要使用 GitHub 上最新的源码,自己编译:

Bower

AMD 模块加载器

独立版本或通过 Bower 安装的版本已用 UMD 包装,因此它们可以直接用作 AMD 模块。

  • 发表于:
  • 原文链接https://kuaibao.qq.com/s/20181104B0ZJUL00?refer=cp_1026
  • 腾讯「云+社区」是腾讯内容开放平台帐号(企鹅号)传播渠道之一,根据《腾讯内容开放平台服务协议》转载发布内容。

扫码关注云+社区

领取腾讯云代金券