学习
实践
活动
专区
工具
TVP
写文章

核心交换机中链路聚合、冗余、堆叠、热备份技术介绍

一、链路聚合

链路聚合是将两个或更多数据信道结合成一个单个的信道,该信道以一个单个的更高带宽的逻辑链路出现。

链路聚合一般用来连接一个或多个带宽需求大的设备,例如连接骨干网络的服务器或服务器群。它可以用于扩展链路带宽,提供更高的连接可靠性。

1. 举例

公司有2层楼,分别运行着不同的业务,本来两个楼层的网络是分开的,但都是一家公司难免会有业务往来,这时我们就可以打通两楼之前的网络,使具有相互联系的部门之间高速通信。

如上图所示,SwitchA和SwitchB通过以太链路分别都连接VLAN10和VLAN20的网络,且SwitchA和SwitchB之间有较大的数据流量。

用户希望SwitchA和SwitchB之间能够提供较大的链路带宽来使相同VLAN间互相通信。同时用户也希望能够提供一定的冗余度,保证数据传输和链路的可靠性。

创建EtherChannel接口并加入成员接口,实现增加链路带宽,2台交换机分别配置EtherChannel1 分别将需要通信的3条线路的端口加入EtherChannel1,设置端口trunk, 允许相应的vlan通过;这样两楼的网络就可以正常通信了。

2. 实现配置步骤:

在SwitchA上创建EtherChannel1并配置为LACP模式。SwitchB配置过程与SwitchA类似,不再赘述

SwitchA

switch> enable

switch# conf t

switch(config)# hostname SwitchA

SwitchA(config)# interface range g0/0/1-3

SwitchA(config-if-range)# channel-group 1 mode active

SwitchA(config-if-range)# interface Port-channel1

SwitchA(config-if)# switchport trunk encapsulation dot1q

SwitchA(config-if)# switchport mode trunk

SwitchB

switch> enable

switch# conf t

switch(config)# hostname SwitchB

SwitchB(config)# interface range g0/0/1-3

SwitchB(config-if-range)# channel-group 1 mode active

SwitchB(config-if-range)# interface Port-channel1

SwitchB(config-if)# switchport trunk encapsulation dot1q

SwitchB(config-if)# switchport mode trunk

二、链路冗余

为了保持网络的稳定性,在多台交换机组成的网络环境中,通常都使用一些备份连接,以提高网络的效率、稳定性,这里的备份连接也称为备份链路或者冗余链路。

三、交换机的堆叠

通过专有的堆叠电缆连接起来,可将多台交换机堆叠成一台逻辑交换机。

该逻辑交换机中的所有交换机共享相同的配置信息和路由信息。当向逻辑交换机增加和减少单体交换机时不会影响其性能。

叠加的交换机之间通过两条环路连接起来。交换机的硬件负责将数据包在双环路上做负载均衡。

环路在这里充当了这个大的逻辑交换机的背板的角色,在双环路都正常工作时,数据包在这台逻辑交换机上的传输率为32Gbps。

当一个数据帧需要传输时,交换机的软件会进行计算看哪条环路更可用,然后数据帧会被送到该环路上。

如果一条堆叠电缆出故障,故障两端的交换机都会侦测到该故 障,并将受影响的环路断开,而逻辑交换机仍然可以以单环的状态工作,此时的数据包通过率为16Gbps。

交换机的堆叠采用菊花链方式,连接的方式参考下图。

堆叠增加交换机端口与带宽的稳定性。

四、热备份(HSRP)

核心交换机是整个网络的心脏,如果核心交换机发生致命性的故障,将导致本地网络的瘫痪,所造成的损失也是难以估计的。所以我们在选择核心交换机时,经常会看到有的核心交换机具有堆叠或热备份等功能。

对核心交换机采用热备份是提高网络可靠性的必然选择。在一个核心交换机完全不能工作的情况下,它的全部功能便被系统中的另一个备份路由器完全接管,直至出现问题的路由器恢复正常,这就是热备份路由协议。

实现HSRP的条件是系统中有多台核心交换机,它们组成一个“热备份组”,这个组形成一个虚拟路由器。

在任意时刻,一个组内只有一个路由器是活动的,并由它来转发数据包,如果活动路由器发生了故障,将选择一个备份路由器来替代活动路由器,但是在本网络内的主机看来,虚拟路由器没有改变。

所以主机仍然保持连接,没有受到故障的影响,这样就较好地解决了核心交换机切换的问题。

为了减少网络的数据流量,在设置完活动核心交换机和备份核心交换机之后,只有活动核心交换机和备份核心交换机定时发送HSRP报文。

如果活动核心交换机失效,备份核心交换机将接管成为活动核心交换机。如果备份核心交换机失效或者变成了活跃核心交换机,将由另外的核心交换机被选为备份核心交换机。

当某台接入层交换机到主核心交换机的线路出现故障,切换至备机,数据流走向.

接入层交换机1的数据链路切换至核心交换机B,但在切换期间接入层交换机1分丢6个数据包,如上图所示。

当服务器与核心交换机A之间主链路出现故障(如线路、网卡等),服务器主网卡切换至备用网卡上时,会丢6个数据包,但当主链路恢复以后,服务器会自动从备用网卡切换至主网卡,而这次切换时数据包不会丢失。

具体终端访问服务器的数据流走向如下图。

  • 发表于:
  • 原文链接https://kuaibao.qq.com/s/20191109A03U9M00?refer=cp_1026
  • 腾讯「腾讯云开发者社区」是腾讯内容开放平台帐号(企鹅号)传播渠道之一,根据《腾讯内容开放平台服务协议》转载发布内容。
  • 如有侵权,请联系 cloudcommunity@tencent.com 删除。

关注

腾讯云开发者公众号
10元无门槛代金券
洞察腾讯核心技术
剖析业界实践案例
腾讯云开发者公众号二维码

扫码关注腾讯云开发者

领取腾讯云代金券