Selenium+python自动化84-python3.6用PyUserInput

前言

python2上安装SendKeys库,对于不好定位的元素,用快捷键操作是极好的,那么在3.6上安装时,会报错

一、python3.6安装SendKeys报错

1.python3.6安装SendKeys是无法安装的,会报错

> pip install SendKeys

二、32位的python3.6安装PyUserInput

1.python3.6分2个版本,1个是32位的python3.6;另外一个是64位的python3.6.

- 如果你的电脑是32位的,装python3.6 32位版本,直接用pip安装是没问题的

- 如果你的电脑是64位的,装python3.6 32位版本,也是没问题的

> pip install PyUserInput

三、64位的python3.6安装PyUserInput

1.如果你的电脑是64位的,装python3.6 64位版本,那么问题就来了

2.报错:No matching distribution found for pyHook (from PyUserInput)

四、pyHook安装

1.pyHook下载地址:[https://www.lfd.uci.edu/~gohlke/pythonlibs/#lxml](https://www.lfd.uci.edu/~gohlke/pythonlibs/#lxml)

2.下载到本地后,用pip安装

> pip install pyHook的本地路径

3.安装完pyHook后,继续安装PyUserInput时候,会报错:No matching distribution found for pywin32 (from PyUserInput)

五、pywin32

1.pywin32下载地址:[https://www.lfd.uci.edu/~gohlke/pythonlibs/#lxml](https://www.lfd.uci.edu/~gohlke/pythonlibs/#lxml)

2.下载到本地后,安装

> pip install pywin32的本地路径

六、 导入PyMouse报错

1.环境安装完了,你以为没事了,那就是too young了,接下来导入模块后直接运行,报错:ImportError: DLL load failed: 找不到指定的模块。

2.问题原因:pywin32-221版本太高了,换成pywin32-220

pywin32-220下载地址:https://sourceforge.net/projects/pywin32/files/pywin32/Build%20220/

3.解决办法:先卸载pywin32: pip uninstall pywin32

4.再重新安装pywin32-220版本,接下来再运行就OK了

  • 发表于:
  • 原文链接:http://kuaibao.qq.com/s/20171216G07YP800?refer=cp_1026

扫码关注云+社区