前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >ZOJ Problem Set - 2100

ZOJ Problem Set - 2100

作者头像
用户1161731
发布2018-01-11 12:08:08
3850
发布2018-01-11 12:08:08
举报
文章被收录于专栏:木宛城主木宛城主

ZOJ Problem Set - 2100

SeedingTime Limit: 1 Second      Memory Limit: 32768 KBIt is spring time and farmers have to plant seeds in the field. Tom has a nice field, which is a rectangle with n * m squares. There are big stones in some of the squares.

Tom has a seeding-machine. At the beginning, the machine lies in the top left corner of the field. After the machine finishes one square, Tom drives it into an adjacent square, and continues seeding. In order to protect the machine, Tom will not drive it into a square that contains stones. It is not allowed to drive the machine into a square that been seeded before, either.

Tom wants to seed all the squares that do not contain stones. Is it possible?

Input

The first line of each test case contains two integers n and m that denote the size of the field. (1 < n, m < 7) The next n lines give the field, each of which contains m characters. 'S' is a square with stones, and '.' is a square without stones.

Input is terminated with two 0's. This case is not to be processed.

Output

For each test case, print "YES" if Tom can make it, or "NO" otherwise.

Sample Input

4 4 .S.. .S.. .... .... 4 4 .... ...S .... ...S 0 0

Sample Output

YES NO

=============

典型的DFS题,很不错。

题目很简单,从左上角出发,判断是否能完全把地耕玩(拖拉机不能在石块和已经耕好的地上行驶。)

代码语言:javascript
复制
#include <stdio.h>
#include <string.h>
int dir[4][2]={{1,0},{0,1},{-1,0},{0,-1}};//四个方向 
char map[10][10];//定义一张地图 
int done;
int Flag;
int n,m;
void dfs(int x,int y) 
{
  int i;
  if(x<1 || y<1 || x>n || y>m)   return;//判断是否越界  
  done++; 
  if(done==n*m)//如果成功则返回 
  {
     Flag=1;
     return;
  }
  for(i=0;i<4;i++)
  {
     if(map[x+dir[i][0]][y+dir[i][1]]=='.')
     {
	 
	     map[x+dir[i][0]][y+dir[i][1]]='S';//标记已经耕过的土地 
	     dfs(x+dir[i][0],y+dir[i][1]);
	 }
  }
  done--;
  map[x][y]='.';
}
int main()
{
   int i,j;  
   memset(map,'S',sizeof(map));
   while(scanf("%d%d%*c",&n,&m)!=EOF)
   {
      if(n==0 && m==0)
      break;
      done=0;
      Flag=0;
      for(i=1;i<=n;i++)
      {
	     
		 for(j=1;j<=m;j++)
	     {
		    scanf("%c",&map[i][j]);
		    if(map[i][j]=='S')
		    done++;
		 }
		 getchar();
	  
	  }
	 	 
	  map[1][1]='S';
	  dfs(1,1);
	  if(Flag==1)
	  printf("YES\n");
	  else
	  printf("NO\n");
   }
    return 0;

}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2011-05-10 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档