前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >06-图2 Saving James Bond - Easy Version

06-图2 Saving James Bond - Easy Version

作者头像
llhthinker
发布2018-01-24 16:36:11
5960
发布2018-01-24 16:36:11
举报
文章被收录于专栏:机器学习与自然语言处理

题目来源:http://pta.patest.cn/pta/test/18/exam/4/question/625

This time let us consider the situation in the movie "Live and Let Die" in which James Bond, the world's most famous spy, was captured by a group of drug dealers. He was sent to a small piece of land at the center of a lake filled with crocodiles. There he performed the most daring action to escape -- he jumped onto the head of the nearest crocodile! Before the animal realized what was happening, James jumped again onto the next big head... Finally he reached the bank before the last crocodile could bite him (actually the stunt man was caught by the big mouth and barely escaped with his extra thick boot).

Assume that the lake is a 100 by 100 square one. Assume that the center of the lake is at (0,0) and the northeast corner at (50,50). The central island is a disk centered at (0,0) with the diameter of 15. A number of crocodiles are in the lake at various positions. Given the coordinates of each crocodile and the distance that James could jump, you must tell him whether or not he can escape.

Input Specification:

Each input file contains one test case. Each case starts with a line containing two positive integers N (≤100), the number of crocodiles, and D, the maximum distance that James could jump. Then N lines follow, each containing the (x,y) location of a crocodile. Note that no two crocodiles are staying at the same position.

Output Specification:

For each test case, print in a line "Yes" if James can escape, or "No" if not.

Sample Input 1:

代码语言:javascript
复制
14 20
25 -15
-25 28
8 49
29 15
-35 -2
5 28
27 -29
-8 -28
-20 -35
-25 -20
-13 29
-30 15
-35 40
12 12

Sample Output 1:

代码语言:javascript
复制
Yes

Sample Input 2:

代码语言:javascript
复制
4 13
-12 12
12 12
-12 -12
12 -12

Sample Output 2:

代码语言:javascript
复制
No
代码语言:javascript
复制
/*
能够跳上的鳄鱼相当于相邻的点,第一步比较特殊单独处理
每次DFS代表一种拯救方案,只要存在一种方案即可获救
*/
#include <cstdio>
#include <cmath>
#include <cstdlib>

const double ISLAND_RADIUS = 15.0 / 2;      //孤岛半径
const double SQUARE_SIZE = 100.0;           //湖(正方形)的大小
const int N = 110;                          //鳄鱼(点)的最大数

typedef struct Point
{
    double x, y;
} Position;

Position P[N];
bool Visited[N];
int n;
double d;

void Save007();
bool DFS(int V);
bool FirstJump(int V);
bool Jump(int V1, int V2);
bool IsSave(int V);

int main()
{
    scanf("%d%lf", &n, &d);
    for (int i = 0; i < n; i++)
        scanf("%lf%lf", &(P[i].x), &(P[i].y));

    for (int i = 0; i < n; i++)
        Visited[i] = false;
    Save007();

    return 0;
}

void Save007()
{
    bool IsSave = false;
    for (int i = 0; i < n; i++)
    {
        if (!Visited[i] && FirstJump(i))
        {
            IsSave = DFS(i);
            if (IsSave)
                break;
        }
    }
    if (IsSave)
        printf("Yes\n");
    else
        printf("No\n");
}

bool DFS(int V)
{
    Visited[V] = true;
    bool answer = false;
    if (IsSave(V))
        return true;
    for (int i = 0; i < n; i++)
    {
        if (!Visited[i] && Jump(V, i))
            answer = DFS(i);
        if (answer)
            break;
    }
    return answer;
}

bool IsSave(int V)
{
    return (abs(P[V].x) >= 50 - d)
            || (abs(P[V].y) >= 50 - d);
}

bool FirstJump(int V)
{
    return sqrt(P[V].x * P[V].x + P[V].y * P[V].y)
            <= d + ISLAND_RADIUS;
}

bool Jump(int V1, int V2)
{
    return sqrt((P[V1].x - P[V2].x) * (P[V1].x - P[V2].x) +
                (P[V1].y - P[V2].y) * (P[V1].y - P[V2].y))
            <= d;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2015-09-28 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Input Specification:
  • Output Specification:
  • Sample Input 1:
  • Sample Output 1:
  • Sample Input 2:
  • Sample Output 2:
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档