前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDUOJ---Can you solve this equation?

HDUOJ---Can you solve this equation?

作者头像
Gxjun
发布2018-03-21 11:43:09
6220
发布2018-03-21 11:43:09
举报
文章被收录于专栏:ml

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 5667    Accepted Submission(s): 2681 http://acm.hdu.edu.cn/showproblem.php?pid=2199

Problem Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100; Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2 100 -4

Sample Output

1.6152 No solution!

Author

Redow

Recommend

lcy

二分搜索

代码:

代码语言:javascript
复制
#include<iostream>
#include<cstdio>
#define sum(x) ((8*x*x*x*x)+(7*x*x*x)+(2*x*x)+(3*x)+(6))
using namespace std;
int main()
{
    int t;
    double y,mid,left,right;
    cin>>t;
    while(t--)
    {
     scanf("%lf",&y);
     left=0.0,right=100.0;
     if(y>=6.0&&y<=sum(100))
     {
      while(right-left>1e-8)
      {
         mid=(left+right)/2.0;
             if(sum(mid)-y>1e-8)
             right=mid;
         else
             if(y-sum(mid)>1e-8)
                 left=mid;
             else 
                 break;
      } 
         printf("%.4lf\n",mid);
     }
     else
         puts("No solution!");
    }
    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2013-08-10 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Can you solve this equation?
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档