前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >hdu---(1325)Is It A Tree?(并查集)

hdu---(1325)Is It A Tree?(并查集)

作者头像
Gxjun
发布2018-03-26 14:46:55
7930
发布2018-03-26 14:46:55
举报
文章被收录于专栏:mlml

Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 14525    Accepted Submission(s): 3232

Problem Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. There is exactly one node, called the root, to which no directed edges point. Every node except the root has exactly one edge pointing to it. There is a unique sequence of directed edges from the root to each node. For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1

Sample Output

Case 1 is a tree. Case 2 is a tree. Case 3 is not a tree.

Source

North Central North America 1997

判断一棵树:  (1)无环 ,(2)入度为0点有且仅有一个,其余点入度仅为1。(3)n个节点,必然有n-1条边

提供的一些数据:

代码语言:javascript
复制
/*
6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0

1 2 3 2 4 2 5 2 0 0
1 2 3 4  4 3 0 0
0 0 
1 1 0 0
1 2 2 1 0 0
1 2 2 3 3 4 4 1 0 0
1 2 2 3 3 1 5 6 0 0
2 3 0 0
-1 -1
*/

答案:

代码语言:javascript
复制
/*
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.
Case 4 is not a tree.
Case 5 is not a tree.
Case 6 is a tree.
Case 7 is not a tree.
Case 8 is not a tree.
Case 9 is not a tree.
Case 10 is not a tree.
Case 11 is a tree.

*/

代码:

代码语言:javascript
复制
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
bool hasp[10000];
struct node{
  int father,rank;
};
node root[10000];
void init(){
  int i;
  root[0].rank=0;
  root[0].father=0;
  for(i=1;i<10000;i++){
      root[i].father=i;
      root[i].rank=1;
  }
}
int find(int a){
    while(a!=root[a].father)
         a=root[a].father;
    return a;
}
void Union(int a,int b){
    /*a->b*/
    root[b].father=a;
    root[a].rank+=root[b].rank;
}
int main(){
    freopen("test.in","r",stdin);
    //system("call test.in");
    int a,b,cnt,x,y,cas=1,tem;
    bool flag;
    while(1){
          flag=false;   //初始化为无环
      memset(hasp,0,sizeof(hasp));
      tem=cnt=0;
      init();
      while(scanf("%d%d",&a,&b)&&(a+b!=0)){
        if(a+b<0) return 0;
        if(!flag)
        {
          x=find(a);
          y=find(b);
         if(x==y) flag=1;
         else Union(a,b);
        if(tem==0) tem=a;
       if(!hasp[a]) hasp[a]=1 , cnt++ ;
       if(!hasp[b]) hasp[b]=1 , cnt++ ;
        }
    }
     /* cnt记录了点的个数 */
     if(root[find(tem)].rank==cnt&&!flag)
        printf("Case %d is a tree.\n",cas++);
     else
        printf("Case %d is not a tree.\n",cas++);
    }
  return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2014-09-03 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Is It A Tree?
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档